treewide: kernel: bump some targets to 4.19
authorPetr Štetiar <ynezz@true.cz>
Thu, 13 Jun 2019 11:48:27 +0000 (13:48 +0200)
committerPetr Štetiar <ynezz@true.cz>
Tue, 18 Jun 2019 14:08:55 +0000 (16:08 +0200)
Lets bump kernel to 4.19 on targets which were run tested or got ACKed
so we've enough time to make it ready for next release:

 armvirt/32 (runtested in qemu)
 armvirt/64 (runtested in qemu)
 ath79/generic (runtested on Carambola2)
 gemini/generic (runtested on DIR-685, DNS-313, SQ201, SL93512R)
 imx6/generic (runtested on Apalis)
 ipq40xx/generic (runtested on nbg6617)
 malta/be64 (runtested in qemu)
 malta/be (runtested in qemu)
 malta/le (runtested in qemu)
 malta/le64 (runtested in qemu)
 mpc85xx/generic (runtested on TL-WDR4900)
 mpc85xx/p2020 (runtested on P2020RDB)
 mvebu/cortexa53
 mvebu/cortexa72
 mvebu/cortexa10
 octeon/generic (runtested on EdgeRouter Lite)
 sunxi/cortexa53 (build tested only)
 sunxi/cortexa7 (runtested on Lime2-K)
 sunxi/cortexa8 (build tested only)
 tegra/generic
 x86/64 (runtested in qemu)

Acked-by: Zoltan HERPAI <wigyori@uid0.hu> [sunxi]
Tested-by: Linus Walleij <linus.walleij@linaro.org> [gemini]
Tested-by: Tomasz Maciej Nowak <tomek_n@o2.pl> [mvebu, tegra]
Tested-by: Daniel Engberg <daniel.engberg.lists@pyret.net> [octeon]
Tested-by: Pawel Dembicki <paweldembicki@gmail.com> [mpc85xx/generic mpc85xx/p2020]
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Signed-off-by: Petr Štetiar <ynezz@true.cz>
12 files changed:
target/linux/armvirt/Makefile
target/linux/ath79/Makefile
target/linux/gemini/Makefile
target/linux/imx6/Makefile
target/linux/ipq40xx/Makefile
target/linux/malta/Makefile
target/linux/mpc85xx/Makefile
target/linux/mvebu/Makefile
target/linux/octeon/Makefile
target/linux/sunxi/Makefile
target/linux/tegra/Makefile
target/linux/x86/Makefile

index 107f8607c33b8911a1411e205890395ebf8b5cc2..9a67ab66a4ab3b7ae0ffdb0ed459458481516872 100644 (file)
@@ -13,7 +13,7 @@ FEATURES+=cpiogz ext4 ramdisk squashfs targz
 MAINTAINER:=Florian Fainelli <f.fainelli@gmail.com>, \
        Yousong Zhou <yszhou4tech@gmail.com>
 
-KERNEL_PATCHVER:=4.14
+KERNEL_PATCHVER:=4.19
 
 include $(INCLUDE_DIR)/target.mk
 
index 0ccc0bed1ce05f7c5a71c8251850742f4216bbcc..cfdf8c87e5317aa5354f06c76cfaa31cded124a5 100644 (file)
@@ -8,8 +8,7 @@ SUBTARGETS:=generic nand tiny
 
 FEATURES:=ramdisk
 
-KERNEL_PATCHVER:=4.14
-KERNEL_TESTING_PATCHVER := 4.19
+KERNEL_PATCHVER:=4.19
 
 include $(INCLUDE_DIR)/target.mk
 
index 867e284714a995be38143ce32eac0775dc046643..3afc6430231f93e5292ffec0726a83e7b1676390 100644 (file)
@@ -13,8 +13,7 @@ FEATURES:=squashfs pci rtc usb dt gpio display ext4 rootfs-part boot-part
 CPU_TYPE:=fa526
 MAINTAINER:=Roman Yeryomin <roman@advem.lv>
 
-KERNEL_PATCHVER:=4.14
-KERNEL_TESTING_PATCHVER := 4.19
+KERNEL_PATCHVER:=4.19
 
 define Target/Description
        Build firmware images for the StorLink/Cortina Gemini CS351x ARM FA526 CPU
index 457e767c05a5e35a5e7188dbb50249671e91d961..ac4300f7ebe97833aadcb7638f22733fdb7493d1 100644 (file)
@@ -14,8 +14,7 @@ CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=neon
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-KERNEL_PATCHVER:=4.14
-KERNEL_TESTING_PATCHVER := 4.19
+KERNEL_PATCHVER:=4.19
 
 include $(INCLUDE_DIR)/target.mk
 
index 2785b73ed1583fa8cab13c1e072012c23b72392a..9b78d1f1bfc5c6145e584ee988cad6bf8296175b 100644 (file)
@@ -8,15 +8,13 @@ CPU_TYPE:=cortex-a7
 CPU_SUBTYPE:=neon-vfpv4
 MAINTAINER:=John Crispin <john@phrozen.org>
 
-# TODO: drop kmod-usb-dwc3-of-simple when migrating to 4.19
-KERNEL_PATCHVER:=4.14
-KERNEL_TESTING_PATCHVER := 4.19
+KERNEL_PATCHVER:=4.19
 
 KERNELNAME:=zImage Image dtbs
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += \
-       kmod-usb-dwc3-of-simple \
+       kmod-usb-dwc3-qcom \
        kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
        kmod-ath10k-ct wpad-basic \
        kmod-usb3 kmod-usb-dwc3 ath10k-firmware-qca4019-ct
index c71f34d10999455805fd1ab9fc173a02b8a61d33..435c1b656861cf1683e01e1bd61789b46f267a5d 100644 (file)
@@ -14,7 +14,7 @@ INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 FEATURES:=ramdisk
 
-KERNEL_PATCHVER:=4.14
+KERNEL_PATCHVER:=4.19
 
 include $(INCLUDE_DIR)/target.mk
 
index 9db478d87b99a978cbba459ef4edd8dc5a753b10..8c407fd30cb6f75bbb7b2d6c73c96124e8367108 100644 (file)
@@ -14,8 +14,7 @@ FEATURES:=squashfs ramdisk
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS:=generic p1020 p2020
 
-KERNEL_PATCHVER:=4.14
-KERNEL_TESTING_PATCHVER := 4.19
+KERNEL_PATCHVER:=4.19
 
 KERNELNAME:=zImage
 
index f39573c0029ae1f6d1693fd1265f44429d8f097e..1688065a5cefb6f8ad75d0a57bbbed0b918fbe8c 100644 (file)
@@ -12,8 +12,7 @@ FEATURES:=fpu usb pci pcie gpio nand squashfs ramdisk boot-part rootfs-part
 SUBTARGETS:=cortexa9 cortexa53 cortexa72
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-KERNEL_PATCHVER:=4.14
-KERNEL_TESTING_PATCHVER:=4.19
+KERNEL_PATCHVER:=4.19
 
 include $(INCLUDE_DIR)/target.mk
 
index 202ed39be7376e50e014784b12976c717d60cff3..aa73b0e5c044fedfa4208bae6a7097f0315cecce 100644 (file)
@@ -13,8 +13,7 @@ FEATURES:=squashfs ramdisk pci usb
 CPU_TYPE:=octeonplus
 MAINTAINER:=John Crispin <john@phrozen.org>
 
-KERNEL_PATCHVER:=4.14
-KERNEL_TESTING_PATCHVER := 4.19
+KERNEL_PATCHVER:=4.19
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.
index aae7df1b443d3a84d99d91a3d3c653e1799f0ce4..cd1bf30e84f902589cc46c2773dfd59b447e3d0e 100644 (file)
@@ -14,8 +14,7 @@ FEATURES:=fpu usb ext4 display rtc squashfs
 SUBTARGETS:=cortexa8 cortexa7 cortexa53
 MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
 
-KERNEL_PATCHVER:=4.14
-KERNEL_TESTING_PATCHVER := 4.19
+KERNEL_PATCHVER:=4.19
 KERNELNAME:=zImage dtbs
 
 # A10: Cortex-A8
index 8a611e29abb4814ce7ed4d55b46b7afab2b74c85..db58bf53d1ff8c37bd59bbf6a20ac16fb8258b62 100644 (file)
@@ -14,8 +14,7 @@ CPU_TYPE := cortex-a9
 CPU_SUBTYPE := vfpv3
 MAINTAINER := Tomasz Maciej Nowak <tomek_n@o2.pl>
 
-KERNEL_PATCHVER := 4.14
-KERNEL_TESTING_PATCHVER := 4.19
+KERNEL_PATCHVER := 4.19
 
 include $(INCLUDE_DIR)/target.mk
 
index 509ccb47a2a677fbdd2ac46da81a0641337435a8..caa2e0b07af4743810004a75f476c4423b3c6cfa 100644 (file)
@@ -13,8 +13,7 @@ FEATURES:=squashfs ext4 vdi vmdk pcmcia targz fpu
 SUBTARGETS:=generic legacy geode 64
 MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
-KERNEL_PATCHVER:=4.14
-KERNEL_TESTING_PATCHVER:=4.19
+KERNEL_PATCHVER:=4.19
 
 KERNELNAME:=bzImage