iwinfo: update to latest Git HEAD
authorChristian Marangi <ansuelsmth@gmail.com>
Sat, 21 Jan 2023 00:23:22 +0000 (01:23 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Sat, 21 Jan 2023 00:23:22 +0000 (01:23 +0100)
Bump ABI to 20230121 due to struct changes

f766138 cli: print the flags on the frequency list
8ee7971 lib: add IWINFO_FREQ_FLAG_NAMES
81184d2 nl80211: fix some comments
2c4ee84 nl80211: prefer non-supplicant-based devices
6194aaf nl80211: simplify iterating over phy's devices
acbf4fe nl80211: remove redundant check in nl80211_phy2ifname()
0172c97 cli: print the frequency and band on the scan list
bbe424f cli: print the band on the frequency list
afa147c nl80211: add "mhz" and "band" to iwinfo_scanlist_entry
0d5ea34 nl80211: add "band" to iwinfo_freqlist_entry
dba0f06 nl80211: add support for radiation and indoor chan restriction
7e3d7de iwinfo: reorganize iwinfo header to enum and defines
9b47b03 devices: add USB devices supported by the mt76 driver
c0fda7c utils: skip comment lines when parsing devices.txt
dbc0ee7 cli: describe USB devices as such
891acee devices: add MediaTek MT7628 card
fac0787 devices: add support for declaring compatible matched devices

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
package/network/utils/iwinfo/Makefile

index 9d562fbaf97d9a5ab34d51b4cb511904fdff9c7c..214df45070d336715d693af9530b4203f43be89d 100644 (file)
@@ -11,13 +11,13 @@ PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/iwinfo.git
-PKG_SOURCE_DATE:=2023-01-06
-PKG_SOURCE_VERSION:=c7b420a2f33c6f1034c3e2191eba0cb0374af7b6
-PKG_MIRROR_HASH:=c5d188b2c7aa0fe987ffba8330c956670047ebf5be9a217ef647549c65002cd6
+PKG_SOURCE_DATE:=2023-01-21
+PKG_SOURCE_VERSION:=f766138662cb1d62bacd1087fab597bedcf708b9
+PKG_MIRROR_HASH:=e7e45ccc7baae2c17369bdd893e67274c3e0eefbd2b2f5319ce3d1f9fdc06d4f
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 PKG_LICENSE:=GPL-2.0
 
-IWINFO_ABI_VERSION:=20210430
+IWINFO_ABI_VERSION:=20230121
 
 include $(INCLUDE_DIR)/package.mk