kernel: 5.15: fix mediatek usb module change
authorJohn Thomson <git@johnthomson.fastmail.com.au>
Mon, 28 Mar 2022 01:50:44 +0000 (11:50 +1000)
committerFelix Fietkau <nbd@nbd.name>
Mon, 28 Mar 2022 09:03:13 +0000 (11:03 +0200)
The mediatek USB kernel module xhci-mtk was restructed.
The module after kernel 5.13 is named xhci-mtk-hcd.
Link:
https://lore.kernel.org/all/0b62e21ddfacc1c2874726dd27ccab80c993f303.1615170625.git.chunfeng.yun@mediatek.com/
Linux 14295a150050 ("usb: xhci-mtk: support to build xhci-mtk-hcd.ko")

Signed-off-by: John Thomson <git@johnthomson.fastmail.com.au>
package/kernel/linux/modules/usb.mk

index c12150fc5c7bbf54378e07cabc322f6f125eaf0f..a52ba745efff9feef3de51e74295680aa46b5eb5 100644 (file)
@@ -1787,8 +1787,10 @@ define KernelPackage/usb-xhci-mtk
   DEPENDS:=+kmod-usb-xhci-hcd
   KCONFIG:=CONFIG_USB_XHCI_MTK
   HIDDEN:=1
-  FILES:=$(LINUX_DIR)/drivers/usb/host/xhci-mtk.ko
-  AUTOLOAD:=$(call AutoLoad,54,xhci-mtk,1)
+  FILES:= \
+        $(LINUX_DIR)/drivers/usb/host/xhci-mtk.ko@lt5.13 \
+        $(LINUX_DIR)/drivers/usb/host/xhci-mtk-hcd.ko@ge5.13
+  AUTOLOAD:=$(call AutoLoad,54,xhci-mtk@lt5.13 xhci-mtk-hcd@gt5.13,1)
   $(call AddDepends/usb)
 endef