build: do not use shell calls to export empty opkg control files, speeds up package...
authorFelix Fietkau <nbd@openwrt.org>
Sun, 3 Apr 2011 02:07:59 +0000 (02:07 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 3 Apr 2011 02:07:59 +0000 (02:07 +0000)
SVN-Revision: 26431

include/package-ipkg.mk

index 2360ac4d4ecb4ed16dffa6c0d3a28ccf94cebc63..9cccff261a8aa597778e8e4ddb300cf434f965d6 100644 (file)
@@ -28,8 +28,10 @@ IPKG_BUILD:= \
 IPKG_STATE_DIR:=$(TARGET_DIR)/usr/lib/opkg
 
 define BuildIPKGVariable
+ifdef Package/$(1)/$(2)
   $(call shexport,Package/$(1)/$(2))
   $(1)_COMMANDS += $(SH_FUNC) var2file "$(call shvar,Package/$(1)/$(2))" $(2);
+endif
 endef
 
 PARENL :=(