odhcp6c: read user scripts from directory
authorLeon M. George <leon@georgemail.eu>
Tue, 23 Mar 2021 10:02:36 +0000 (11:02 +0100)
committerHans Dedecker <dedeckeh@gmail.com>
Sat, 17 Apr 2021 19:15:33 +0000 (21:15 +0200)
Placeholder DHCP user scripts were added recently.

These files make package-based installations of such scripts more difficult.
Pull user callbacks from directories instead to allow packages and users to
install co-existing scripts more easily.

References:
b4f3d93b5 odhcp6c: add a odhcp6c.user placeholder script

Signed-off-by: Leon M. George <leon@georgemail.eu>
Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> [PKG_RELEASE increase]
package/network/ipv6/odhcp6c/Makefile
package/network/ipv6/odhcp6c/files/dhcpv6.script

index b3b2ea11fb1fb30d46bc401a4e7f308680b7a7e8..a4e62d04f230f9f0b37e51241b94080744a4f47b 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcp6c
-PKG_RELEASE:=17
+PKG_RELEASE:=18
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/odhcp6c.git
@@ -44,6 +44,7 @@ endef
 
 define Package/odhcp6c/conffiles
 /etc/odhcp6c.user
+/etc/odhcp6c.user.d/
 endef
 
 define Package/odhcp6c/install
@@ -52,7 +53,7 @@ define Package/odhcp6c/install
        $(INSTALL_DIR) $(1)/lib/netifd/proto
        $(INSTALL_BIN) ./files/dhcpv6.sh $(1)/lib/netifd/proto/dhcpv6.sh
        $(INSTALL_BIN) ./files/dhcpv6.script $(1)/lib/netifd/
-       $(INSTALL_DIR) $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/odhcp6c.user.d/
        $(INSTALL_CONF) ./files/odhcp6c.user $(1)/etc/
 endef
 
index 28955a358fcd9a6d4e8321e8bb04c80f37df642b..b1a99ed98681f5b232f091438236e7bff812c0c8 100755 (executable)
@@ -237,5 +237,8 @@ esac
 
 # user rules
 [ -f /etc/odhcp6c.user ] && . /etc/odhcp6c.user "$@"
+for f in /etc/odhcp6c.user.d/*; do
+  [ -f "$f" ] && (. "$f" "$@")
+done
 
 exit 0