comgt: remove obsolete iptables support code
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 26 May 2010 20:14:42 +0000 (20:14 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 26 May 2010 20:14:42 +0000 (20:14 +0000)
SVN-Revision: 21574

package/comgt/Makefile
package/comgt/files/3g.iface

index 97ce6c2b8c43880363b77d6f35ec53d7bb60c335..a7c45c558a863e4777ae2abb6d70ed61f1ac9a5a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=comgt
 PKG_VERSION:=0.32
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/comgt
index cd4e4cc5c611280525dcb5ec1aa9a894588c9733..a89f053873aaa43c6b2591d138e7bd39873b309e 100644 (file)
@@ -6,15 +6,9 @@ config_get proto "$INTERFACE" proto
        config_get iface "$INTERFACE" ifname
        case "$ACTION" in
                ifup)
-                       iptables -I LAN_ACCEPT 1 -i "$iface" -j RETURN
-                       iptables -A FORWARD -o "$iface" -j ACCEPT
-                       iptables -t nat -A POSTROUTING -o "$iface" -j MASQUERADE 
                        set_3g_led 1 1 0
                ;;
                ifdown)
-                       iptables -D LAN_ACCEPT -i "$iface" -j RETURN
-                       iptables -D FORWARD -o "$iface" -j ACCEPT
-                       iptables -t nat -D POSTROUTING -o "$iface" -j MASQUERADE 
                        set_3g_led 0 0 0
                ;;
        esac