ramips: add support for Wavlink WL-WN578A2
authorThomas Aldrian <dev.aldrian@gmail.com>
Tue, 27 Apr 2021 19:14:34 +0000 (20:14 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 27 May 2021 23:12:21 +0000 (01:12 +0200)
This commit adds support for the Wavlink WL-WN578A2 dual-band wall-plug
wireless router. This device is also sold under the name SilverCrest
SWV 733 A2.

Device Specifications:

- CPU: MediaTek MT7628AN (580MHz)
- Flash: 8MB
- RAM: 64MB
- Bootloader: U-Boot
- Ethernet: 2x 10/100 Mbps
- 2.4 GHz: 802.11b/g/n SoC
- 5 GHz: 802.11a/n/ac MT7610E
- Antennas: internal
- 4 green LEDs: WPS/Power, LAN, WAN, wifi-low, wifi-med, wifi-high
- Buttons: Reset, WPS
- Sliding mode switch: AP, repeater, client
- Small sliding power switch

Flashing instructions:

U-Boot launches TFTP client if WPS button is pressed during power-on.
Configure as follows:

- Server IP: 192.168.10.100
- Filename (rename sysupgrade file to this): firmware.bin

Flashing should not take more than a minute, device will reboot
automatically.

Signed-off-by: Thomas Aldrian <dev.aldrian@gmail.com>
target/linux/ramips/dts/mt7628an_wavlink_wl-wn578a2.dts [new file with mode: 0644]
target/linux/ramips/image/mt76x8.mk
target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
target/linux/ramips/mt76x8/base-files/etc/board.d/02_network

diff --git a/target/linux/ramips/dts/mt7628an_wavlink_wl-wn578a2.dts b/target/linux/ramips/dts/mt7628an_wavlink_wl-wn578a2.dts
new file mode 100644 (file)
index 0000000..d7238e1
--- /dev/null
@@ -0,0 +1,166 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7628an.dtsi"
+
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/gpio/gpio.h>
+
+/ {
+       compatible = "wavlink,wl-wn578a2", "mediatek,mt7628an-soc";
+       model = "Wavlink WL-WN578A2";
+
+       aliases {
+               led-boot = &led_wps;
+               led-failsafe = &led_wps;
+               led-running = &led_wps;
+               led-upgrade = &led_wps;
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio 43 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+
+               wps {
+                       label = "wps";
+                       gpios = <&gpio 38 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_WPS_BUTTON>;
+               };
+
+               ap {
+                       label = "ap";
+                       gpios = <&gpio 41 GPIO_ACTIVE_LOW>;
+                       linux,code = <BTN_0>;
+                       linux,input-type = <EV_SW>;
+               };
+
+               repeater {
+                       label = "repeater";
+                       gpios = <&gpio 42 GPIO_ACTIVE_LOW>;
+                       linux,code = <BTN_1>;
+                       linux,input-type = <EV_SW>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               wifi-high {
+                       label = "green:wifi-high";
+                       gpios = <&gpio 37 GPIO_ACTIVE_LOW>;
+               };
+
+               wifi-med {
+                       label = "green:wifi-med";
+                       gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+               };
+
+               wifi-low {
+                       label = "green:wifi-low";
+                       gpios = <&gpio 44 GPIO_ACTIVE_LOW>;
+               };
+
+               lan {
+                       label = "green:lan";
+                       gpios = <&gpio 40 GPIO_ACTIVE_LOW>;
+               };
+
+               wan {
+                       label = "green:wan";
+                       gpios = <&gpio 39 GPIO_ACTIVE_LOW>;
+               };
+
+               led_wps: wps {
+                       label = "green:wps";
+                       gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&state_default {
+       gpio {
+               groups = "i2c", "wdt", "wled_an", "p0led_an", "p1led_an",
+                       "p2led_an", "p3led_an", "p4led_an", "refclk", "gpio";
+               function = "gpio";
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie0 {
+       wifi@0,0 {
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x8000>;
+               ieee80211-freq-limit = <5000000 6000000>;
+       };
+};
+
+&spi0 {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <40000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0x30000>;
+                               read-only;
+                       };
+
+                       partition@30000 {
+                               label = "u-boot-env";
+                               reg = <0x30000 0x10000>;
+                               read-only;
+                       };
+
+                       factory: partition@40000 {
+                               label = "factory";
+                               reg = <0x40000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@50000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x50000 0x7b0000>;
+                       };
+               };
+       };
+};
+
+&wmac {
+       status = "okay";
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0x28>;
+};
+
+&esw {
+       mediatek,portmap = <0x2f>;
+};
+
+&usbphy {
+       status = "disabled";
+};
+
+&ehci {
+       status = "disabled";
+};
+
+&ohci {
+       status = "disabled";
+};
index c5a0baa1cb667632e6757f63499054cb2765dd40..3ba4d658be22e457b6086a66503b6f20c5434471 100644 (file)
@@ -734,6 +734,16 @@ define Device/wavlink_wl-wn577a2
 endef
 TARGET_DEVICES += wavlink_wl-wn577a2
 
+define Device/wavlink_wl-wn578a2
+  IMAGE_SIZE := 7872k
+  DEVICE_VENDOR := Wavlink
+  DEVICE_MODEL := WL-WN578A2
+  DEVICE_ALT0_VENDOR := SilverCrest
+  DEVICE_ALT0_MODEL := SWV 733 A2
+  DEVICE_PACKAGES := kmod-mt76x0e
+endef
+TARGET_DEVICES += wavlink_wl-wn578a2
+
 define Device/widora_neo-16m
   IMAGE_SIZE := 16064k
   DEVICE_VENDOR := Widora
index fdef158ea87f09add2c671f4da8388e4f26accd6..e2fb44c81e0a4ba9676e7b0ebf2cd0d0fccf21e0 100644 (file)
@@ -129,7 +129,8 @@ wavlink,wl-wn575a3)
        ucidef_set_led_rssi "wifi-med" "wifi-med" "green:wifi-med" "wlan1" "50" "84"
        ucidef_set_led_rssi "wifi-high" "wifi-high" "green:wifi-high" "wlan1" "85" "100"
        ;;
-wavlink,wl-wn577a2)
+wavlink,wl-wn577a2|\
+wavlink,wl-wn578a2)
        ucidef_set_led_switch "lan" "lan" "green:lan" "switch0" "0x8"
        ucidef_set_led_switch "wan" "wan" "green:wan" "switch0" "0x10"
        ;;
index 5ce44d0e9b25d94d4bd1d9ba14940d033edadb8d..d61a60591c5e6562d769420d61f5b7745d0fb1a2 100644 (file)
@@ -46,7 +46,8 @@ ramips_setup_interfaces()
                ;;
        buffalo,wcr-1166ds|\
        elecom,wrc-1167fs|\
-       wavlink,wl-wn577a2)
+       wavlink,wl-wn577a2|\
+       wavlink,wl-wn578a2)
                ucidef_add_switch "switch0" \
                        "3:lan" "4:wan" "6@eth0"
                ;;
@@ -168,7 +169,8 @@ ramips_setup_macs()
                ;;
        cudy,wr1000|\
        hilink,hlk-7688a|\
-       wavlink,wl-wn577a2)
+       wavlink,wl-wn577a2|\
+       wavlink,wl-wn578a2)
                wan_mac=$(mtd_get_mac_binary factory 0x2e)
                label_mac=$(mtd_get_mac_binary factory 0x4)
                ;;