hostapd: enable OWE for the basic-{openssl, wolfssl} variants
authorRui Salvaterra <rsalvaterra@gmail.com>
Sat, 31 Oct 2020 11:59:48 +0000 (11:59 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Sat, 31 Oct 2020 13:02:28 +0000 (13:02 +0000)
Opportunistic Wireless Encryption is needed to create/access encrypted networks
which don't require authentication.

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
package/network/services/hostapd/Makefile

index c03ec6bdc4f316ac48aa8d6fba3e1d3b9b75e532..f076eba88fb3f6d6f722a114adb568862964713e 100644 (file)
@@ -102,6 +102,9 @@ ifeq ($(SSL_VARIANT),openssl)
   DRIVER_MAKEOPTS += CONFIG_TLS=openssl CONFIG_SAE=y
   TARGET_LDFLAGS += -lcrypto -lssl
 
+  ifeq ($(LOCAL_VARIANT),basic)
+    DRIVER_MAKEOPTS += CONFIG_OWE=y
+  endif
   ifeq ($(LOCAL_VARIANT),mesh)
     DRIVER_MAKEOPTS += CONFIG_AP=y CONFIG_MESH=y
   endif
@@ -114,6 +117,9 @@ ifeq ($(SSL_VARIANT),wolfssl)
   DRIVER_MAKEOPTS += CONFIG_TLS=wolfssl CONFIG_SAE=y
   TARGET_LDFLAGS += -lwolfssl
 
+  ifeq ($(LOCAL_VARIANT),basic)
+    DRIVER_MAKEOPTS += CONFIG_OWE=y
+  endif
   ifeq ($(LOCAL_VARIANT),mesh)
     DRIVER_MAKEOPTS += CONFIG_AP=y CONFIG_MESH=y CONFIG_WPS_NFC=1
   endif