hostapd: fix key_mgmt typo
authorLeon M. George <leon@georgemail.eu>
Tue, 12 Jan 2021 08:38:02 +0000 (09:38 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 14 Jan 2021 02:54:06 +0000 (03:54 +0100)
The key_mgmt variable was mistyped when checking against "WPS", so
the if clause was never entered.

Fixes: f5753aae233f ("hostapd: add support for WPS pushbutton station")
Signed-off-by: Leon M. George <leon@georgemail.eu>
[add commit message, bump PKG_RELEASE]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
package/network/services/hostapd/Makefile
package/network/services/hostapd/files/hostapd.sh

index 53470a2c02372edff43e628fdc2acba73a6936c4..4f740951c0bb98f94bff59e7201ded64a0ae059a 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_RELEASE:=26
+PKG_RELEASE:=27
 
 PKG_SOURCE_URL:=http://w1.fi/hostap.git
 PKG_SOURCE_PROTO:=git
index d9a5332bee1872c77439e12efc4cd7d141d7d3e9..815f22db74f2bccedb8c73546b01089aac110fd7 100644 (file)
@@ -1368,7 +1368,7 @@ wpa_supplicant_add_network() {
                append network_data "mcast_rate=$mc_rate" "$N$T"
        }
 
-       if [ "$key_mgnt" = "WPS" ]; then
+       if [ "$key_mgmt" = "WPS" ]; then
                echo "wps_cred_processing=1" >> "$_config"
        else
                cat >> "$_config" <<EOF