ipq-wifi: add support for Linksys EA6350v3
authorOever González <notengobattery@gmail.com>
Thu, 24 Jan 2019 03:20:55 +0000 (21:20 -0600)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 26 Jan 2019 20:42:57 +0000 (21:42 +0100)
This commit adds support for the Linksys EA6350v3 device in the ipq-wifi
target.

Without this patch, the Linksys EA6350v3 won't be hable to have fully
functional wireless interfaces. This is not permanent: the board data has
already been sent to ath10k _at_ lists _dot_ infradead _dot_ org

Signed-off-by: Ryan Pannell <ryan@osukl.com>
Signed-off-by: Oever González <notengobattery@gmail.com>
package/firmware/ipq-wifi/Makefile
package/firmware/ipq-wifi/board-linksys_ea6350v3.bin [new file with mode: 0644]

index 4b39f970dd6aa40350bc37c56aa0d689b2bb7646..cf1ad042bfe88e739f3dd394351587964ee4235c 100644 (file)
@@ -17,7 +17,7 @@ endef
 # Please send a mail with your device-specific board files upstream.
 # You can find instructions and examples on the linux-wireless wiki:
 # <https://wireless.wiki.kernel.org/en/users/drivers/ath10k/boardfiles>
-ALLWIFIBOARDS:=engenius_eap1300
+ALLWIFIBOARDS:=engenius_eap1300 linksys_ea6350v3
 ALLWIFIPACKAGES:=$(foreach BOARD,$(ALLWIFIBOARDS),ipq-wifi-$(BOARD))
 
 define Package/ipq-wifi-default
@@ -53,5 +53,6 @@ endef
 
 #$(eval $(call generate-ipq-wifi-package,<devicename>,<filename>,<displayname>))
 $(eval $(call generate-ipq-wifi-package,engenius_eap1300,board-engenius_eap1300.bin,EnGenius EAP1300))
+$(eval $(call generate-ipq-wifi-package,linksys_ea6350v3,board-linksys_ea6350v3.bin,Linksys EA6350v3))
 
 $(foreach PACKAGE,$(ALLWIFIPACKAGES),$(eval $(call BuildPackage,$(PACKAGE))))
diff --git a/package/firmware/ipq-wifi/board-linksys_ea6350v3.bin b/package/firmware/ipq-wifi/board-linksys_ea6350v3.bin
new file mode 100644 (file)
index 0000000..aea9d20
Binary files /dev/null and b/package/firmware/ipq-wifi/board-linksys_ea6350v3.bin differ