kernel: bump 5.15 to 5.15.45
authorRui Salvaterra <rsalvaterra@gmail.com>
Mon, 6 Jun 2022 07:46:34 +0000 (08:46 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 6 Jun 2022 17:20:28 +0000 (19:20 +0200)
Patches automatically rebased.

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
include/kernel-5.15
target/linux/bcm27xx/patches-5.15/950-0163-hid-usb-Add-device-quirks-for-Freeway-Airmouse-T3-an.patch
target/linux/bcm27xx/patches-5.15/950-0470-sound-usb-add-device-quirks-for-A4Tech-FHD-1080p-web.patch
target/linux/generic/hack-5.15/251-kconfig.patch
target/linux/generic/hack-5.15/253-ksmbd-config.patch
target/linux/generic/hack-5.15/261-lib-arc4-unhide.patch
target/linux/generic/pending-5.15/530-jffs2_make_lzma_available.patch
target/linux/generic/pending-5.15/768-net-dsa-mv88e6xxx-Request-assisted-learning-on-CPU-port.patch
target/linux/ipq40xx/patches-5.15/707-net-phy-Add-Qualcom-QCA807x-driver.patch
target/linux/mediatek/patches-5.15/500-gsw-rtl8367s-mt7622-support.patch

index 6692deaf3f450f616e5ee5d93f1be91a235a990d..2abff11cbb6b938730c6f43157a9d50577b2e1c1 100644 (file)
@@ -1,2 +1,2 @@
-LINUX_VERSION-5.15 = .44
-LINUX_KERNEL_HASH-5.15.44 = 9bfabc38e56758bd0cfe22715a3f9a74cdf4a8870f3b150a03d2ffda29f832dc
+LINUX_VERSION-5.15 = .45
+LINUX_KERNEL_HASH-5.15.45 = b2390d7d977c66036ef0ceb294e408f2bdaab6dfeeb8ff4f4e0a84b71f8d8754
index aa04cf68ba6a198f9ca442a2031615f003b4a317..9774074e50a9e53b8e168feb4166cb7a8d87ece6 100644 (file)
@@ -33,7 +33,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
  #define USB_VENDOR_ID_BELKIN          0x050d
  #define USB_DEVICE_ID_FLIP_KVM                0x3201
  
-@@ -1305,6 +1308,9 @@
+@@ -1306,6 +1309,9 @@
  #define USB_VENDOR_ID_XAT     0x2505
  #define USB_DEVICE_ID_XAT_CSR 0x0220
  
index 705f05913b22a2230db83c89eaf47956214fceb2..1d2cb9a029f0273bc0781475c5d911fa41330f55 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
 
 --- a/sound/usb/quirks.c
 +++ b/sound/usb/quirks.c
-@@ -1900,6 +1900,8 @@ static const struct usb_audio_quirk_flag
+@@ -1902,6 +1902,8 @@ static const struct usb_audio_quirk_flag
                   QUIRK_FLAG_ALIGN_TRANSFER),
        DEVICE_FLG(0x1224, 0x2a25, /* Jieli Technology USB PHY 2.0 */
                   QUIRK_FLAG_GET_SAMPLE_RATE),
index 3304e9543a068cf8f4307bed8d3ff4d2a0b8af46..49c9688cf2e12c6491295fca2f9cec9b7c2f7a33 100644 (file)
@@ -92,7 +92,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
        bool
 --- a/lib/Kconfig
 +++ b/lib/Kconfig
-@@ -438,16 +438,16 @@ config BCH_CONST_T
+@@ -440,16 +440,16 @@ config BCH_CONST_T
  # Textsearch support is select'ed if needed
  #
  config TEXTSEARCH
index 89be6f6c474731b41ee65cce90a49f823791108a..20a437f5c42702beff04d2bc2260d281453da5dc 100644 (file)
@@ -11,7 +11,7 @@
          that can be interpreted by the ASN.1 stream decoder and used to
 --- a/lib/Kconfig
 +++ b/lib/Kconfig
-@@ -609,7 +609,7 @@ config LIBFDT
+@@ -611,7 +611,7 @@ config LIBFDT
        bool
  
  config OID_REGISTRY
index dfba811f31f20e6e3e7c30ed2afc7291b92228cf..4ffd8cfa37dd8e81dfa2308dcf234cd2479bdb43 100644 (file)
@@ -4,7 +4,7 @@ from backports.
 
 --- a/lib/crypto/Kconfig
 +++ b/lib/crypto/Kconfig
-@@ -4,7 +4,7 @@ config CRYPTO_LIB_AES
+@@ -6,7 +6,7 @@ config CRYPTO_LIB_AES
        tristate
  
  config CRYPTO_LIB_ARC4
index 80c8110a8255d43272eb84b6ea577de8d1d0f135..28cdec51b2c544f2696169c8125641d386a76633 100644 (file)
@@ -1087,7 +1087,7 @@ Signed-off-by: Alexandros C. Couloumbis <alex@ozo.com>
  #define JFFS2_NODE_ACCURATE 0x2000
 --- a/lib/Kconfig
 +++ b/lib/Kconfig
-@@ -335,6 +335,12 @@ config ZSTD_DECOMPRESS
+@@ -337,6 +337,12 @@ config ZSTD_DECOMPRESS
  
  source "lib/xz/Kconfig"
  
index 662b956e4c07e608a2edcec5e68258c68ffe0403..8a718a02f213ec0c893d81d88970748cc740890c 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Tobias Waldekranz <tobias@waldekranz.com>
 
 --- a/drivers/net/dsa/mv88e6xxx/chip.c
 +++ b/drivers/net/dsa/mv88e6xxx/chip.c
-@@ -6320,6 +6320,7 @@ static int mv88e6xxx_register_switch(str
+@@ -6319,6 +6319,7 @@ static int mv88e6xxx_register_switch(str
        ds->ops = &mv88e6xxx_switch_ops;
        ds->ageing_time_min = chip->info->age_time_coeff;
        ds->ageing_time_max = chip->info->age_time_coeff * U8_MAX;
index eba1d3454eab4241909f471d0c3c49614c29bec8..87be5980c4aa0e4de436425aa0612884b08a6ca0 100644 (file)
@@ -40,7 +40,7 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
        help
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -90,6 +90,7 @@ obj-$(CONFIG_NATIONAL_PHY)   += national.o
+@@ -92,6 +92,7 @@ obj-$(CONFIG_NATIONAL_PHY)   += national.o
  obj-$(CONFIG_NXP_C45_TJA11XX_PHY)     += nxp-c45-tja11xx.o
  obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
  obj-$(CONFIG_QSEMI_PHY)               += qsemi.o
index aec8f327f18550f65137038eab90475cb468ed1f..262df9d2cfabc1962cb71ed582032b56a9ecba8e 100644 (file)
@@ -15,7 +15,7 @@
        help
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -93,6 +93,7 @@ obj-$(CONFIG_QSEMI_PHY)              += qsemi.o
+@@ -95,6 +95,7 @@ obj-$(CONFIG_QSEMI_PHY)              += qsemi.o
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o
  obj-$(CONFIG_RENESAS_PHY)     += uPD60620.o
  obj-$(CONFIG_ROCKCHIP_PHY)    += rockchip.o