iperf: Fix compilation with libcxx
authorRosen Penev <rosenp@gmail.com>
Sat, 14 Dec 2019 05:25:03 +0000 (21:25 -0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 22 Dec 2019 23:22:07 +0000 (00:22 +0100)
Avoids redefining bool.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/network/utils/iperf/Makefile
package/network/utils/iperf/patches/010-libcxx.patch [new file with mode: 0644]

index 33d00b43d75e886a6d1a9cd68ea370307c8a238c..3a235fadc732d2875a5875f14144cb12e71e6637 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iperf
 PKG_VERSION:=2.0.13
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_HASH:=c88adec966096a81136dda91b4bd19c27aae06df4d45a7f547a8e50d723778ad
diff --git a/package/network/utils/iperf/patches/010-libcxx.patch b/package/network/utils/iperf/patches/010-libcxx.patch
new file mode 100644 (file)
index 0000000..cf01242
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/config.h.in
++++ b/config.h.in
+@@ -360,7 +360,9 @@
+ #undef _REENTRANT
+ /* */
++#ifndef __cplusplus
+ #undef bool
++#endif
+ /* Define to empty if `const' does not conform to ANSI C. */
+ #undef const