ipq40xx: add support for GL.iNet GL-B2200
authorTruongSinh Tran-Nguyen <i@truongsinh.pro>
Wed, 1 Dec 2021 15:18:17 +0000 (16:18 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Thu, 2 Dec 2021 20:43:07 +0000 (20:43 +0000)
This patch adds supports for the GL-B2200 router.

Specifications:
  - SOC: Qualcomm IPQ4019 ARM Quad-Core
  - RAM: 512 MiB
  - Flash: 16 MiB NOR - SPI0
  - EMMC: 8GB EMMC
  - ETH: Qualcomm QCA8075
  - WLAN1: Qualcomm Atheros QCA4019 2.4GHz 802.11b/g/n 2x2
  - WLAN2: Qualcomm Atheros QCA4019 5GHz 802.11n/ac W2 2x2
  - WLAN3: Qualcomm Atheros QCA9886 5GHz 802.11n/ac W2 2x2
  - INPUT: Reset, WPS
  - LED: Power, Internet
  - UART1: On board pin header near to LED (3.3V, TX, RX, GND), 3.3V without pin - 115200 8N1
  - UART2: On board with BLE module
  - SPI1: On board socket for Zigbee module

Update firmware instructions:
Please update the firmware via U-Boot web UI (by default at 192.168.1.1, following instructions found at
https://docs.gl-inet.com/en/3/troubleshooting/debrick/).
Normal sysupgrade, either via CLI or LuCI, is not possible from stock firmware.
Please do use the *gl-b2200-squashfs-emmc.img file, gunzipping the produced *gl-b2200-squashfs-emmc.img.gz one first.

What's working:
- WiFi 2G, 5G
- WPA2/WPA3

Not tested:
- Bluetooth LE/Zigbee

Credits goes to the original authors of this patch.

V1->V2:
- updates *arm-boot-add-dts-files.patch correctly (sorry, my mistake)
- add uboot-envtools support
V2->V3:
- Li Zhang updated official patch to fix wrong MAC address on wlan0 (PCI) interface
V3->V4:
- wire up sysupgrade

Signed-off-by: Li Zhang <li.zhang@gl-inet.com>
[fix tab and trailing space, document what's working and what's not]
Signed-off-by: TruongSinh Tran-Nguyen <i@truongsinh.pro>
[rebase on top of master, address remaining comments]
Signed-off-by: Enrico Mioso <mrkiko.rs@gmail.com>
[remove redundant check in platform.sh]
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
12 files changed:
package/boot/uboot-envtools/files/ipq40xx
package/firmware/ipq-wifi/Makefile
package/firmware/ipq-wifi/board-glinet_gl-b2200.qca4019 [new file with mode: 0644]
package/firmware/ipq-wifi/board-glinet_gl-b2200.qca9888 [new file with mode: 0644]
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ipq40xx/base-files/lib/upgrade/platform.sh
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-gl-b2200.dts [new file with mode: 0644]
target/linux/ipq40xx/generic/target.mk
target/linux/ipq40xx/image/generic.mk
target/linux/ipq40xx/patches-5.10/901-arm-boot-add-dts-files.patch
target/linux/ipq40xx/patches-5.4/901-arm-boot-add-dts-files.patch

index 1462aa991d7da512f5f88ca55961ebe7323ec938..9a71a622f7bada02b897e0c3f492c17b6ad6114c 100644 (file)
@@ -35,6 +35,7 @@ devolo,magic-2-wifi-next|\
 edgecore,ecw5211|\
 glinet,gl-ap1300|\
 glinet,gl-b1300|\
+glinet,gl-b2200|\
 luma,wrtq-329acn|\
 netgear,wac510|\
 openmesh,a42|\
index ebaac48c24e7761a4dc8ec1e2708b9309e2eaba1..b1e6541e6143dc381bd40443b9a91cc651caf277 100644 (file)
@@ -39,6 +39,7 @@ ALLWIFIBOARDS:= \
        engenius_emr3500 \
        ezviz_cs-w3-wd1200g-eup \
        glinet_gl-ap1300 \
+       glinet_gl-b2200 \
        glinet_gl-s1300 \
        linksys_ea8300 \
        linksys_mr8300-v0 \
@@ -127,6 +128,7 @@ $(eval $(call generate-ipq-wifi-package,engenius_emd1,EnGenius EMD1))
 $(eval $(call generate-ipq-wifi-package,engenius_emr3500,EnGenius EMR3500))
 $(eval $(call generate-ipq-wifi-package,ezviz_cs-w3-wd1200g-eup,EZVIZ CS-W3-WD1200G EUP))
 $(eval $(call generate-ipq-wifi-package,glinet_gl-ap1300,GL.iNet GL-AP1300))
+$(eval $(call generate-ipq-wifi-package,glinet_gl-b2200,GL.iNet GL-B2200))
 $(eval $(call generate-ipq-wifi-package,glinet_gl-s1300,GL.iNet GL-S1300))
 $(eval $(call generate-ipq-wifi-package,linksys_ea8300,Linksys EA8300))
 $(eval $(call generate-ipq-wifi-package,linksys_mr8300-v0,Linksys MR8300))
diff --git a/package/firmware/ipq-wifi/board-glinet_gl-b2200.qca4019 b/package/firmware/ipq-wifi/board-glinet_gl-b2200.qca4019
new file mode 100644 (file)
index 0000000..ac18501
Binary files /dev/null and b/package/firmware/ipq-wifi/board-glinet_gl-b2200.qca4019 differ
diff --git a/package/firmware/ipq-wifi/board-glinet_gl-b2200.qca9888 b/package/firmware/ipq-wifi/board-glinet_gl-b2200.qca9888
new file mode 100644 (file)
index 0000000..4f0a521
Binary files /dev/null and b/package/firmware/ipq-wifi/board-glinet_gl-b2200.qca9888 differ
index 63209fa49aa7665d076ae31f95ca9c2a84d5bda1..c37fc58b22a4c67326a67bf3468f226766e48269 100644 (file)
@@ -106,6 +106,11 @@ ipq40xx_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0u@eth0" "3:lan" "4:lan"
                ;;
+       glinet,gl-b2200)
+               ucidef_set_interfaces_lan_wan "eth0" "eth1"
+               ucidef_add_switch "switch0" \
+                       "0u@eth0" "1:lan" "2:lan" "3:lan" "5:lan" "0u@eth1" "4:wan"
+               ;;
        mobipromo,cm520-79f)
                ucidef_add_switch "switch0" \
                        "0u@eth0" "3:lan:2" "4:lan:1"
index f43a3a88b727144e5e1470d17bc6f40abe71cd4a..8924fb3258fae652b26d033de901d806d0a8e279 100644 (file)
@@ -9,6 +9,9 @@ board=$(board_name)
 case "$FIRMWARE" in
 "ath10k/cal-pci-0000:01:00.0.bin")
        case "$board" in
+       glinet,gl-b2200)
+               caldata_extract "ART" 0x9000 0x2f20
+               ;;
        meraki,mr33)
                caldata_extract_ubi "ART" 0x9000 0x844
                caldata_valid "4408" || caldata_extract "ART" 0x9000 0x844
@@ -64,6 +67,7 @@ case "$FIRMWARE" in
        ezviz,cs-w3-wd1200g-eup |\
        glinet,gl-ap1300 |\
        glinet,gl-b1300 |\
+       glinet,gl-b2200 |\
        glinet,gl-s1300 |\
        linksys,ea6350v3 |\
        mobipromo,cm520-79f |\
@@ -186,6 +190,7 @@ case "$FIRMWARE" in
        ezviz,cs-w3-wd1200g-eup |\
        glinet,gl-ap1300 |\
        glinet,gl-b1300 |\
+       glinet,gl-b2200 |\
        glinet,gl-s1300 |\
        linksys,ea6350v3 |\
        mobipromo,cm520-79f |\
index 8f8494dcffc0203de15f888b77f0ad33e3c60362..357e02000a8bdd1c19290716c08c69ea3c3199c6 100644 (file)
@@ -96,6 +96,12 @@ platform_do_upgrade() {
        qxwlan,e2600ac-c2)
                nand_do_upgrade "$1"
                ;;
+       glinet,gl-b2200)
+               CI_KERNPART="0:HLOS"
+               CI_ROOTPART="rootfs"
+               CI_DATAPART="rootfs_data"
+               emmc_do_upgrade "$1"
+               ;;
        alfa-network,ap120c-ac)
                part="$(awk -F 'ubi.mtd=' '{printf $2}' /proc/cmdline | sed -e 's/ .*$//')"
                if [ "$part" = "rootfs1" ]; then
@@ -166,3 +172,12 @@ platform_do_upgrade() {
                ;;
        esac
 }
+
+platform_copy_config() {
+       case "$(board_name)" in
+       glinet,gl-b2200)
+               emmc_copy_config
+               ;;
+       esac
+       return 0;
+}
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-gl-b2200.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-gl-b2200.dts
new file mode 100644 (file)
index 0000000..6b84f78
--- /dev/null
@@ -0,0 +1,364 @@
+// SPDX-License-Identifier: GPL-2.0-only OR MIT
+
+#include "qcom-ipq4019.dtsi"
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/soc/qcom,tcsr.h>
+
+/ {
+       model = "GL.iNet GL-B2200";
+       compatible = "glinet,gl-b2200", "qcom,ipq4019";
+
+       memory {
+               device_type = "memory";
+               reg = <0x80000000 0x10000000>;
+       };
+
+       chosen {
+               bootargs-append = " root=/dev/mmcblk0p2 rw rootwait clk_ignore_unused";
+       };
+
+       soc {
+               rng@22000 {
+                       status = "okay";
+               };
+
+               mdio@90000 {
+                       status = "okay";
+               };
+
+               ess-psgmii@98000 {
+                       status = "okay";
+               };
+
+               tcsr@1949000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1949000 0x100>;
+                       qcom,wifi_glb_cfg = <TCSR_WIFI_GLB_CFG>;
+               };
+
+               tcsr@194b000 {
+                       /* select hostmode */
+                       compatible = "qcom,tcsr";
+                       reg = <0x194b000 0x100>;
+                       qcom,usb-hsphy-mode-select = <TCSR_USB_HSPHY_HOST_MODE>;
+                       status = "okay";
+               };
+
+               ess_tcsr@1953000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1953000 0x1000>;
+                       qcom,ess-interface-select = <TCSR_ESS_PSGMII>;
+               };
+
+               tcsr@1957000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1957000 0x100>;
+                       qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
+               };
+
+               crypto@8e3a000 {
+                       status = "okay";
+               };
+
+               ess-switch@c000000 {
+                       status = "okay";
+                       switch_lan_bmp = <0x2e>;
+                       switch_wan_bmp = <0x10>;
+               };
+
+               edma@c080000 {
+                       status = "okay";
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               wps {
+                       label = "wps";
+                       gpios = <&tlmm 18 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_WPS_BUTTON>;
+                       linux,input-type = <1>;
+               };
+
+               reset {
+                       label = "reset";
+                       gpios = <&tlmm 43 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+                       linux,input-type = <1>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               power_blue {
+                       label = "blue:power";
+                       gpios = <&tlmm 57 GPIO_ACTIVE_HIGH>;
+                       default-state = "on";
+               };
+               internet_blue {
+                       label = "blue:internet";
+                       gpios = <&tlmm 60 GPIO_ACTIVE_HIGH>;
+               };
+               power_white {
+                       label = "white:power";
+                       gpios = <&tlmm 61 GPIO_ACTIVE_LOW>;
+               };
+               internet_white {
+                       label = "white:internet";
+                       gpios = <&tlmm 66 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&gmac1 {
+       qcom,phy_mdio_addr = <3>;
+       qcom,poll_required = <1>;
+       qcom,forced_speed = <1000>;
+       qcom,forced_duplex = <1>;
+       vlan_tag = <2 0x10>;
+};
+
+&gmac0 {
+       vlan_tag = <1 0x2e>;
+};
+
+&vqmmc {
+       status = "okay";
+};
+
+&sdhci {
+       status = "okay";
+       pinctrl-0 = <&sd_pins>;
+       pinctrl-names = "default";
+       cd-gpios = <&tlmm 3 GPIO_ACTIVE_LOW>;
+       vqmmc-supply = <&vqmmc>;
+};
+
+&blsp_dma {
+       status = "okay";
+};
+
+&cryptobam {
+       status = "okay";
+};
+
+&blsp1_spi1 {
+       pinctrl-0 = <&spi_0_pins>;
+       pinctrl-names = "default";
+       status = "okay";
+       cs-gpios = <&tlmm 12 GPIO_ACTIVE_HIGH>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <24000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "SBL1";
+                               reg = <0x0 0x40000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "MIBIB";
+                               reg = <0x40000 0x20000>;
+                               read-only;
+                       };
+
+                       partition@60000 {
+                               label = "QSEE";
+                               reg = <0x60000 0x60000>;
+                               read-only;
+                       };
+
+                       partition@c0000 {
+                               label = "CDT";
+                               reg = <0xc0000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@d0000 {
+                               label = "DDRPARAMS";
+                               reg = <0xd0000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@e0000 {
+                               label = "APPSBLENV";
+                               reg = <0xe0000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@f0000 {
+                               label = "APPSBL";
+                               reg = <0xf0000 0x80000>;
+                               read-only;
+                       };
+
+                       partition@170000 {
+                               label = "ART";
+                               reg = <0x170000 0x10000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&blsp1_spi2 {
+       pinctrl-0 = <&spi_1_pins>;
+       pinctrl-names = "default";
+       status = "okay";
+
+       spidev1: spi@0 {
+               compatible = "siliconlabs,si3210";
+               reg = <0>;
+               spi-max-frequency = <24000000>;
+       };
+};
+
+&blsp1_uart1 {
+       pinctrl-0 = <&serial_pins>;
+       pinctrl-names = "default";
+       status = "okay";
+};
+
+&blsp1_uart2 {
+       pinctrl-0 = <&serial_1_pins>;
+       pinctrl-names = "default";
+       status = "okay";
+};
+
+&tlmm {
+       serial_pins: serial_pinmux {
+               mux {
+                       pins = "gpio16", "gpio17";
+                       function = "blsp_uart0";
+                       bias-disable;
+               };
+       };
+
+       serial_1_pins: serial1_pinmux {
+               mux {
+                       pins = "gpio8", "gpio9",
+                               "gpio10", "gpio11";
+                       function = "blsp_uart1";
+                       bias-disable;
+               };
+       };
+
+       spi_0_pins: spi_0_pinmux {
+               pinmux {
+                       function = "blsp_spi0";
+                       pins = "gpio13", "gpio14", "gpio15";
+               };
+               pinmux_cs {
+                       function = "gpio";
+                       pins = "gpio12";
+               };
+               pinconf {
+                       pins = "gpio13", "gpio14", "gpio15";
+                       drive-strength = <12>;
+                       bias-disable;
+               };
+               pinconf_cs {
+                       pins = "gpio12";
+                       drive-strength = <2>;
+                       bias-disable;
+                       output-high;
+               };
+       };
+
+       spi_1_pins: spi_1_pinmux {
+               mux {
+                       pins = "gpio44", "gpio46", "gpio47";
+                       function = "blsp_spi1";
+                       bias-disable;
+               };
+               cs {
+                       pins = "gpio45";
+                       function = "gpio";
+                       bias-pull-up;
+               };
+               reset {
+                       pins = "gpio43";
+                       function = "gpio";
+                       output-high;
+               };
+               mux_2 {
+                       pins = "gpio35";
+                       function = "gpio";
+                       output-high;
+               };
+               host_int {
+                       pins = "gpio2";
+                       function = "gpio";
+                       input;
+               };
+               wake {
+                       pins = "gpio48";
+                       function = "gpio";
+                       output-high;
+               };
+       };
+
+       sd_pins: sd_pins {
+               pinmux {
+                       function = "sdio";
+                       pins = "gpio23", "gpio24", "gpio25", "gpio26",
+                               "gpio29", "gpio30", "gpio31", "gpio32";
+                       drive-strength = <10>;
+               };
+
+               pinmux_sd_clk {
+                       function = "sdio";
+                       pins = "gpio27";
+                       drive-strength = <16>;
+               };
+
+               pinmux_sd7 {
+                       function = "sdio";
+                       pins = "gpio28";
+                       drive-strength = <10>;
+                       bias-disable;
+               };
+       };
+
+};
+
+&pcie0 {
+       status = "okay";
+       perst-gpio = <&tlmm 38 GPIO_ACTIVE_LOW>;
+       wake-gpio = <&tlmm 50 GPIO_ACTIVE_LOW>;
+
+       bridge@0,0 {
+               reg = <0x00000000 0 0 0 0>;
+               #address-cells = <3>;
+               #size-cells = <2>;
+               ranges;
+
+               wifi2: wifi@1,0 {
+                       status = "okay";
+                       compatible = "qcom,ath10k";
+                       reg = <0x00010000 0 0 0 0>;
+                       qcom,ath10k-calibration-variant = "GL-B2200";
+               };
+       };
+};
+
+&wifi0 {
+       status = "okay";
+       qcom,ath10k-calibration-variant = "GL-B2200";
+};
+
+&wifi1 {
+       status = "okay";
+       qcom,ath10k-calibration-variant = "GL-B2200";
+};
index f5cb1fb19b943f3c55a4110be4a33f41a26d13d0..e158b1c98b1065a8a7a47727d17113e60cbb491c 100644 (file)
@@ -1 +1,2 @@
 BOARDNAME:=Generic
+FEATURES+=emmc
index 0d7d7a30d223be108e2288b3e7424c84f3350b80..872c4f957f32152985d52c36c49c1bc2f3eb095c 100644 (file)
@@ -92,6 +92,16 @@ define Build/qsdk-ipq-factory-nand-askey
        @mv $@.new $@
 endef
 
+define Build/qsdk-ipq-app-gpt
+       cp $@ $@.tmp 2>/dev/null || true
+       ptgen -g -o $@.tmp -a 1 -l 1024 \
+                       -t 0x2e -N 0:HLOS -r -p 32M \
+                       -t 0x83 -N rootfs -r -p 128M \
+                               -N rootfs_data -p 512M
+       cat $@.tmp >> $@
+       rm $@.tmp
+endef
+
 define Build/SenaoFW
        -$(STAGING_DIR_HOST)/bin/mksenaofw \
                -n $(BOARD_NAME) -r $(VENDOR_ID) -p $(1) \
@@ -520,6 +530,24 @@ define Device/glinet_gl-b1300
 endef
 TARGET_DEVICES += glinet_gl-b1300
 
+define Device/glinet_gl-b2200
+       $(call Device/FitzImage)
+       DEVICE_VENDOR := GL.iNet
+       DEVICE_MODEL := GL-B2200
+       SOC := qcom-ipq4019
+       DEVICE_DTS_CONFIG := config@ap.dk04.1-c3
+       KERNEL_INITRAMFS_SUFFIX := -recovery.itb
+       IMAGES := emmc.img.gz sysupgrade.bin
+       IMAGE/emmc.img.gz := qsdk-ipq-app-gpt |\
+               pad-to 1024k | append-kernel |\
+               pad-to 33792k | append-rootfs |\
+               append-metadata | gzip
+       IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+       DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-glinet_gl-b2200 \
+               kmod-fs-ext4 kmod-mmc kmod-spi-dev mkf2fs e2fsprogs kmod-fs-f2fs
+endef
+TARGET_DEVICES += glinet_gl-b2200
+
 define Device/glinet_gl-s1300
        $(call Device/FitzImage)
        DEVICE_VENDOR := GL.iNet
index 3bd13bf9321954e2fe99433ec4bfaef86c39a3fa..b641251423fab3a4722348b9ef6003c73cd18eda 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -902,11 +902,70 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+@@ -902,11 +902,71 @@ dtb-$(CONFIG_ARCH_QCOM) += \
        qcom-apq8074-dragonboard.dtb \
        qcom-apq8084-ifc6540.dtb \
        qcom-apq8084-mtp.dtb \
@@ -76,6 +76,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 +      qcom-ipq4029-ap-303h.dtb \
 +      qcom-ipq4029-ap-365.dtb \
 +      qcom-ipq4029-gl-b1300.dtb \
++      qcom-ipq4019-gl-b2200.dtb \
 +      qcom-ipq4029-gl-s1300.dtb \
 +      qcom-ipq4029-mr33.dtb \
        qcom-ipq8064-ap148.dtb \
index 734d08387a42c6f7ebce98dc0e29b046e18d38ce..4270418d6c2bc13246942a268aac3617cb386913 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -837,11 +837,68 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+@@ -837,11 +837,69 @@ dtb-$(CONFIG_ARCH_QCOM) += \
        qcom-apq8074-dragonboard.dtb \
        qcom-apq8084-ifc6540.dtb \
        qcom-apq8084-mtp.dtb \
@@ -74,6 +74,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 +      qcom-ipq4029-ap-303h.dtb \
 +      qcom-ipq4029-ap-365.dtb \
 +      qcom-ipq4029-gl-b1300.dtb \
++      qcom-ipq4019-gl-b2200.dtb \
 +      qcom-ipq4029-gl-s1300.dtb \
 +      qcom-ipq4029-mr33.dtb \
        qcom-ipq8064-ap148.dtb \