kernel: bump 5.4 to 5.4.120
authorJohn Audia <graysky@archlinux.us>
Fri, 21 May 2021 10:29:01 +0000 (06:29 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 23 May 2021 13:09:06 +0000 (15:09 +0200)
Removed upstreamed:
  generic/pending-5.4/770-02-net-ethernet-mtk_eth_soc-fix-rx-vlan-offload.patch

All other patches automatically rebased.

Build system: x86_64
Build-tested: ipq806x/R7800

Note that since I rebased the previous commit, I removed my Run-tested line
although I confirm building the image successfully.

Signed-off-by: John Audia <graysky@archlinux.us>
12 files changed:
include/kernel-version.mk
target/linux/apm821xx/patches-5.4/801-usb-xhci-add-firmware-loader-for-uPD720201-and-uPD72.patch
target/linux/apm821xx/patches-5.4/802-usb-xhci-force-msi-renesas-xhci.patch
target/linux/bcm27xx/patches-5.4/950-0211-usb-xhci-Show-that-the-VIA-VL805-supports-LPM.patch
target/linux/bcm27xx/patches-5.4/950-0264-xhci-add-quirk-for-host-controllers-that-don-t-updat.patch
target/linux/bcm27xx/patches-5.4/950-0297-arch-arm-Add-model-string-to-cpuinfo.patch
target/linux/bcm27xx/patches-5.4/950-0993-xhci-quirks-add-link-TRB-quirk-for-VL805.patch
target/linux/generic/hack-5.4/911-kobject_add_broadcast_uevent.patch
target/linux/generic/pending-5.4/770-02-net-ethernet-mtk_eth_soc-fix-rx-vlan-offload.patch [deleted file]
target/linux/ipq806x/patches-5.4/0063-2-tsens-support-configurable-interrupts.patch
target/linux/layerscape/patches-5.4/301-arch-0008-arm-add-new-non-shareable-ioremap.patch
target/linux/layerscape/patches-5.4/820-usb-0005-usb-dwc3-add-otg-properties-update.patch

index 14b0f27ad58ded30cd5cf30c324e902b4251e4b0..80b2567ed60d1586787b3b19ab6c9481456eeae2 100644 (file)
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .119
+LINUX_VERSION-5.4 = .120
 LINUX_VERSION-5.10 = .39
 
-LINUX_KERNEL_HASH-5.4.119 = 71e7decf1e8149a8aed88d30df4f2a62a6c6b168111de6b261685ac7c0ecb2a0
+LINUX_KERNEL_HASH-5.4.120 = 38d0373c69d001a66c4b8c1b8df453d193eb38b46b6fa0d02560262ab0c10860
 LINUX_KERNEL_HASH-5.10.39 = 5738a515ca97853481767360c568eae46c8d777d98a69e018a3299baa6b3f614
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index dbed597973e91cfeaef1c7139e4b1121fd584db2..980a0407db12c38d1b3f261dad65838480aa46da 100644 (file)
@@ -93,7 +93,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
  static const char hcd_name[] = "xhci_hcd";
  
  static struct hc_driver __read_mostly xhci_pci_hc_driver;
-@@ -307,6 +347,873 @@ static void xhci_pme_acpi_rtd3_enable(st
+@@ -309,6 +349,873 @@ static void xhci_pme_acpi_rtd3_enable(st
  static void xhci_pme_acpi_rtd3_enable(struct pci_dev *dev) { }
  #endif /* CONFIG_ACPI */
  
@@ -967,7 +967,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
  /* called during probe() after chip reset completes */
  static int xhci_pci_setup(struct usb_hcd *hcd)
  {
-@@ -348,6 +1255,27 @@ static int xhci_pci_probe(struct pci_dev
+@@ -350,6 +1257,27 @@ static int xhci_pci_probe(struct pci_dev
        struct hc_driver *driver;
        struct usb_hcd *hcd;
  
@@ -995,7 +995,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
        driver = (struct hc_driver *)id->driver_data;
  
        /* Prevent runtime suspending between USB-2 and USB-3 initialization */
-@@ -409,6 +1337,16 @@ static void xhci_pci_remove(struct pci_d
+@@ -411,6 +1339,16 @@ static void xhci_pci_remove(struct pci_d
  {
        struct xhci_hcd *xhci;
  
@@ -1012,7 +1012,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
        xhci = hcd_to_xhci(pci_get_drvdata(dev));
        xhci->xhc_state |= XHCI_STATE_REMOVING;
  
-@@ -548,6 +1486,11 @@ static int xhci_pci_resume(struct usb_hc
+@@ -550,6 +1488,11 @@ static int xhci_pci_resume(struct usb_hc
        if (pdev->vendor == PCI_VENDOR_ID_INTEL)
                usb_enable_intel_xhci_ports(pdev);
  
index f248407fdbbe8fd50a4e57652136cf7d9697b291..9a0bab5c4b0b86052e5428f734f6a6f56a7579f2 100644 (file)
@@ -13,7 +13,7 @@ produce a noisy warning.
 
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -286,6 +286,7 @@ static void xhci_pci_quirks(struct devic
+@@ -288,6 +288,7 @@ static void xhci_pci_quirks(struct devic
            pdev->device == 0x0015) {
                xhci->quirks |= XHCI_RESET_ON_RESUME;
                xhci->quirks |= XHCI_ZERO_64B_REGS;
index 83a2341e1b1ff9e78050e3263f7a9e9a147d94c8..5679126103fcade1f4e25b0c99107edc832630dd 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -255,6 +255,10 @@ static void xhci_pci_quirks(struct devic
+@@ -257,6 +257,10 @@ static void xhci_pci_quirks(struct devic
                        pdev->device == 0x3432)
                xhci->quirks |= XHCI_BROKEN_STREAMS;
  
index db69423d33e90aad41a7bf0cd93f476356426e48..e60468c848d4ae0271d3259b7748f5a00ef14515 100644 (file)
@@ -23,7 +23,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
 
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -256,8 +256,10 @@ static void xhci_pci_quirks(struct devic
+@@ -258,8 +258,10 @@ static void xhci_pci_quirks(struct devic
                xhci->quirks |= XHCI_BROKEN_STREAMS;
  
        if (pdev->vendor == PCI_VENDOR_ID_VIA &&
index 83c1592df90cd2f0212dd3bb6daebe3277bdd30c..4e9598a54ee822f023c9580309fd63ef58032af3 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/arch/arm/kernel/setup.c
 +++ b/arch/arm/kernel/setup.c
-@@ -1240,6 +1240,8 @@ static int c_show(struct seq_file *m, vo
+@@ -1249,6 +1249,8 @@ static int c_show(struct seq_file *m, vo
  {
        int i, j;
        u32 cpuid;
@@ -19,7 +19,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  
        for_each_online_cpu(i) {
                /*
-@@ -1299,6 +1301,14 @@ static int c_show(struct seq_file *m, vo
+@@ -1308,6 +1310,14 @@ static int c_show(struct seq_file *m, vo
        seq_printf(m, "Revision\t: %04x\n", system_rev);
        seq_printf(m, "Serial\t\t: %s\n", system_serial);
  
index 12804bae7565cff1e680e5be00df4325d70138a9..355421ee268cb13d5ebd514e5de942389b8b595c 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
 
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -259,6 +259,7 @@ static void xhci_pci_quirks(struct devic
+@@ -261,6 +261,7 @@ static void xhci_pci_quirks(struct devic
                        pdev->device == 0x3483) {
                xhci->quirks |= XHCI_LPM_SUPPORT;
                xhci->quirks |= XHCI_EP_CTX_BROKEN_DCS;
index 52453e5ce3a01ede0e20c5801e9f35be3386ac3c..6f5e50d091b124d0fec304c53818ce9a81f56d7f 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #endif /* _KOBJECT_H_ */
 --- a/lib/kobject_uevent.c
 +++ b/lib/kobject_uevent.c
-@@ -690,6 +690,43 @@ int add_uevent_var(struct kobj_uevent_en
+@@ -691,6 +691,43 @@ int add_uevent_var(struct kobj_uevent_en
  EXPORT_SYMBOL_GPL(add_uevent_var);
  
  #if defined(CONFIG_NET)
diff --git a/target/linux/generic/pending-5.4/770-02-net-ethernet-mtk_eth_soc-fix-rx-vlan-offload.patch b/target/linux/generic/pending-5.4/770-02-net-ethernet-mtk_eth_soc-fix-rx-vlan-offload.patch
deleted file mode 100644 (file)
index e178770..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From: Felix Fietkau <nbd@nbd.name>
-Date: Wed, 26 Aug 2020 16:52:12 +0200
-Subject: [PATCH] net: ethernet: mtk_eth_soc: fix rx vlan offload
-
-The VLAN ID in the rx descriptor is only valid if the RX_DMA_VID bit is set
-Fixes frames wrongly marked with VLAN tags
-
-Signed-off-by: Felix Fietkau <nbd@nbd.name>
----
-
---- a/drivers/net/ethernet/mediatek/mtk_eth_soc.c
-+++ b/drivers/net/ethernet/mediatek/mtk_eth_soc.c
-@@ -1320,7 +1320,7 @@ static int mtk_poll_rx(struct napi_struc
-               skb->protocol = eth_type_trans(skb, netdev);
-               if (netdev->features & NETIF_F_HW_VLAN_CTAG_RX &&
--                  RX_DMA_VID(trxd.rxd3))
-+                  (trxd.rxd2 & RX_DMA_VTAG))
-                       __vlan_hwaccel_put_tag(skb, htons(ETH_P_8021Q),
-                                              RX_DMA_VID(trxd.rxd3));
-               skb_record_rx_queue(skb, 0);
---- a/drivers/net/ethernet/mediatek/mtk_eth_soc.h
-+++ b/drivers/net/ethernet/mediatek/mtk_eth_soc.h
-@@ -295,6 +295,7 @@
- #define RX_DMA_LSO            BIT(30)
- #define RX_DMA_PLEN0(_x)      (((_x) & 0x3fff) << 16)
- #define RX_DMA_GET_PLEN0(_x)  (((_x) >> 16) & 0x3fff)
-+#define RX_DMA_VTAG           BIT(15)
- /* QDMA descriptor rxd3 */
- #define RX_DMA_VID(_x)                ((_x) & 0xfff)
index 585bd62a58d32b1c9edec66593a19e78b34c0d29..54488f25a82c12ce0ea1f7efb30f501f15fa2e04 100644 (file)
@@ -163,7 +163,7 @@ Signed-off-by: Rajith Cherian <rajith@codeaurora.org>
        mutex_unlock(&tzd->lock);
  
        return tzd;
-@@ -762,7 +802,10 @@ static const char * const trip_types[] =
+@@ -765,7 +805,10 @@ static const char * const trip_types[] =
        [THERMAL_TRIP_ACTIVE]   = "active",
        [THERMAL_TRIP_PASSIVE]  = "passive",
        [THERMAL_TRIP_HOT]      = "hot",
index a20909f3173037ba1c07c616aca43b0f9fc53227..85a4478cd805825f6196eff0ef6d80540175e340 100644 (file)
@@ -63,7 +63,7 @@ Signed-off-by: Roy Pledge <roy.pledge@nxp.com>
   * address space as memory. Needed when the kernel wants to execute
 --- a/arch/arm/mm/mmu.c
 +++ b/arch/arm/mm/mmu.c
-@@ -312,6 +312,13 @@ static struct mem_type mem_types[] __ro_
+@@ -314,6 +314,13 @@ static struct mem_type mem_types[] __ro_
                .prot_sect = PMD_TYPE_SECT | PMD_SECT_AP_WRITE,
                .domain    = DOMAIN_KERNEL,
        },
@@ -77,7 +77,7 @@ Signed-off-by: Roy Pledge <roy.pledge@nxp.com>
        [MT_ROM] = {
                .prot_sect = PMD_TYPE_SECT,
                .domain    = DOMAIN_KERNEL,
-@@ -648,6 +655,7 @@ static void __init build_mem_type_table(
+@@ -650,6 +657,7 @@ static void __init build_mem_type_table(
        }
        kern_pgprot |= PTE_EXT_AF;
        vecs_pgprot |= PTE_EXT_AF;
@@ -85,7 +85,7 @@ Signed-off-by: Roy Pledge <roy.pledge@nxp.com>
  
        /*
         * Set PXN for user mappings
-@@ -676,6 +684,7 @@ static void __init build_mem_type_table(
+@@ -678,6 +686,7 @@ static void __init build_mem_type_table(
        mem_types[MT_MEMORY_RWX].prot_pte |= kern_pgprot;
        mem_types[MT_MEMORY_RW].prot_sect |= ecc_mask | cp->pmd;
        mem_types[MT_MEMORY_RW].prot_pte |= kern_pgprot;
index ab9630677461431f8b9accf185e87c9716f5e21c..5c567ccbf81aa866c13496a09b436d824cb4343f 100644 (file)
@@ -54,7 +54,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
         * All 3.1 IP version constants are greater than the 3.0 IP
 --- a/drivers/usb/dwc3/gadget.c
 +++ b/drivers/usb/dwc3/gadget.c
-@@ -3568,6 +3568,10 @@ int dwc3_gadget_init(struct dwc3 *dwc)
+@@ -3570,6 +3570,10 @@ int dwc3_gadget_init(struct dwc3 *dwc)
        dwc->gadget.sg_supported        = true;
        dwc->gadget.name                = "dwc3-gadget";
        dwc->gadget.lpm_capable         = true;