add madwifi-tools
authorFelix Fietkau <nbd@openwrt.org>
Thu, 25 Aug 2005 11:59:22 +0000 (11:59 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 25 Aug 2005 11:59:22 +0000 (11:59 +0000)
SVN-Revision: 1751

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/madwifi-tools/Config.in [new file with mode: 0644]
openwrt/package/madwifi-tools/Makefile [new file with mode: 0644]
openwrt/package/madwifi-tools/ipkg/madwifi-tools.control [new file with mode: 0644]

index 43e9a334c4a6fc11cf511c9395f16cd2b25294a5..f9d6de65008bc9ced628fbdc98280de50191ff35 100644 (file)
@@ -167,6 +167,7 @@ source "package/setserial/Config.in"
 
 comment "Utilities ---"
 source "package/gdbserver/Config.in"
+source "package/madwifi-tools/Config.in"
 source "package/usbutils/Config.in"  # lsusb
 source "package/strace/Config.in"
 
index 0f5777c055a2ae63c6316939aa4abe77db5a0f42..0b9794132b5af62de0014e5d59486ef6319a62cc 100644 (file)
@@ -82,6 +82,7 @@ package-$(BR2_PACKAGE_LIGHTTPD) += lighttpd
 package-$(BR2_PACKAGE_LINUX_ATM) += linux-atm
 package-$(BR2_PACKAGE_LUA) += lua
 package-$(BR2_PACKAGE_LZO) += lzo
+package-$(BR2_PACKAGE_MADWIFI_TOOLS) += madwifi-tools
 package-$(BR2_PACKAGE_MARADNS) += maradns
 package-$(BR2_PACKAGE_MATRIXSSL) += matrixssl
 package-$(BR2_PACKAGE_MICROCOM) += microcom
diff --git a/openwrt/package/madwifi-tools/Config.in b/openwrt/package/madwifi-tools/Config.in
new file mode 100644 (file)
index 0000000..30f3563
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_MADWIFI_TOOLS
+       prompt "madwifi-tools - utilities for configuring the Atheros Wifi driver"
+       tristate
+       default m if CONFIG_DEVEL
+       help
+         Driver utilities for Atheros 802.11a/b/g MiniPCI cards
diff --git a/openwrt/package/madwifi-tools/Makefile b/openwrt/package/madwifi-tools/Makefile
new file mode 100644 (file)
index 0000000..a7afde1
--- /dev/null
@@ -0,0 +1,38 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=madwifi
+PKG_VERSION:=2005-08-13
+PKG_RELEASE:=1
+PKG_MD5SUM:=188127127aebd8815595c025a787d729
+
+PKG_SOURCE_URL:=http://madwifi.otaku42.de/2005/08/
+PKG_SOURCE:=$(PKG_NAME)-cvs-snapshot-$(PKG_VERSION).tar.bz2
+PKG_CAT:=bzcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,MADWIFI_TOOLS,madwifi-tools,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH),kmod-madwifi))
+
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR)/tools \
+               $(TARGET_CONFIGURE_OPTS)
+       touch $@
+
+$(IPKG_MADWIFI_TOOLS):
+       mkdir -p $(IDIR_MADWIFI_TOOLS)/usr/sbin
+       cp -fpR $(PKG_BUILD_DIR)/tools/athstats \
+               $(PKG_BUILD_DIR)/tools/athdebug \
+               $(PKG_BUILD_DIR)/tools/80211stats \
+               $(PKG_BUILD_DIR)/tools/80211debug \
+               $(PKG_BUILD_DIR)/tools/athctrl \
+               $(PKG_BUILD_DIR)/tools/athkey \
+               $(IDIR_MADWIFI_TOOLS)/usr/sbin
+       $(RSTRIP) $(IDIR_MADWIFI_TOOLS)
+       $(IPKG_BUILD) $(IDIR_MADWIFI_TOOLS) $(PACKAGE_DIR)
diff --git a/openwrt/package/madwifi-tools/ipkg/madwifi-tools.control b/openwrt/package/madwifi-tools/ipkg/madwifi-tools.control
new file mode 100644 (file)
index 0000000..de46b73
--- /dev/null
@@ -0,0 +1,6 @@
+Package: madwifi-tools
+Priority: optional
+Section: net
+Maintainer: Felix Fietkau <openwrt@nbd.name>
+Source: buildroot internal
+Description: Driver utilities for Atheros 802.11a/b/g MiniPCI cards