ath79: don't use the pcs,cr5000 wps led as usb led
authorMathias Kresin <dev@kresin.me>
Thu, 16 Aug 2018 07:53:26 +0000 (09:53 +0200)
committerMathias Kresin <dev@kresin.me>
Thu, 16 Aug 2018 19:20:57 +0000 (21:20 +0200)
If it isn't a usb led, it shouldn't be used as one by default. It is up
to the user to add such a (mis)configuration for the board.

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/image/generic.mk

index a42bde530f5ec9753e817d8a6d5fba43bb2cb560..2c83b138f40eab8f4e14a871a96db51036a1713f 100755 (executable)
@@ -45,10 +45,6 @@ pcs,cr3000)
        ucidef_set_led_switch "lan3" "LAN3" "pcs:blue:lan3" "switch0" "0x10"
        ucidef_set_led_switch "lan4" "LAN4" "pcs:blue:lan4" "switch0" "0x02"
        ;;
-pcs,cr5000)
-       ucidef_set_led_usbdev "usb" "USB" "pcs:white:wps" "1-1"
-       ;;
-
 tplink,re450-v2)
        ucidef_set_led_netdev "lan_data" "LAN Data" "tp-link:green:lan_data" "eth0" "tx rx"
        ucidef_set_led_netdev "lan_link" "LAN Link" "tp-link:green:lan_link" "eth0" "link"
index 01020810ccc73368b118d4d14a097db88c6f97c2..6681bcf3077a5e73e2906bb70ebc03495d6cb471 100644 (file)
@@ -127,7 +127,7 @@ TARGET_DEVICES += pcs_cr3000
 define Device/pcs_cr5000
   ATH_SOC := ar9344
   DEVICE_TITLE := PowerCloud Systems CR5000
-  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport kmod-usb-core
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-core
   IMAGE_SIZE := 7808k
   IMAGES := sysupgrade.bin
   SUPPORTED_DEVICES += cr5000