ath79: fix SUPPORTED_DEVICES not matching ar71xx board names
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 23 Jan 2020 14:42:48 +0000 (15:42 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 23 Jan 2020 15:09:58 +0000 (16:09 +0100)
Based on a script for comparison, this fixes (hopefully) all errors
in SUPPORTED_DEVICES for ar71xx->ath79 upgrade.

Devices where old string is removed as the device does not exist
in ar71xx:
- dlink_dir-859-a1
- tplink_archer-a7-v5
- tplink_cpe510-v3

Devices where string is changed because it did not match the board
name in ar71xx:
- tplink_tl-mr3220-v1
- tplink_tl-mr3420-v1
- tplink_tl-wr2543-v1
- tplink_tl-wr741nd-v4
- tplink_tl-wr841-v7
- ubnt_unifiac-mesh
- ubnt_unifiac-mesh-pro
- ubnt_unifiac-pro

For this device, the correct string could not be found, but we could
not determine the correct one. Thus, the string is removed for now:
- tplink_tl-wr740n-v4

The script for checking this is quite simple (note that newer
entries, i.e. ath79->ath79 upgrade, are displayed as missing):

  newpath=target/linux/ath79/image/
  oldpath=target/linux/ar71xx/base-files/lib/ar71xx.sh

  for s in $(grep -roh "SUPPORTED_DEVICES.*" $newpath | sed 's/SUPPORTED_DEVICES *.= *//'); do
    found="Missing"
    grep -q -r "\"$s\"" $oldpath && found="Found"
    echo "$s: $found."
  done

The errors might be filtered by appending 'grep "Missing"' to the script.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/image/generic-tp-link.mk
target/linux/ath79/image/generic-ubnt.mk
target/linux/ath79/image/generic.mk
target/linux/ath79/image/tiny-tp-link.mk

index 53138e343b2d92a3332e2d442b3449190faf4636..7ac27759ccf82b5fe2638de7ee9b8a5519bb00f9 100644 (file)
@@ -10,7 +10,6 @@ define Device/tplink_archer-a7-v5
        ath10k-firmware-qca988x-ct
   TPLINK_BOARD_ID := ARCHER-A7-V5
   BOARDNAME := ARCHER-A7-V5
-  SUPPORTED_DEVICES += archer-a7-v5
 endef
 TARGET_DEVICES += tplink_archer-a7-v5
 
@@ -306,7 +305,6 @@ define Device/tplink_cpe510-v3
   DEVICE_VARIANT := v3
   DEVICE_PACKAGES := rssileds
   TPLINK_BOARD_ID := CPE510V3
-  SUPPORTED_DEVICES += cpe510-v3
 endef
 TARGET_DEVICES += tplink_cpe510-v3
 
@@ -517,7 +515,7 @@ define Device/tplink_tl-wr2543-v1
   IMAGE/sysupgrade.bin := tplink-v1-image sysupgrade -v 3.13.99 | \
        append-metadata | check-size $$$$(IMAGE_SIZE)
   IMAGE/factory.bin := tplink-v1-image factory -v 3.13.99
-  SUPPORTED_DEVICES += tl-wr2543-v1
+  SUPPORTED_DEVICES += tl-wr2543n
 endef
 TARGET_DEVICES += tplink_tl-wr2543-v1
 
index 78364caffe83fa9780efb6429f71d1e0376ee43c..49564201e20e08231689bd883ba653f58d95d0ac 100644 (file)
@@ -268,14 +268,14 @@ TARGET_DEVICES += ubnt_unifiac-lr
 define Device/ubnt_unifiac-mesh
   $(Device/ubnt_unifiac)
   DEVICE_MODEL := UniFi AC-Mesh
-  SUPPORTED_DEVICES += ubnt-unifiac-mesh
+  SUPPORTED_DEVICES += unifiac-lite
 endef
 TARGET_DEVICES += ubnt_unifiac-mesh
 
 define Device/ubnt_unifiac-mesh-pro
   $(Device/ubnt_unifiac)
   DEVICE_MODEL := UniFi AC-Mesh Pro
-  SUPPORTED_DEVICES += ubnt-unifiac-mesh-pro
+  SUPPORTED_DEVICES += unifiac-pro
 endef
 TARGET_DEVICES += ubnt_unifiac-mesh-pro
 
@@ -283,6 +283,6 @@ define Device/ubnt_unifiac-pro
   $(Device/ubnt_unifiac)
   DEVICE_MODEL := UniFi AC-Pro
   DEVICE_PACKAGES += kmod-usb2
-  SUPPORTED_DEVICES += ubnt-unifiac-pro
+  SUPPORTED_DEVICES += unifiac-pro
 endef
 TARGET_DEVICES += ubnt_unifiac-pro
index e5243dc0953ac090c5fca63715df2ef2cc21c8eb..4f45b122ce78bfa5aab7b9ce2fdf6cf23090a366 100644 (file)
@@ -486,7 +486,6 @@ define Device/dlink_dir-859-a1
   IMAGE_SIZE := 15872k
   DEVICE_PACKAGES :=  kmod-usb2 kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct
   SEAMA_SIGNATURE := wrgac37_dlink.2013gui_dir859
-  SUPPORTED_DEVICES += dir-859-a1
 endef
 TARGET_DEVICES += dlink_dir-859-a1
 
index e5208530d6569236ce7e6e63a8b6b4340aa51fa6..2107e47cc3e543b4765f9fb6423ce9365a773471 100644 (file)
@@ -40,7 +40,7 @@ define Device/tplink_tl-mr3220-v1
   DEVICE_VARIANT := v1
   TPLINK_HWID := 0x32200001
   DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport
-  SUPPORTED_DEVICES += tl-mr3220-v1
+  SUPPORTED_DEVICES += tl-mr3220
 endef
 TARGET_DEVICES += tplink_tl-mr3220-v1
 
@@ -51,7 +51,7 @@ define Device/tplink_tl-mr3420-v1
   DEVICE_VARIANT := v1
   TPLINK_HWID := 0x34200001
   DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport
-  SUPPORTED_DEVICES += tl-mr3420-v1
+  SUPPORTED_DEVICES += tl-mr3420
 endef
 TARGET_DEVICES += tplink_tl-mr3420-v1
 
@@ -134,7 +134,6 @@ define Device/tplink_tl-wr740n-v4
   DEVICE_MODEL := TL-WR740N
   DEVICE_VARIANT := v4
   TPLINK_HWID := 0x07400004
-  SUPPORTED_DEVICES += tl-wr740n-v4
 endef
 TARGET_DEVICES += tplink_tl-wr740n-v4
 
@@ -153,7 +152,7 @@ define Device/tplink_tl-wr741nd-v4
   DEVICE_MODEL := TL-WR741N/ND
   DEVICE_VARIANT := v4
   TPLINK_HWID := 0x07410004
-  SUPPORTED_DEVICES += tl-wr741n-v4
+  SUPPORTED_DEVICES += tl-wr741nd-v4
 endef
 TARGET_DEVICES += tplink_tl-wr741nd-v4
 
@@ -181,7 +180,7 @@ define Device/tplink_tl-wr841-v7
   DEVICE_MODEL := TL-WR841N/ND
   DEVICE_VARIANT := v7
   TPLINK_HWID := 0x08410007
-  SUPPORTED_DEVICES += tl-wr841-v7
+  SUPPORTED_DEVICES += tl-wr841n-v7
 endef
 TARGET_DEVICES += tplink_tl-wr841-v7