bintuils: Pack libctf-nobfd.so in addition
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 9 Aug 2020 12:42:14 +0000 (14:42 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 10 Aug 2020 21:02:37 +0000 (23:02 +0200)
readelf is linked against this library on MIPS64BE
This fixes a build problem on MIPS64BE.

In addition also explicitly activate it in the configure command.

Fixes: 60f595daab45 ("binutils: update to version 2.34")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/devel/binutils/Makefile

index 6ad326efa039f79829ad9c24b2c459e59ee5f12f..9f7a0724f4f0f6334570ed189fbe0a03913fd235 100644 (file)
@@ -84,7 +84,8 @@ CONFIGURE_ARGS += \
        --target=$(REAL_GNU_TARGET_NAME) \
        --enable-shared \
        --enable-install-libiberty \
-       --enable-install-libbfd
+       --enable-install-libbfd \
+       --enable-install-libctf
 
 define Build/Install
        $(call Build/Install/Default)
@@ -106,7 +107,7 @@ endef
 
 define Package/libctf/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libctf.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libctf*.so* $(1)/usr/lib/
 endef
 
 define Package/libopcodes/install