tools/elfutils: depend on m4
authorStijn Tintel <stijn@linux-ipv6.be>
Wed, 18 May 2022 13:15:09 +0000 (16:15 +0300)
committerStijn Tintel <stijn@linux-ipv6.be>
Wed, 18 May 2022 13:17:35 +0000 (16:17 +0300)
Some buildbots fail to build elfutils due to m4 being missing. Add m4 as
a dependency for elfutils to fix this.

Fixes: ad79b9271949 ("elfutils: move host build to tools")
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
tools/Makefile

index 507971c6d59f71a699af8c4b5276130c598aa957..be1a23ed512fb5f3edd1466f0df12495d93bde2d 100644 (file)
@@ -85,7 +85,7 @@ ifeq ($(HOST_OS),Darwin)
   tools-y += bash
 else
   $(curdir)/dwarves/compile += $(curdir)/elfutils/compile
-  $(curdir)/elfutils/compile := $(curdir)/zlib/compile
+  $(curdir)/elfutils/compile := $(curdir)/m4/compile $(curdir)/zlib/compile
   tools-$(CONFIG_DWARVES) += dwarves
   tools-y += elfutils
 endif