tools/ccache: add cmake dependency
authorRosen Penev <rosenp@gmail.com>
Mon, 7 Feb 2022 04:51:40 +0000 (20:51 -0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 28 Feb 2022 23:08:08 +0000 (00:08 +0100)
This will be needed for the next commit as ccache's cmake dependency is
satisfied by zstd currenly.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
tools/Makefile

index 681344a014fc74b2a3d90d7f43c90ac3b1c4f66c..a13c2e82b5a37b328d605c16cd9282d94ec3fd4b 100644 (file)
@@ -87,7 +87,7 @@ endif
 ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
 $(foreach tool, $(filter-out xz zstd pkgconf patch ninja meson libressl cmake,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/compile))
 tools-y += ccache
-$(curdir)/ccache/compile := $(curdir)/zstd/compile
+$(curdir)/ccache/compile := $(curdir)/cmake/compile $(curdir)/zstd/compile
 endif
 
 # in case there is no patch tool on the host we need to make patch tool a