tools/mm-macros: remove
authorRosen Penev <rosenp@gmail.com>
Thu, 16 Sep 2021 05:27:43 +0000 (22:27 -0700)
committerPaul Spooren <mail@aparcar.org>
Fri, 17 Sep 2021 02:27:32 +0000 (16:27 -1000)
ccaaab1c048159611e93a181dde740f49fa12483 says that this is in the
codebase because of libsigc++, which is not in the codebase anymore.
Neither in base nor in packages. It doesn't seem to be needed by
anything else either. GNOME packages have transitioned to using meson,
which does not use m4 files.

Tested local compile with CONFIG_ALL. No problems seen.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
tools/Makefile
tools/mm-macros/Makefile [deleted file]

index a48aa80db3ad88eb1a9371f8cf34bb24b22d3260..82a877379c26450468fd5b920b84936ad39dba77 100644 (file)
@@ -24,7 +24,7 @@ endif
 tools-y += autoconf autoconf-archive automake bc bison cmake cpio dosfstools
 tools-y += e2fsprogs fakeroot findutils firmware-utils flex gengetopt
 tools-y += libressl libtool lzma m4 make-ext4fs missing-macros mkimage
-tools-y += mklibs mm-macros mtd-utils mtools ninja padjffs2 patch-image
+tools-y += mklibs mtd-utils mtools ninja padjffs2 patch-image
 tools-y += patchelf pkgconf quilt squashfskit4 sstrip xxd zip zlib zstd
 tools-$(BUILD_B43_TOOLS) += b43-tools
 tools-$(BUILD_ISL) += isl
@@ -60,7 +60,6 @@ $(curdir)/make-ext4fs/compile := $(curdir)/zlib/compile
 $(curdir)/missing-macros/compile := $(curdir)/autoconf/compile
 $(curdir)/mkimage/compile += $(curdir)/libressl/compile
 $(curdir)/mklibs/compile := $(curdir)/libtool/compile
-$(curdir)/mm-macros/compile := $(curdir)/libtool/compile
 $(curdir)/mpc/compile := $(curdir)/mpfr/compile $(curdir)/gmp/compile
 $(curdir)/mpfr/compile := $(curdir)/gmp/compile
 $(curdir)/mtd-utils/compile := $(curdir)/libtool/compile $(curdir)/e2fsprogs/compile $(curdir)/zlib/compile
diff --git a/tools/mm-macros/Makefile b/tools/mm-macros/Makefile
deleted file mode 100644 (file)
index 0715633..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-#
-# Copyright (C) 2010-2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=mm-macros
-PKG_VERSION:=1.0.0
-
-PKG_SOURCE_URL:=@GNOME/mm-common/1.0
-PKG_SOURCE:=mm-common-$(PKG_VERSION).tar.xz
-PKG_HASH:=b97d9b041e5952486cab620b44ab09f6013a478f43b6699ae899b8a4da189cd4
-
-HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/mm-common-$(PKG_VERSION)
-
-HOST_FIXUP:=autoreconf
-
-include $(INCLUDE_DIR)/host-build.mk
-
-define Host/Install
-       $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/aclocal
-       $(INSTALL_DATA) $(HOST_BUILD_DIR)/macros/*.m4 $(STAGING_DIR_HOST)/share/aclocal/
-endef
-
-define Host/Clean
-       -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
-       $(call Host/Clean/Default)
-endef
-
-$(eval $(call HostBuild))