ramips: add support for Ubiquiti UniFi nanoHD
authorDavid Bauer <mail@david-bauer.net>
Sun, 8 Mar 2020 20:39:19 +0000 (21:39 +0100)
committerDavid Bauer <mail@david-bauer.net>
Tue, 10 Mar 2020 20:54:46 +0000 (21:54 +0100)
Hardware
--------
SoC:   MediaTek MT7621AT
WiFi:  MediaTek MT7603 bgn 2T2R
       MediaTek MT7615 ac  4T4R
Flash: 32M SPI (Macronix MX25L25635F)
RAM:   128M DDR3 (Winbond W631GG6KB)
LED:   Dome (Blue / White)
BTN:   Reset

Installation
------------

These instructions were written for firmware version v3.9.27.
Downgrade if necessary.

1. Copy the OpenWrt sysupgrade image to the devices /tmp folder
   via scp. On factory defaults, user and password is "ubnt" at
   192.168.1.20/24.

2. Write the bootselect flag. Otherwise, the device might boot from the
   wrong partition. Verify the mtd partition used in the command below
   is the one labled "bs" in /proc/mtd (as this might change in the
   future).

   > dd if=/dev/zero bs=1 count=1 of=/dev/mtd4

3. Write the OpenWrt sysupgrade to the mtd partitions labled
   "kernel0" and "kernel1".

   > dd if=/tmp/openwrt-sysupgrade.bin of=/dev/mtdblock6
   > dd if=/tmp/openwrt-sysupgrade.bin of=/dev/mtdblock7

4. Reboot or powercycle the device.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ramips/dts/mt7621_ubnt_unifi-nanohd.dts [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk
target/linux/ramips/mt7621/base-files/etc/board.d/02_network

diff --git a/target/linux/ramips/dts/mt7621_ubnt_unifi-nanohd.dts b/target/linux/ramips/dts/mt7621_ubnt_unifi-nanohd.dts
new file mode 100644 (file)
index 0000000..903cbc6
--- /dev/null
@@ -0,0 +1,141 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "ubnt,unifi-nanohd", "mediatek,mt7621-soc";
+       model = "Ubiquiti UniFi nanoHD";
+
+       aliases {
+               led-boot = &led_white;
+               led-failsafe = &led_white;
+               led-running = &led_blue;
+               led-upgrade = &led_blue;
+
+               label-mac-device = &ethernet;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_blue: dome_blue {
+                       label = "nanohd:blue:dome";
+                       gpios = <&gpio0 3 GPIO_ACTIVE_HIGH>;
+               };
+
+               led_white: dome_white {
+                       label = "nanohd:white:dome";
+                       gpios = <&gpio0 4 GPIO_ACTIVE_HIGH>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 12 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+};
+
+&spi0 {
+       status = "okay";
+
+       flash@0 {
+               compatible = "mx25l25635f", "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <50000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0x60000>;
+                               read-only;
+                       };
+
+                       partition@60000 {
+                               label = "u-boot-env";
+                               reg = <0x60000 0x10000>;
+                               read-only;
+                       };
+
+                       factory: partition@70000 {
+                               label = "factory";
+                               reg = <0x70000 0x10000>;
+                               read-only;
+                       };
+
+                       eeprom: partition@80000 {
+                               label = "eeprom";
+                               reg = <0x80000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@90000 {
+                               label = "bs";
+                               reg = <0x90000 0x10000>;
+                       };
+
+                       partition@a0000 {
+                               label = "cfg";
+                               reg = <0xa0000 0x100000>;
+                               read-only;
+                       };
+
+                       partition@1a0000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x1a0000 0xf30000>;
+                       };
+
+                       partition@10d0000 {
+                               label = "kernel1";
+                               reg = <0x10d0000 0xf30000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie0 {
+       wifi@0,0 {
+               reg = <0x0 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x0000>;
+       };
+};
+
+&pcie1 {
+       wifi@0,0 {
+               reg = <0x0 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x8000>;
+       };
+};
+
+&ethernet {
+       mtd-mac-address = <&eeprom 0x0>;
+};
+
+&state_default {
+       gpio {
+               ralink,group = "i2c", "uart2";
+               ralink,function = "gpio";
+       };
+};
index 98d83f944ffd97685f885df14861b377d6d62c85..f24830bfb79b81e6a676cac7331cc4d468639692 100644 (file)
@@ -792,6 +792,14 @@ define Device/ubiquiti_edgerouterx-sfp
 endef
 TARGET_DEVICES += ubiquiti_edgerouterx-sfp
 
+define Device/ubnt_unifi-nanohd
+  DEVICE_VENDOR := Ubiquiti
+  DEVICE_MODEL := UniFi nanoHD
+  DEVICE_PACKAGES += kmod-mt7603 kmod-mt7615e wpad-basic
+  IMAGE_SIZE := 15552k
+endef
+TARGET_DEVICES += ubnt_unifi-nanohd
+
 define Device/unielec_u7621-06-16m
   IMAGE_SIZE := 16064k
   DEVICE_VENDOR := UniElec
index c930f34592bf15ae9198ab90416bf50908af4d16..a68ffe6126289a377d7bf6aa21a6c2f4a2525490 100755 (executable)
@@ -129,7 +129,8 @@ ramips_setup_interfaces()
                ;;
        netgear,ex6150|\
        tplink,re350-v1|\
-       tplink,re650-v1)
+       tplink,re650-v1|\
+       ubnt,unifi-nanohd)
                ucidef_add_switch "switch0" \
                        "0:lan" "6@eth0"
                ;;