tools/expat: update to 2.4.6
authorRosen Penev <rosenp@gmail.com>
Fri, 18 Jun 2021 05:50:51 +0000 (22:50 -0700)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 28 Feb 2022 23:08:08 +0000 (00:08 +0100)
Switched to CMake for faster compilation and greater parallel
friendliness.

Added CMake options from the packages feed.

This release fixes various CVEs.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
tools/Makefile
tools/expat/Makefile

index 4c2aa1a1e969519c4551357936bf312f8c5b21bf..f3f9a3bf736c271a51ef875315d26c8dc2542395 100644 (file)
@@ -46,6 +46,7 @@ $(curdir)/bison/compile := $(curdir)/flex/compile
 $(curdir)/cbootimage/compile += $(curdir)/automake/compile
 $(curdir)/cmake/compile += $(curdir)/libressl/compile $(curdir)/ninja/compile
 $(curdir)/dosfstools/compile := $(curdir)/autoconf/compile $(curdir)/automake/compile
+$(curdir)/expat/compile := $(curdir)/cmake/compile
 $(curdir)/e2fsprogs/compile := $(curdir)/libtool/compile
 $(curdir)/fakeroot/compile := $(curdir)/libtool/compile
 $(curdir)/findutils/compile := $(curdir)/bison/compile
index cfc70b2a49d3e308e0a451733d3c416ea0813b82..0bc54a3d488b466664430b855ac3a92a358c0aab 100644 (file)
@@ -9,21 +9,25 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=expat
 PKG_CPE_ID:=cpe:/a:libexpat:expat
-PKG_VERSION:=2.2.10
+PKG_VERSION:=2.4.6
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_HASH:=b2c160f1b60e92da69de8e12333096aeb0c3bf692d41c60794de278af72135a5
+PKG_HASH:=ce317706b07cae150f90cddd4253f5b4fba929607488af5ac47bf2bc08e31f09
 PKG_SOURCE_URL:=https://github.com/libexpat/libexpat/releases/download/R_$(subst .,_,$(PKG_VERSION))
 
-HOST_BUILD_PARALLEL:=1
-
 include $(INCLUDE_DIR)/host-build.mk
-
-HOST_CONFIGURE_ARGS += \
-       --without-docbook
-
-define Host/Install
-       $(MAKE) -C $(HOST_BUILD_DIR) install
-endef
+include $(INCLUDE_DIR)/cmake.mk
+
+CMAKE_HOST_OPTIONS += \
+       -DDOCBOOK_TO_MAN=OFF \
+       -DEXPAT_BUILD_TOOLS=OFF \
+       -DEXPAT_BUILD_EXAMPLES=OFF \
+       -DEXPAT_BUILD_TESTS=OFF \
+       -DEXPAT_BUILD_DOCS=OFF \
+       -DEXPAT_WITH_LIBBSD=OFF \
+       -DEXPAT_ENABLE_INSTALL=ON \
+       -DEXPAT_DTD=OFF \
+       -DEXPAT_NS=OFF \
+       -DEXPAT_DEV_URANDOM=OFF
 
 $(eval $(call HostBuild))