lldp: remove calls to user/group_add/exists
authorJohn Crispin <john@openwrt.org>
Thu, 11 Sep 2014 12:28:22 +0000 (12:28 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 11 Sep 2014 12:28:22 +0000 (12:28 +0000)
use the new ipkg based mechanism

Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 42472

package/network/services/lldpd/Makefile
package/network/services/lldpd/files/lldpd.init

index 31367833ec555d650832c6bae833784207963018..0b858483be8af53f0d714efa893e65cd5e7457a3 100644 (file)
@@ -31,6 +31,7 @@ define Package/lldpd
   TITLE:=Link Layer Discovery Protocol daemon
   URL:=https://github.com/vincentbernat/lldpd/wiki
   DEPENDS:=+libevent2 +USE_EGLIBC:libbsd
+  USERID:=lldp:lldp
 endef
 
 define Package/lldpd/description
index 35999501f9729b1fc0072519fec888ee44f050fa..b2eea70fd3577ccce092a7df24b929bf281a726c 100644 (file)
@@ -50,9 +50,6 @@ start() {
        [ $enable_sonmp -gt 0 ] && append args '-s'
        [ $enable_edp -gt 0 ] && append args '-e'
 
-       user_exists  lldp 121 || user_add  lldp 121 129
-       group_exists lldp 129 || group_add lldp 129
-
        mkdir -p /var/run/lldp
        chown lldp:lldp /var/run/lldp