busybox: support V=c toplevel verboseness flag (#11799)
authorFlorian Fainelli <florian@openwrt.org>
Tue, 7 Aug 2012 16:08:11 +0000 (16:08 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 7 Aug 2012 16:08:11 +0000 (16:08 +0000)
Signed-off-by: Gregory M. Turner <gmt@malth.us>
SVN-Revision: 33035

package/busybox/Makefile

index ef7f51877b68ec87cc68d46ac8f222345b70e4d1..13aa28945ded2b098a0a0662ee828587b54f9230 100644 (file)
@@ -26,6 +26,12 @@ ifeq ($(DUMP),)
   STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell $(SH_FUNC) grep '^CONFIG_BUSYBOX_' $(TOPDIR)/.config | md5s)
 endif
 
+ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
+  BB_MAKE_VERBOSE := V=1
+else
+  BB_MAKE_VERBOSE :=
+endif
+
 init-y :=
 init-$(CONFIG_BUSYBOX_CONFIG_HTTPD) += httpd
 init-$(CONFIG_BUSYBOX_CONFIG_CROND) += cron
@@ -58,6 +64,7 @@ define Build/Configure
                CROSS_COMPILE="$(TARGET_CROSS)" \
                KBUILD_HAVE_NLS=no \
                ARCH="$(ARCH)" \
+               $(BB_MAKE_VERBOSE) \
                oldconfig
 endef
 
@@ -81,6 +88,7 @@ define Build/Compile
                ARCH="$(ARCH)" \
                SKIP_STRIP=y \
                LDLIBS="$(LDLIBS)" \
+               $(BB_MAKE_VERBOSE) \
                all
        rm -rf $(PKG_INSTALL_DIR)
        $(FIND) $(PKG_BUILD_DIR) -lname "*busybox" -exec rm \{\} \;
@@ -91,6 +99,7 @@ define Build/Compile
                ARCH="$(ARCH)" \
                CONFIG_PREFIX="$(PKG_INSTALL_DIR)" \
                LDLIBS="$(LDLIBS)" \
+               $(BB_MAKE_VERBOSE) \
                install
 endef