imagebuilder: fix broken image generation with external targets
authorPetr Štetiar <ynezz@true.cz>
Thu, 24 Mar 2022 05:52:37 +0000 (06:52 +0100)
committerPetr Štetiar <ynezz@true.cz>
Fri, 25 Mar 2022 13:28:00 +0000 (14:28 +0100)
When using external targets there is a symlink being created for the
target under target/linux which then becomes dangling under Image
Builder. Fix it by dereferencing the possible symlink.

Tested on IB with external target, ipq40xx and mvebu.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/imagebuilder/Makefile

index 8607a2d7094c6bd63e12b65f44ce717d32bcc768..3bbadc7204d1e8859cbf363ae3101b753b08422f 100644 (file)
@@ -78,7 +78,7 @@ ifneq ($(CONFIG_SIGNATURE_CHECK),)
        $(CP) -L $(STAGING_DIR_ROOT)/usr/sbin/opkg-key $(PKG_BUILD_DIR)/scripts/
 endif
 
-       $(CP) $(TOPDIR)/target/linux $(PKG_BUILD_DIR)/target/
+       $(CP) -L $(TOPDIR)/target/linux $(PKG_BUILD_DIR)/target/
        if [ -d $(TOPDIR)/staging_dir/host/lib/grub ]; then \
                $(CP) $(TOPDIR)/staging_dir/host/lib/grub/ $(PKG_BUILD_DIR)/staging_dir/host/lib; \
        fi