lantiq: fix dsl_control status handling.
authorMartin Schiller <ms@dev.tdt.de>
Mon, 23 Sep 2019 07:50:24 +0000 (09:50 +0200)
committerDavid Bauer <mail@david-bauer.net>
Tue, 15 Oct 2019 21:23:08 +0000 (23:23 +0200)
Commit 7519a36774ca ("base-files,procd: add generic service status")
introduced the generic 'status' command which broke the previous
dsl_control status output. To fix this, let's rename the "old" command
to "dslstat".

Fixes: 7519a36774ca ("base-files,procd: add generic service status")
Signed-off-by: Martin Schiller <ms@dev.tdt.de>
package/network/config/ltq-adsl-app/Makefile
package/network/config/ltq-adsl-app/files/dsl_control
package/network/config/ltq-vdsl-app/Makefile
package/network/config/ltq-vdsl-app/files/dsl_control
target/linux/lantiq/base-files/lib/functions/lantiq_dsl.sh

index 3fa9f67d32893a15466b7145c2d9626da374236c..98c22a655f43cec02e32462ec63a2d9565d6bb72 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=dsl_cpe_control_danube
 PKG_VERSION:=3.24.4.4
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_BUILD_DIR:=$(BUILD_DIR)/dsl_cpe_control-$(PKG_VERSION)
 PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources/
index 91fcb46beb82ae3d9cc196534f82420f0e3c7036..b6aa72c0e7b4552ba9960298b34720a8054a26c7 100644 (file)
@@ -4,9 +4,9 @@
 START=97
 USE_PROCD=1
 
-EXTRA_COMMANDS="status lucistat"
-EXTRA_HELP="   status  Get DSL status information
-       lucistat  Get status information if lua friendly format"
+EXTRA_COMMANDS="dslstat lucistat"
+EXTRA_HELP="   dslstat Get DSL status information
+       lucistat Get status information in lua friendly format"
 
 [ -f /lib/functions/lantiq_dsl.sh ] && . /lib/functions/lantiq_dsl.sh
 
index e2ecefa25896ec5c90ea4d593506e2e9296fa1d2..198841977c4dae02acf99f724f9386d8f1b3ff35 100644 (file)
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ltq-vdsl-app
 PKG_VERSION:=4.17.18.6
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_BASE_NAME:=dsl_cpe_control
 PKG_SOURCE:=$(PKG_BASE_NAME)_vrx-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
index e62a5e558cf87a21a7ad2aeac131d97e5e68b8e9..dfaf06872d3785a5a88d43815ce358106f4b1029 100644 (file)
@@ -4,9 +4,9 @@
 START=97
 USE_PROCD=1
 
-EXTRA_COMMANDS="status lucistat"
-EXTRA_HELP="   status  Get DSL status information
-       lucistat  Get status information if lua friendly format"
+EXTRA_COMMANDS="dslstat lucistat"
+EXTRA_HELP="   dslstat Get DSL status information
+       lucistat Get status information in lua friendly format"
 
 [ -f /lib/functions/lantiq_dsl.sh ] && . /lib/functions/lantiq_dsl.sh
 
index cbdec1279cfde6de6abd610bd7953f7a11c4c8c8..11b02fc4aa397f368b38182d737dc6686bdeb8de 100755 (executable)
@@ -728,7 +728,7 @@ profile() {
        fi
 }
 
-status() {
+dslstat() {
        vendor
        chipset
        xtse
@@ -744,6 +744,6 @@ status() {
 
 lucistat() {
        echo "local dsl={}"
-       status
+       dslstat
        echo "return dsl"
 }