kernel: bump 5.4 to 5.4.169
authorJohn Audia <graysky@archlinux.us>
Wed, 29 Dec 2021 15:23:53 +0000 (10:23 -0500)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 3 Jan 2022 00:00:03 +0000 (01:00 +0100)
All patches automatically rebased.

Build system: x86_64
Build-tested: ramips/mt7621*

*Had to revert 7f1edbd in order to build due to FS#4149

Signed-off-by: John Audia <graysky@archlinux.us>
include/kernel-version.mk
target/linux/generic/backport-5.4/782-net-next-1-of-net-pass-the-dst-buffer-to-of_get_mac_address.patch
target/linux/generic/pending-5.4/820-libata-Assign-OF-node-to-the-SCSI-device.patch
target/linux/ipq40xx/patches-5.4/0005-01-v5.8-net-phy-mdio-add-IPQ4019-MDIO-driver.patch
target/linux/ipq40xx/patches-5.4/705-net-add-qualcomm-ar40xx-phy.patch
target/linux/ipq40xx/patches-5.4/707-net-phy-Add-Qualcom-QCA807x-driver.patch
target/linux/layerscape/patches-5.4/701-net-0327-at803x-Address-packet-drops-at-low-traffic-rate-due-.patch
target/linux/layerscape/patches-5.4/701-net-0328-net-phy-Inphi-IN112525_s03-retimer-support.patch
target/linux/realtek/patches-5.4/705-add-rtl-phy.patch

index ae0d01e74d9e89c4916a58b9f733cddebdd4a235..456aaf7dba791a77810505cb4f594828eb2e2593 100644 (file)
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .167
+LINUX_VERSION-5.4 = .169
 LINUX_VERSION-5.10 = .88
 
-LINUX_KERNEL_HASH-5.4.167 = b4e43116217ee02009aba7eab3081e64560b81ce42bc6096fcd81257f470a5a7
+LINUX_KERNEL_HASH-5.4.169 = 554382d95f71afd5f9b49292eb5d1cbe3be1a0bad22d21487c9e6d506ee01a19
 LINUX_KERNEL_HASH-5.10.88 = 6f8631b6c382a2b0cfeff1e5f8805c8e1cfbe8d714b6e65f5bb79733c99068eb
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 764fa79d25e9031c9682892a398d4f13583bcb26..31e1781ee002fe788a7d2ccdfdb2339cd996c50e 100644 (file)
@@ -334,7 +334,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        }
 --- a/drivers/net/ethernet/broadcom/bcmsysport.c
 +++ b/drivers/net/ethernet/broadcom/bcmsysport.c
-@@ -2420,7 +2420,6 @@ static int bcm_sysport_probe(struct plat
+@@ -2423,7 +2423,6 @@ static int bcm_sysport_probe(struct plat
        struct bcm_sysport_priv *priv;
        struct device_node *dn;
        struct net_device *dev;
@@ -342,7 +342,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        u32 txq, rxq;
        int ret;
  
-@@ -2502,12 +2501,10 @@ static int bcm_sysport_probe(struct plat
+@@ -2505,12 +2504,10 @@ static int bcm_sysport_probe(struct plat
        }
  
        /* Initialize netdevice members */
index bec9363fa157550cd376641f1c9e26d5e52820b3..c4cbaaa77775e93503a43bc84c96295e8e77f7fa 100644 (file)
@@ -41,7 +41,7 @@ ChangeLog v1->v2:
  
  #include "libata.h"
  #include "libata-transport.h"
-@@ -4579,6 +4580,34 @@ int ata_scsi_add_hosts(struct ata_host *
+@@ -4590,6 +4591,34 @@ int ata_scsi_add_hosts(struct ata_host *
        return rc;
  }
  
@@ -76,7 +76,7 @@ ChangeLog v1->v2:
  void ata_scsi_scan_host(struct ata_port *ap, int sync)
  {
        int tries = 5;
-@@ -4604,6 +4633,7 @@ void ata_scsi_scan_host(struct ata_port
+@@ -4615,6 +4644,7 @@ void ata_scsi_scan_host(struct ata_port
                                                 NULL);
                        if (!IS_ERR(sdev)) {
                                dev->sdev = sdev;
index d678f761f516595cf58825e3952c5646ca97600c..b48e922fb0adbfd7c0e48b86aef8bf0aad824ac0 100644 (file)
@@ -37,7 +37,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        depends on ARCH_MOXART || COMPILE_TEST
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -50,6 +50,7 @@ obj-$(CONFIG_MDIO_CAVIUM)    += mdio-cavium
+@@ -49,6 +49,7 @@ obj-$(CONFIG_MDIO_CAVIUM)    += mdio-cavium
  obj-$(CONFIG_MDIO_GPIO)               += mdio-gpio.o
  obj-$(CONFIG_MDIO_HISI_FEMAC) += mdio-hisi-femac.o
  obj-$(CONFIG_MDIO_I2C)                += mdio-i2c.o
index 9adddcabc3867cefe6362f37bef5e20fed717907..6315a81527c6e8bc234e8f64d4baab06edd53bac 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -584,6 +584,13 @@ config XILINX_GMII2RGMII
+@@ -580,6 +580,13 @@ config XILINX_GMII2RGMII
          the Reduced Gigabit Media Independent Interface(RGMII) between
          Ethernet physical media devices and the Gigabit Ethernet controller.
  
@@ -16,7 +16,7 @@
  config MICREL_KS8995MA
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -69,6 +69,7 @@ ifdef CONFIG_HWMON
+@@ -68,6 +68,7 @@ ifdef CONFIG_HWMON
  aquantia-objs                 += aquantia_hwmon.o
  endif
  obj-$(CONFIG_AQUANTIA_PHY)    += aquantia.o
index b71b28d941c5092ee3ee5b7cf71573e706903835..3bd88d15058ce2ec0a971afc0f642d3d5a6ddc37 100644 (file)
@@ -25,7 +25,7 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
 
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -537,6 +537,12 @@ config NXP_TJA11XX_PHY
+@@ -533,6 +533,12 @@ config NXP_TJA11XX_PHY
        ---help---
          Currently supports the NXP TJA1100 and TJA1101 PHY.
  
@@ -40,7 +40,7 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
        ---help---
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -103,6 +103,7 @@ obj-$(CONFIG_MICROSEMI_PHY)        += mscc.o
+@@ -102,6 +102,7 @@ obj-$(CONFIG_MICROSEMI_PHY)        += mscc.o
  obj-$(CONFIG_NATIONAL_PHY)    += national.o
  obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
  obj-$(CONFIG_QSEMI_PHY)               += qsemi.o
index f8dda3a22df3e0ac1f189390a12e22d048da8dbc..babecdecb7b77b01fbafce1d6f40dbc8195d42f8 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Vladimir Oltean <vladimir.oltean@nxp.com>
 
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -367,6 +367,16 @@ config AT803X_PHY
+@@ -363,6 +363,16 @@ config AT803X_PHY
        ---help---
          Currently supports the AT8030 and AT8035 model
  
index 68a0bc4eaa1066cebf60bc333655e2ccf2cdf0f5..dcb6071e287f641ec251cf403784611029aeb933 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Florin Chiculita <florinlaurentiu.chiculita@nxp.com>
 
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -475,6 +475,11 @@ config ICPLUS_PHY
+@@ -471,6 +471,11 @@ config ICPLUS_PHY
        ---help---
          Currently supports the IP175C and IP1001 PHYs.
  
@@ -29,7 +29,7 @@ Signed-off-by: Florin Chiculita <florinlaurentiu.chiculita@nxp.com>
        ---help---
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -87,6 +87,7 @@ obj-$(CONFIG_DP83848_PHY)    += dp83848.o
+@@ -86,6 +86,7 @@ obj-$(CONFIG_DP83848_PHY)    += dp83848.o
  obj-$(CONFIG_DP83867_PHY)     += dp83867.o
  obj-$(CONFIG_FIXED_PHY)               += fixed_phy.o
  obj-$(CONFIG_ICPLUS_PHY)      += icplus.o
index f4cd8f2d6d7a68459370142c1ae88477632e93cb..1ab9e212d48108a409ec49032aa98a386fed1d05 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -540,6 +540,12 @@ config REALTEK_PHY
+@@ -536,6 +536,12 @@ config REALTEK_PHY
        ---help---
          Supports the Realtek 821x PHY.
  
@@ -15,7 +15,7 @@
        ---help---
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -102,6 +102,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o
+@@ -101,6 +101,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o
  obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
  obj-$(CONFIG_QSEMI_PHY)               += qsemi.o
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o