kernel: bump 4.14 to 4.14.201
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 14 Oct 2020 11:14:57 +0000 (13:14 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 14 Oct 2020 15:18:54 +0000 (17:18 +0200)
Refreshed all patches.

Fixes:
- CVE-2020-14386

Compile-tested on: ar71xx, cns3xxx, imx6, x86_64
Runtime-tested on: ar71xx, cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm2708/patches-4.14/950-0034-mm-Remove-the-PFN-busy-warning.patch
target/linux/generic/backport-4.14/320-v4.16-netfilter-nf_conntrack-add-IPS_OFFLOAD-status-bit.patch
target/linux/generic/hack-4.14/700-swconfig_switch_drivers.patch
target/linux/generic/pending-4.14/120-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch
target/linux/generic/pending-4.14/630-packet_socket_type.patch
target/linux/ipq40xx/patches-4.14/700-net-add-qualcomm-mdio-and-phy.patch
target/linux/layerscape/patches-4.14/202-core-linux-support-layerscape.patch
target/linux/layerscape/patches-4.14/709-mdio-phy-support-layerscape.patch
target/linux/uml/patches-4.14/101-mconsole-exec.patch

index d894d865a87afdece71d63b0c071b6692bc58826..67dec3c20e61192c221d9974925b8a5238aeec35 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .200
+LINUX_VERSION-4.14 = .201
 
-LINUX_KERNEL_HASH-4.14.200 = 5d404a0224a34b5379f1871cc46825487d557c2660459d2b5c3cd4871d699a38
+LINUX_KERNEL_HASH-4.14.201 = e228dc406c433df4d78c8e877230cc3899c1088c295de8f0d948fc766ae1235b
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 21a3d50dfacf733b29f5001173ea45753705c9ab..d91a7301d29b2423411931be93c60e90878dd615 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Eric Anholt <eric@anholt.net>
 
 --- a/mm/page_alloc.c
 +++ b/mm/page_alloc.c
-@@ -7626,8 +7626,6 @@ int alloc_contig_range(unsigned long sta
+@@ -7629,8 +7629,6 @@ int alloc_contig_range(unsigned long sta
  
        /* Make sure the range is really isolated. */
        if (test_pages_isolated(outer_start, end, false)) {
index 885d632d22db4d56ce668cc45525aa17b0c086e9..6390cc4f2b1c50e7ae81e7456b00c6edb890f764 100644 (file)
@@ -90,7 +90,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
                                expired_count++;
 --- a/net/netfilter/nf_conntrack_netlink.c
 +++ b/net/netfilter/nf_conntrack_netlink.c
-@@ -1123,6 +1123,14 @@ static const struct nla_policy ct_nla_po
+@@ -1125,6 +1125,14 @@ static const struct nla_policy ct_nla_po
                                    .len = NF_CT_LABELS_MAX_SIZE },
  };
  
@@ -105,7 +105,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  static int ctnetlink_flush_conntrack(struct net *net,
                                     const struct nlattr * const cda[],
                                     u32 portid, int report)
-@@ -1135,7 +1143,7 @@ static int ctnetlink_flush_conntrack(str
+@@ -1137,7 +1145,7 @@ static int ctnetlink_flush_conntrack(str
                        return PTR_ERR(filter);
        }
  
@@ -114,7 +114,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
                                  portid, report);
        kfree(filter);
  
-@@ -1181,6 +1189,11 @@ static int ctnetlink_del_conntrack(struc
+@@ -1183,6 +1191,11 @@ static int ctnetlink_del_conntrack(struc
  
        ct = nf_ct_tuplehash_to_ctrack(h);
  
index f9df4755008f57edcfeb9eca9fb54b4297271897..c49383e8a7d738f13f6c8721fece12e4481a97e8 100644 (file)
@@ -12,7 +12,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -198,6 +198,89 @@ config LED_TRIGGER_PHY
+@@ -199,6 +199,89 @@ config LED_TRIGGER_PHY
                <Speed in megabits>Mbps or <Speed in gigabits>Gbps
  
  
index 53b1a9a13c42a1d4804e56ae9e831ac27c1ff4b2..c6f82991e10bcf337fdc67b53db3b69aaef9addf 100644 (file)
@@ -71,7 +71,7 @@ Signed-off-by: Tobias Wolf <dev-NTEO@vplace.de>
 
 --- a/mm/page_alloc.c
 +++ b/mm/page_alloc.c
-@@ -6151,7 +6151,7 @@ static void __ref alloc_node_mem_map(str
+@@ -6152,7 +6152,7 @@ static void __ref alloc_node_mem_map(str
                mem_map = NODE_DATA(0)->node_mem_map;
  #if defined(CONFIG_HAVE_MEMBLOCK_NODE_MAP) || defined(CONFIG_FLATMEM)
                if (page_to_pfn(mem_map) != pgdat->node_start_pfn)
index 36405692139340ffeefc370ac45c6414e234fdcf..e9b40b18c62067923e7b50a96ab7658d6c8bd4a5 100644 (file)
@@ -71,7 +71,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -2216,12 +2218,12 @@ static int tpacket_rcv(struct sk_buff *s
+@@ -2217,12 +2219,12 @@ static int tpacket_rcv(struct sk_buff *s
        BUILD_BUG_ON(TPACKET_ALIGN(sizeof(*h.h2)) != 32);
        BUILD_BUG_ON(TPACKET_ALIGN(sizeof(*h.h3)) != 48);
  
@@ -87,7 +87,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -3318,6 +3320,7 @@ static int packet_create(struct net *net
+@@ -3325,6 +3327,7 @@ static int packet_create(struct net *net
        mutex_init(&po->pg_vec_lock);
        po->rollover = NULL;
        po->prot_hook.func = packet_rcv;
@@ -95,7 +95,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
-@@ -3940,6 +3943,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3947,6 +3950,16 @@ packet_setsockopt(struct socket *sock, i
                po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
                return 0;
        }
@@ -112,7 +112,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        default:
                return -ENOPROTOOPT;
        }
-@@ -3992,6 +4005,13 @@ static int packet_getsockopt(struct sock
+@@ -3999,6 +4012,13 @@ static int packet_getsockopt(struct sock
        case PACKET_VNET_HDR:
                val = po->has_vnet_hdr;
                break;
index 00cfa3ab9be9eededa3c60631d47d0d6dc0f0dc1..a185653747d8ff63b65a60e9c286a5a98d0aeff3 100644 (file)
@@ -10,7 +10,7 @@ Subject: [PATCH 30/38] NET: add qualcomm mdio and PHY
 
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -481,6 +481,20 @@ config XILINX_GMII2RGMII
+@@ -482,6 +482,20 @@ config XILINX_GMII2RGMII
          the Reduced Gigabit Media Independent Interface(RGMII) between
          Ethernet physical media devices and the Gigabit Ethernet controller.
  
index 2dd5b176038bbc9e9c1282ee7f6badfc6736def4..90352580fd88de2404c85bb4a71a0a5c73cb23dd 100644 (file)
@@ -623,7 +623,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  EXPORT_SYMBOL(dma_noop_ops);
 --- a/mm/page_alloc.c
 +++ b/mm/page_alloc.c
-@@ -4372,8 +4372,14 @@ void page_frag_free(void *addr)
+@@ -4373,8 +4373,14 @@ void page_frag_free(void *addr)
  {
        struct page *page = virt_to_head_page(addr);
  
index 17fe50cdd5e68967e2989b7b3371bd790d3efd16..9eadf2bfda02b76b08e09d12addafaa45898e10e 100644 (file)
@@ -70,7 +70,7 @@ Signed-off-by: Vladimir Oltean <vladimir.oltean@nxp.com>
  config MDIO_GPIO
        tristate "GPIO lib-based bitbanged MDIO buses"
        depends on MDIO_BITBANG && GPIOLIB
-@@ -303,6 +321,16 @@ config AT803X_PHY
+@@ -304,6 +322,16 @@ config AT803X_PHY
        ---help---
          Currently supports the AT8030 and AT8035 model
  
@@ -87,7 +87,7 @@ Signed-off-by: Vladimir Oltean <vladimir.oltean@nxp.com>
  config BCM63XX_PHY
        tristate "Broadcom 63xx SOCs internal PHY"
        depends on BCM63XX
-@@ -385,6 +413,11 @@ config ICPLUS_PHY
+@@ -386,6 +414,11 @@ config ICPLUS_PHY
        ---help---
          Currently supports the IP175C and IP1001 PHYs.
  
index 2acb519323e2ea7860cfd231e875ea9b1388e08a..c775ccc69140e486dc83e3ca47354c940179d99e 100644 (file)
        int (*init)(struct subprocess_info *info, struct cred *new);
 --- a/kernel/umh.c
 +++ b/kernel/umh.c
-@@ -25,6 +25,7 @@
+@@ -26,6 +26,7 @@
  #include <linux/ptrace.h>
  #include <linux/async.h>
  #include <linux/uaccess.h>
  
  #include <trace/events/module.h>
  
-@@ -70,6 +71,28 @@ static int call_usermodehelper_exec_asyn
+@@ -71,6 +72,28 @@ static int call_usermodehelper_exec_asyn
        flush_signal_handlers(current, 1);
        spin_unlock_irq(&current->sighand->siglock);
  
 +      }
 +
        /*
-        * Our parent (unbound workqueue) runs with elevated scheduling
-        * priority. Avoid propagating that into the userspace child.
-@@ -393,6 +416,20 @@ struct subprocess_info *call_usermodehel
+        * Initial kernel threads share ther FS with init, in order to
+        * get the init root directory. But we've now created a new
+@@ -402,6 +425,20 @@ struct subprocess_info *call_usermodehel
  }
  EXPORT_SYMBOL(call_usermodehelper_setup);