libnl-tiny: update to latest Git head
authorPetr Štetiar <ynezz@true.cz>
Mon, 7 Oct 2019 14:34:17 +0000 (16:34 +0200)
committerPetr Štetiar <ynezz@true.cz>
Wed, 6 Nov 2019 15:31:42 +0000 (16:31 +0100)
Includes following changes:

 0230d0698e59 add initial GitLab CI support
 5e13b797a988 iron out all extra compiler warnings
 802fbd4d6f39 cmake: enable extra compiler checks
 050bb5c4431b convert into CMake project
 5b350e42d1fd refactor into separate Git project

and converts the package build to utilize CMake.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/libs/libnl-tiny/Makefile

index b13d13d3c5a04b0c92d3f2b66d0da25c01f8d647..4fde17a3655e02b8ed529e424a8e0b261d0b83d7 100644 (file)
@@ -12,14 +12,16 @@ PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/libnl-tiny.git
-PKG_SOURCE_DATE:=2017-11-16
-PKG_SOURCE_VERSION:=8ee5f3a4023f822d1c916bb2b5e845d3597ac674
-PKG_MIRROR_HASH:=4ec0e67dc3234858da513832906f653e3644a261ac043cbeb95f3a3591daed86
+PKG_SOURCE_DATE:=2019-10-04
+PKG_SOURCE_VERSION:=0230d0698e596ab2e836abd2459d970b14bacb25
+PKG_MIRROR_HASH:=a2543a577a91fbf9ee7fe662a1e2675da1d65d2f56bba8471a2cfe2ddd1cd46a
+CMAKE_INSTALL:=1
 
 PKG_LICENSE:=LGPL-2.1
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
 
 define Package/libnl-tiny
   SECTION:=libs
@@ -31,25 +33,16 @@ define Package/libnl-tiny/description
  This package contains a stripped down version of libnl
 endef
 
-TARGET_CFLAGS += $(FPIC)
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)/src \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               all
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig $(1)/usr/include/libnl-tiny
-       $(CP) $(PKG_BUILD_DIR)/src/include/* $(1)/usr/include/libnl-tiny
-       $(CP) $(PKG_BUILD_DIR)/src/libnl-tiny.so $(1)/usr/lib/
-       $(CP) $(PKG_BUILD_DIR)/files/libnl-tiny.pc $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/libnl-tiny/* $(1)/usr/include/libnl-tiny
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libnl-tiny.so $(1)/usr/lib/
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/libnl-tiny.pc $(1)/usr/lib/pkgconfig
 endef
 
 define Package/libnl-tiny/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/src/libnl-tiny.so $(1)/usr/lib/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libnl-tiny.so $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libnl-tiny))