ath79: add support for Dongwon T&I DW02-412H
authorJihoon Han <rapid_renard@renard.ga>
Fri, 1 Oct 2021 05:53:06 +0000 (14:53 +0900)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 31 Oct 2021 20:58:28 +0000 (21:58 +0100)
Dongwon T&I DW02-412H is a 2.4/5GHz band 11ac (WiFi-5) router, based on
Qualcomm Atheros QCA9557.

Specifications
--------------

- SoC: Qualcomm Atheros QCA9557-AT4A
- RAM: DDR2 128MB
- Flash: SPI NOR 2MB (Winbond W25Q16DVSSIG / ESMT F25L16PA(2S)) +
         NAND 64/128MB
- WiFi:
  - 2.4GHz: QCA9557 WMAC
  - 5GHz: QCA9882-BR4A
- Ethernet: 5x 10/100/1000Mbps
  - Switch: QCA8337N-AL3C
- USB: 1x USB 2.0
- UART:
  - JP2: 3.3V, TX, RX, GND (3.3V is the square pad) / 115200 8N1

Installation
--------------

1.  Connect a serial interface to UART header and
    interrupt the autostart of kernel.
2.  Transfer the factory image via TFTP and write it to the NAND flash.
3.  Update U-Boot environment variable.
    > tftpboot 0x81000000 <your image>-factory.img
    > nand erase 0x1000000
    > nand write 0x81000000 0x1000000 ${filesize}
    > setenv bootpart 2
    > saveenv

Revert to stock firmware
--------------

1.  Revert to stock U-Boot environment variable.
    > setenv bootpart 1
    > saveenv

MAC addresses as verified by OEM firmware
--------------

   WAN: *:XX (label)
   LAN: *:XX + 1
  2.4G: *:XX + 3
    5G: *:XX + 4

The label MAC address was found in art 0x0.

Credits
--------------

Credit goes to the @manatails who first developed how to port OpenWRT
to this device and had a significant impact on this patch.

And thanks to @adschm and @mans0n for guiding me to revise the code
in many ways.

Signed-off-by: Jihoon Han <rapid_renard@renard.ga>
Reviewed-by: Sungbo Eo <mans0n@gorani.run>
Tested-by: Sungbo Eo <mans0n@gorani.run>
package/boot/uboot-envtools/files/ath79
target/linux/ath79/dts/qca9557_dongwon_dw02-412h-128m.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9557_dongwon_dw02-412h-64m.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9557_dongwon_dw02-412h.dtsi [new file with mode: 0644]
target/linux/ath79/image/nand.mk
target/linux/ath79/nand/base-files/etc/board.d/01_leds
target/linux/ath79/nand/base-files/etc/board.d/02_network
target/linux/ath79/nand/base-files/etc/hotplug.d/firmware/11-ath10k-caldata

index 91ba587bf8f6532dc31e0b4c9cece7ba74fedd1d..00339dcbcce94a57778cc4167b0be13f6bb61745 100644 (file)
@@ -77,9 +77,8 @@ buffalo,wzr-hp-g300nh-s)
 domywifi,dw33d)
        ubootenv_add_uci_config "/dev/mtd4" "0x0" "0x10000" "0x10000"
        ;;
-glinet,gl-ar150)
-       ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x8000" "0x10000"
-       ;;
+dongwon,dw02-412h-64m|\
+dongwon,dw02-412h-128m|\
 glinet,gl-ar300m-lite|\
 glinet,gl-ar300m-nand|\
 glinet,gl-ar300m-nor|\
@@ -88,6 +87,9 @@ glinet,gl-ar300m16)
        [ -n "$idx" ] && \
                ubootenv_add_uci_config "/dev/mtd$idx" "0x0" "0x10000" "0x10000"
        ;;
+glinet,gl-ar150)
+       ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x8000" "0x10000"
+       ;;
 netgear,wndr3700|\
 netgear,wndr3700-v2|\
 netgear,wndrmac-v1)
diff --git a/target/linux/ath79/dts/qca9557_dongwon_dw02-412h-128m.dts b/target/linux/ath79/dts/qca9557_dongwon_dw02-412h-128m.dts
new file mode 100644 (file)
index 0000000..2308d82
--- /dev/null
@@ -0,0 +1,34 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9557_dongwon_dw02-412h.dtsi"
+
+/ {
+       model = "Dongwon T&I DW02-412H (128M)";
+       compatible = "dongwon,dw02-412h-128m", "qca,qca9557";
+};
+
+&nand {
+       status = "okay";
+
+       partitions {
+               compatible = "fixed-partitions";
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "current";
+                       reg = <0x0 0x1000000>;
+                       read-only;
+               };
+
+               partition@1000000 {
+                       label = "kernel";
+                       reg = <0x1000000 0x800000>;
+               };
+
+               partition@1800000 {
+                       label = "ubi";
+                       reg = <0x1800000 0x6800000>;
+               };
+       };
+};
diff --git a/target/linux/ath79/dts/qca9557_dongwon_dw02-412h-64m.dts b/target/linux/ath79/dts/qca9557_dongwon_dw02-412h-64m.dts
new file mode 100644 (file)
index 0000000..2420dc1
--- /dev/null
@@ -0,0 +1,34 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9557_dongwon_dw02-412h.dtsi"
+
+/ {
+       model = "Dongwon T&I DW02-412H (64M)";
+       compatible = "dongwon,dw02-412h-64m", "qca,qca9557";
+};
+
+&nand {
+       status = "okay";
+
+       partitions {
+               compatible = "fixed-partitions";
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "current";
+                       reg = <0x0 0x1000000>;
+                       read-only;
+               };
+
+               partition@1000000 {
+                       label = "kernel";
+                       reg = <0x1000000 0x800000>;
+               };
+
+               partition@1800000 {
+                       label = "ubi";
+                       reg = <0x1800000 0x2800000>;
+               };
+       };
+};
diff --git a/target/linux/ath79/dts/qca9557_dongwon_dw02-412h.dtsi b/target/linux/ath79/dts/qca9557_dongwon_dw02-412h.dtsi
new file mode 100644 (file)
index 0000000..fd56983
--- /dev/null
@@ -0,0 +1,175 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca955x.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       aliases {
+               led-boot = &led_wan;
+               led-failsafe = &led_wan;
+               led-upgrade = &led_wan;
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               wps {
+                       label = "WPS button";
+                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_WPS_BUTTON>;
+               };
+
+               reset {
+                       label = "Reset button";
+                       gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_wan: wan {
+                       label = "green:wan";
+                       gpios = <&gpio 22 GPIO_ACTIVE_LOW>;
+               };
+
+               wlan {
+                       label = "green:wlan";
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&spi {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <50000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x040000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "u-boot-env";
+                               reg = <0x040000 0x010000>;
+                       };
+
+                       partition@50000 {
+                               label = "log";
+                               reg = <0x050000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@60000 {
+                               label = "recoverk";
+                               reg = <0x060000 0x0e0000>;
+                               read-only;
+                       };
+
+                       partition@140000 {
+                               label = "recoverr";
+                               reg = <0x140000 0x090000>;
+                               read-only;
+                       };
+
+                       partition@1d0000 {
+                               label = "nvram";
+                               reg = <0x1d0000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@1e0000 {
+                               label = "nvbackup";
+                               reg = <0x1e0000 0x010000>;
+                               read-only;
+                       };
+
+                       art: partition@1f0000 {
+                               label = "art";
+                               reg = <0x1f0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&pcie0 {
+       status = "okay";
+
+       wifi@0,0 {
+               compatible = "qcom,ath10k";
+               reg = <0 0 0 0 0>;
+       };
+};
+
+&wmac {
+       status = "okay";
+
+       mtd-cal-data = <&art 0x1000>;
+       nvmem-cells = <&macaddr_art_0>;
+       nvmem-cell-names = "mac-address";
+       mac-address-increment = <3>;
+};
+
+&usb_phy0 {
+       status = "okay";
+};
+
+&usb0 {
+       status = "okay";
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy0: ethernet-phy@0 {
+               reg = <0>;
+
+               qca,ar8327-initvals = <
+                       0x04 0x07600000 /* PORT0 PAD MODE CTRL */
+                       0x50 0xcf37cf37 /* LED Control Register 0 */
+                       0x54 0x00000000 /* LED Control Register 1 */
+                       0x58 0x00000000 /* LED Control Register 2 */
+                       0x5c 0x0030c300 /* LED Control Register 3 */
+                       0x7c 0x0000007e /* PORT0_STATUS */
+                       >;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       nvmem-cells = <&macaddr_art_0>;
+       nvmem-cell-names = "mac-address";
+       mac-address-increment = <1>;
+       phy-handle = <&phy0>;
+       pll-data = <0xa6000000 0x00000101 0x00001616>;
+
+       gmac-config {
+               device = <&gmac>;
+               rgmii-enabled = <1>;
+       };
+};
+
+&art {
+       compatible = "nvmem-cells";
+       #address-cells = <1>;
+       #size-cells = <1>;
+
+       macaddr_art_0: macaddr@0 {
+               reg = <0x0 0x6>;
+       };
+};
index 8d3d2ce5b286ce7ff053ad633323114fa65f295e..b34e796ac385c785839fb6826fe3c6f6e5230881 100644 (file)
@@ -1,3 +1,16 @@
+define Build/dw-headers
+       head -c 4 $@ >> $@.tmp && \
+       head -c 8 /dev/zero >> $@.tmp && \
+       tail -c +9 $@ >> $@.tmp && \
+       ( \
+               header_crc="$$(head -c 68 $@.tmp | gzip -c | \
+                       tail -c 8 | od -An -N4 -tx4 --endian little | tr -d ' \n')"; \
+               printf "$$(echo $$header_crc | sed 's/../\\x&/g')" | \
+                       dd of=$@.tmp bs=4 count=1 seek=1 conv=notrunc \
+       )
+       mv $@.tmp $@
+endef
+
 # attention: only zlib compression is allowed for the boot fs
 define Build/zyxel-buildkerneljffs
        mkdir -p $@.tmp/boot
@@ -76,6 +89,41 @@ define Device/domywifi_dw33d
 endef
 TARGET_DEVICES += domywifi_dw33d
 
+define Device/dongwon_dw02-412h
+  SOC := qca9557
+  DEVICE_VENDOR := Dongwon T&I
+  DEVICE_MODEL := DW02-412H
+  DEVICE_ALT0_VENDOR := KT
+  DEVICE_ALT0_MODEL := GiGA WiFi home
+  DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca988x-ct
+  KERNEL_SIZE := 8192k
+  BLOCKSIZE := 128k
+  PAGESIZE := 2048
+  KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | dw-headers
+  KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma | dw-headers
+  UBINIZE_OPTS := -E 5
+  IMAGES += factory.img
+  IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | \
+       check-size
+  IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+endef
+
+define Device/dongwon_dw02-412h-64m
+  $(Device/dongwon_dw02-412h)
+  DEVICE_VARIANT := (64M)
+  DEVICE_ALT0_VARIANT := (64M)
+  IMAGE_SIZE := 49152k
+endef
+TARGET_DEVICES += dongwon_dw02-412h-64m
+
+define Device/dongwon_dw02-412h-128m
+  $(Device/dongwon_dw02-412h)
+  DEVICE_VARIANT := (128M)
+  DEVICE_ALT0_VARIANT := (128M)
+  IMAGE_SIZE := 114688k
+endef
+TARGET_DEVICES += dongwon_dw02-412h-128m
+
 define Device/glinet_gl-ar300m-common-nand
   SOC := qca9531
   DEVICE_VENDOR := GL.iNet
index fc745547634e275d13f5db19bb393bbb6291fb27..f694d07e9c4d9ebdff29fca20a356101a06fb1c7 100644 (file)
@@ -6,6 +6,10 @@ board_config_update
 board=$(board_name)
 
 case "$board" in
+dongwon,dw02-412h-64m|\
+dongwon,dw02-412h-128m)
+       ucidef_set_led_switch "wan" "WAN" "green:wan" "switch0" "0x02"
+       ;;
 glinet,gl-ar300m-nand|\
 glinet,gl-ar300m-nor)
        ucidef_set_led_netdev "lan" "LAN" "green:lan" "eth0"
index 7402fc067a5b3ca01ed7b3f70c6393ac17f850fb..dbb9e6815013dd6b4a350d4d5744d1a274b66f7f 100644 (file)
@@ -15,6 +15,11 @@ ath79_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth0" "1:wan" "2:lan" "3:lan" "4:lan" "5:lan" "6@eth1"
                ;;
+       dongwon,dw02-412h-64m|\
+       dongwon,dw02-412h-128m)
+               ucidef_add_switch "switch0" \
+                       "0@eth0" "2:lan:4" "3:lan:3" "4:lan:2" "5:lan:1" "1:wan"
+               ;;
        glinet,gl-ar750s-nor|\
        glinet,gl-ar750s-nor-nand)
                ucidef_add_switch "switch0" \
@@ -47,6 +52,11 @@ ath79_setup_macs()
        local board="$1"
 
        case "$board" in
+       dongwon,dw02-412h-64m|\
+       dongwon,dw02-412h-128m)
+               wan_mac=$(mtd_get_mac_binary art 0x0)
+               label_mac=$wan_mac
+               ;;
        netgear,wndr3700-v4|\
        netgear,wndr4300|\
        netgear,wndr4300sw|\
index f8cc8f1a2b720ef29102a5d2c5c61becd49f66e2..71dfb161e46540e21e2649e1a8458b1051f71028 100644 (file)
@@ -13,6 +13,11 @@ case "$FIRMWARE" in
                caldata_extract "art" 0x5000 0x844
                ath10k_patch_mac $(mtd_get_mac_binary art 0x12)
                ;;
+       dongwon,dw02-412h-64m|\
+       dongwon,dw02-412h-128m)
+               caldata_extract "art" 0x5000 0x844
+               ath10k_patch_mac $(macaddr_add $(mtd_get_mac_binary art 0x0) 4)
+               ;;
        glinet,gl-ar750s-nor|\
        glinet,gl-ar750s-nor-nand)
                caldata_extract "art" 0x5000 0x844