tools: include the value of CONFIG_SDK_LLVM_BPF in the stampfile
authorFelix Fietkau <nbd@nbd.name>
Sun, 21 Nov 2021 11:13:52 +0000 (12:13 +0100)
committerFelix Fietkau <nbd@nbd.name>
Sun, 21 Nov 2021 12:47:18 +0000 (13:47 +0100)
tools/llvm-bpf needs to be checked if the value changes

Signed-off-by: Felix Fietkau <nbd@nbd.name>
tools/Makefile

index 686d5294d3e7fbad517a99ce6a3b120456003737..82a67a00dd23d5cf9166df4222d99807d696a8c6 100644 (file)
@@ -156,7 +156,8 @@ $(curdir)/ := .config prereq
 
 $(curdir)/install: $(curdir)/compile
 
-tools_enabled = $(foreach tool,$(sort $(tools-y) $(tools-)),$(if $(filter $(tool),$(tools-y)),y,n))
+tools_config = CONFIG_SDK_LLVM_BPF
+tools_enabled = $(foreach tool,$(sort $(tools-y) $(tools-)),$(if $(filter $(tool),$(tools-y)),y,n))$(foreach c,$(tools_config),$(if $($(c)),y,n))
 $(eval $(call stampfile,$(curdir),tools,compile,,_$(subst $(space),,$(tools_enabled)),$(STAGING_DIR_HOST)))
 $(eval $(call stampfile,$(curdir),tools,check,$(TMP_DIR)/.build,,$(STAGING_DIR_HOST)))
 $(eval $(call subdir,$(curdir)))