rssileds: add dependencies based on LDFLAGS
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 20 Feb 2020 17:38:04 +0000 (18:38 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 22 Feb 2020 13:26:01 +0000 (14:26 +0100)
This adds the direct dependencies introduced by TARGET_LDFLAGS
to the package's DEPENDS variable.

This was found by accidentally building rssileds on octeon, which
resulted in:

"Package rssileds is missing dependencies for the following libraries:
libnl-tiny.so"

Though the dependencies are provided when building for the
relevant targets ar71xx, ath79 and ramips, it seems more tidy to
specify them explicitly.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
package/network/utils/rssileds/Makefile

index 27cdb4c67cdfb58c10625a44bc83ebd0c6f43968..7a59314693ca8b1462d6e420fc0a81ffed5f1542 100644 (file)
@@ -18,7 +18,7 @@ define Package/rssileds
   SECTION:=net
   CATEGORY:=Network
   TITLE:=RSSI real-time LED indicator
-  DEPENDS:=+libiwinfo
+  DEPENDS:=+libiwinfo +libnl-tiny +libubox +libuci
   MAINTAINER:=Daniel Golle <dgolle@allnet.de>
 endef