tools/pkgconf: update to 1.8.0
authorRosen Penev <rosenp@gmail.com>
Sat, 19 Jun 2021 02:53:17 +0000 (19:53 -0700)
committerPaul Spooren <mail@aparcar.org>
Fri, 17 Sep 2021 02:31:28 +0000 (16:31 -1000)
Switch to compiling with meson for faster and more reliable compilation.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
tools/Makefile
tools/pkgconf/Makefile

index e16af6c68f75be6ebcd5775cdfce4f127e677a72..f794e57f2ed5eed5d3de4f25f2f454e89e5bcbb3 100644 (file)
@@ -66,6 +66,7 @@ $(curdir)/mpfr/compile := $(curdir)/gmp/compile
 $(curdir)/mtd-utils/compile := $(curdir)/libtool/compile $(curdir)/e2fsprogs/compile $(curdir)/zlib/compile
 $(curdir)/padjffs2/compile := $(curdir)/findutils/compile
 $(curdir)/patchelf/compile := $(curdir)/libtool/compile
+$(curdir)/pkgconf/compile := $(curdir)/meson/compile
 $(curdir)/quilt/compile := $(curdir)/autoconf/compile $(curdir)/findutils/compile
 $(curdir)/sdcc/compile := $(curdir)/bison/compile
 $(curdir)/squashfs/compile := $(curdir)/lzma-old/compile
@@ -79,7 +80,7 @@ ifneq ($(HOST_OS),Linux)
 endif
 
 ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
-$(foreach tool, $(filter-out xz zstd patch pkgconf libressl ninja cmake,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/compile))
+$(foreach tool, $(filter-out xz zstd pkgconf patch ninja meson libressl cmake,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/compile))
 tools-y += ccache
 $(curdir)/ccache/compile := $(curdir)/zstd/compile
 endif
index 0f56de0e29f879362ff072f6223caa110ea7466d..d2f3252b12ef4412fcff363925b02ac8fcb80ba3 100644 (file)
@@ -7,29 +7,32 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pkgconf
-PKG_VERSION:=1.7.3
+PKG_VERSION:=1.8.0
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://distfiles.dereferenced.org/pkgconf
-PKG_HASH:=b846aea51cf696c3392a0ae58bef93e2e72f8e7073ca6ad1ed8b01c85871f9c0
-
-HOST_BUILD_PARALLEL:=1
+PKG_HASH:=ef9c7e61822b7cb8356e6e9e1dca58d9556f3200d78acab35e4347e9d4c2bbaf
 
 include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/meson.mk
 
 unexport PKG_CONFIG
 
 HOSTCC := $(HOSTCC_NOCACHE)
 
+MESON_HOST_ARGS += \
+       -Ddefault_library=static \
+       -Dtests=false
+
 define Host/Install
-       $(MAKE) -C $(HOST_BUILD_DIR) install
+       $(call Host/Install/Meson)
        mv $(STAGING_DIR_HOST)/bin/pkgconf $(STAGING_DIR_HOST)/bin/pkg-config.real
        $(INSTALL_BIN) ./files/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config
 endef
 
 define Host/Clean
-       -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
-       $(call Host/Clean/Default)
+       rm -f $(STAGING_DIR_HOST)/bin/pkg-config.real $(STAGING_DIR_HOST)/bin/pkg-config
+       $(call Host/Clean/Meson)
 endef
 
 $(eval $(call HostBuild))