kernel: bump 5.4 to 5.4.161
authorJohn Audia <graysky@archlinux.us>
Sat, 27 Nov 2021 19:56:33 +0000 (14:56 -0500)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 28 Nov 2021 15:32:45 +0000 (16:32 +0100)
Removed upstreamed:
    ath79/patches-5.4/921-serial-core-add-support-for-boot-console-with-arbitr.patch[1]

Manually rebased:
    layerscape/patches-5.4/804-crypto-0016-MLKU-114-1-crypto-caam-reduce-page-0-regs-access-to-.patch
    octeontx/patches-5.4/0004-PCI-add-quirk-for-Gateworks-PLX-PEX860x-switch-with-.patch

All other patches automatically rebased.

1. Private email exchange with patch author, Hauke Mehrtens

Signed-off-by: John Audia <graysky@archlinux.us>
31 files changed:
include/kernel-version.mk
target/linux/apm821xx/patches-5.4/801-usb-xhci-add-firmware-loader-for-uPD720201-and-uPD72.patch
target/linux/apm821xx/patches-5.4/802-usb-xhci-force-msi-renesas-xhci.patch
target/linux/ath79/patches-5.4/910-unaligned_access_hacks.patch
target/linux/ath79/patches-5.4/921-serial-core-add-support-for-boot-console-with-arbitr.patch [deleted file]
target/linux/generic/backport-5.4/700-v5.5-net-core-allow-fast-GRO-for-skbs-with-Ethernet-heade.patch
target/linux/generic/backport-5.4/782-net-next-1-of-net-pass-the-dst-buffer-to-of_get_mac_address.patch
target/linux/generic/hack-5.4/661-use_fq_codel_by_default.patch
target/linux/generic/hack-5.4/721-phy_packets.patch
target/linux/generic/hack-5.4/904-debloat_dma_buf.patch
target/linux/generic/pending-5.4/103-MIPS-select-CPU_MIPS64-for-remaining-MIPS64-CPUs.patch
target/linux/generic/pending-5.4/300-mips_expose_boot_raw.patch
target/linux/generic/pending-5.4/680-NET-skip-GRO-for-foreign-MAC-addresses.patch
target/linux/generic/pending-5.4/690-net-add-support-for-threaded-NAPI-polling.patch
target/linux/layerscape/patches-5.4/301-arch-0002-arm64-add-support-to-remap-kernel-cacheable-memory-t.patch
target/linux/layerscape/patches-5.4/301-arch-0003-arm64-pgtable-add-support-to-map-cacheable-and-non-s.patch
target/linux/layerscape/patches-5.4/303-core-0003-cgroup-let-a-symlink-too-be-created-with-a-cftype-fi.patch
target/linux/layerscape/patches-5.4/303-core-0004-cgroup-bfq-revert-bfq.weight-symlink-change.patch
target/linux/layerscape/patches-5.4/804-crypto-0012-MLK-19053-crypto-caam-RNG4-TRNG-errata.patch
target/linux/layerscape/patches-5.4/804-crypto-0016-MLKU-114-1-crypto-caam-reduce-page-0-regs-access-to-.patch
target/linux/layerscape/patches-5.4/804-crypto-0020-MLKU-25-3-crypto-caam-add-Secure-Memory-support.patch
target/linux/layerscape/patches-5.4/804-crypto-0024-MLK-19449-crypto-caam-Change-structure-type-represen.patch
target/linux/layerscape/patches-5.4/804-crypto-0041-LF-292-2-crypto-caam-add-power-management.patch
target/linux/layerscape/patches-5.4/812-pcie-0004-pci-add-support-aer-pme-interrupts-with-none-MSI-MSI.patch
target/linux/layerscape/patches-5.4/820-usb-0015-MLK-17380-4-usb-host-xhci-add-EH-SINGLE_STEP_SET_FEA.patch
target/linux/layerscape/patches-5.4/820-usb-0021-MLK-22099-usb-host-xhci-do-warm-reset-for-link-state.patch
target/linux/octeontx/patches-5.4/0004-PCI-add-quirk-for-Gateworks-PLX-PEX860x-switch-with-.patch
target/linux/ramips/patches-5.4/0031-uvc-add-iPassion-iP2970-support.patch
target/linux/ramips/patches-5.4/0051-serial-add-ugly-custom-baud-rate-hack.patch
target/linux/ramips/patches-5.4/0098-disable_cm.patch
target/linux/realtek/patches-5.4/302-clocksource-add-rtl9300-driver.patch

index 811e795506c5f80d83c9123e5a4a61b930b8b9dc..df4fd84f895794ddbd5b36c490d0eb6294158d0d 100644 (file)
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .159
+LINUX_VERSION-5.4 = .161
 LINUX_VERSION-5.10 = .82
 
-LINUX_KERNEL_HASH-5.4.159 = d718325f4eab325dce4f82b88418f68ba130864118229539541331e0a4478643
+LINUX_KERNEL_HASH-5.4.161 = 3149c6b52a3079218a60bd369a80d18275b574d84908ffee32a0a8f9ddf939a7
 LINUX_KERNEL_HASH-5.10.82 = d66f7c7eed02f84ae550b3c91a26c70eea13682a6d672432f07bce66ff8ce350
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 220e5da73b116376bc70912052c87b3c73730ff3..b85f62e680617781808e94e326b619e155bd1895 100644 (file)
@@ -48,7 +48,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
  
  #include "xhci.h"
  #include "xhci-trace.h"
-@@ -65,6 +67,44 @@
+@@ -72,6 +74,44 @@
  #define PCI_DEVICE_ID_ASMEDIA_2142_XHCI                       0x2142
  #define PCI_DEVICE_ID_ASMEDIA_3242_XHCI                       0x3242
  
@@ -93,7 +93,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
  static const char hcd_name[] = "xhci_hcd";
  
  static struct hc_driver __read_mostly xhci_pci_hc_driver;
-@@ -311,6 +351,873 @@ static void xhci_pme_acpi_rtd3_enable(st
+@@ -327,6 +367,873 @@ static void xhci_pme_acpi_rtd3_enable(st
  static void xhci_pme_acpi_rtd3_enable(struct pci_dev *dev) { }
  #endif /* CONFIG_ACPI */
  
@@ -967,7 +967,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
  /* called during probe() after chip reset completes */
  static int xhci_pci_setup(struct usb_hcd *hcd)
  {
-@@ -352,6 +1259,27 @@ static int xhci_pci_probe(struct pci_dev
+@@ -368,6 +1275,27 @@ static int xhci_pci_probe(struct pci_dev
        struct hc_driver *driver;
        struct usb_hcd *hcd;
  
@@ -995,7 +995,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
        driver = (struct hc_driver *)id->driver_data;
  
        /* Prevent runtime suspending between USB-2 and USB-3 initialization */
-@@ -413,6 +1341,16 @@ static void xhci_pci_remove(struct pci_d
+@@ -429,6 +1357,16 @@ static void xhci_pci_remove(struct pci_d
  {
        struct xhci_hcd *xhci;
  
@@ -1012,7 +1012,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
        xhci = hcd_to_xhci(pci_get_drvdata(dev));
        xhci->xhc_state |= XHCI_STATE_REMOVING;
  
-@@ -552,6 +1490,11 @@ static int xhci_pci_resume(struct usb_hc
+@@ -568,6 +1506,11 @@ static int xhci_pci_resume(struct usb_hc
        if (pdev->vendor == PCI_VENDOR_ID_INTEL)
                usb_enable_intel_xhci_ports(pdev);
  
index 6980ce80ee9fba4a9bc9d1752369d971a6d0e986..1fe38dc60ad3fd0c9cfc109a9e9f8ca38f5c4b8d 100644 (file)
@@ -13,7 +13,7 @@ produce a noisy warning.
 
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -290,6 +290,7 @@ static void xhci_pci_quirks(struct devic
+@@ -297,6 +297,7 @@ static void xhci_pci_quirks(struct devic
            pdev->device == 0x0015) {
                xhci->quirks |= XHCI_RESET_ON_RESUME;
                xhci->quirks |= XHCI_ZERO_64B_REGS;
index d2200c8976e0ad2324406bcf21c949d327b95b68..26c4a7b213dae0fa3ea65b094090703a0f8f5fca 100644 (file)
        ptr = ip6hoff + sizeof(struct ipv6hdr);
 --- a/include/net/neighbour.h
 +++ b/include/net/neighbour.h
-@@ -274,8 +274,10 @@ static inline bool neigh_key_eq128(const
+@@ -275,8 +275,10 @@ static inline bool neigh_key_eq128(const
        const u32 *n32 = (const u32 *)n->primary_key;
        const u32 *p32 = pkey;
  
diff --git a/target/linux/ath79/patches-5.4/921-serial-core-add-support-for-boot-console-with-arbitr.patch b/target/linux/ath79/patches-5.4/921-serial-core-add-support-for-boot-console-with-arbitr.patch
deleted file mode 100644 (file)
index 2a2aafa..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-From 4d3c17975c7814884a721fe693b3adf5c426d759 Mon Sep 17 00:00:00 2001
-From: Hauke Mehrtens <hauke@hauke-m.de>
-Date: Tue, 10 Nov 2015 22:18:39 +0100
-Subject: [RFC] serial: core: add support for boot console with arbitrary
- baud rates
-
-The Arduino Yun uses a baud rate of 250000 by default. The serial is
-going over the Atmel ATmega and is used to connect to this chip.
-Without this patch Linux wants to switch the console to 9600 Baud.
-
-With this patch Linux will use the configured baud rate and not a
-default one specified in uart_register_driver().
-
-Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
-[rebased to 4.14, slightly reworded commit message]
-Signed-off-by: Sungbo Eo <mans0n@gorani.run>
----
- drivers/tty/serial/serial_core.c | 6 +++++-
- include/linux/console.h          | 1 +
- 2 files changed, 6 insertions(+), 1 deletions(-)
-
---- a/drivers/tty/serial/serial_core.c
-+++ b/drivers/tty/serial/serial_core.c
-@@ -220,6 +220,8 @@ static int uart_port_startup(struct tty_
-       if (retval == 0) {
-               if (uart_console(uport) && uport->cons->cflag) {
-                       tty->termios.c_cflag = uport->cons->cflag;
-+                      tty->termios.c_ospeed = uport->cons->baud;
-+                      tty->termios.c_ispeed = uport->cons->baud;
-                       uport->cons->cflag = 0;
-               }
-               /*
-@@ -2110,8 +2112,10 @@ uart_set_options(struct uart_port *port,
-        * Allow the setting of the UART parameters with a NULL console
-        * too:
-        */
--      if (co)
-+      if (co) {
-               co->cflag = termios.c_cflag;
-+              co->baud = baud;
-+      }
-       return 0;
- }
---- a/include/linux/console.h
-+++ b/include/linux/console.h
-@@ -153,6 +153,7 @@ struct console {
-       short   flags;
-       short   index;
-       int     cflag;
-+      int     baud;
-       void    *data;
-       struct   console *next;
- };
index 13f0d9d0006230b1eebb01076bf9d059c3beaf6c..a8181bca94a4dee2b0e21b267c681661972748e8 100644 (file)
@@ -66,7 +66,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
-@@ -5429,8 +5429,7 @@ static inline void skb_gro_reset_offset(
+@@ -5432,8 +5432,7 @@ static inline void skb_gro_reset_offset(
        NAPI_GRO_CB(skb)->frag0 = NULL;
        NAPI_GRO_CB(skb)->frag0_len = 0;
  
index 55149150c9b6605c23e7c23fce596acdf0aaa8f7..ea77969f50aeb44ee0eac9dc82e4ab3715fccd2e 100644 (file)
@@ -1385,7 +1385,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                        if (ret)
 --- a/drivers/net/ethernet/ti/davinci_emac.c
 +++ b/drivers/net/ethernet/ti/davinci_emac.c
-@@ -1685,7 +1685,6 @@ davinci_emac_of_get_pdata(struct platfor
+@@ -1697,7 +1697,6 @@ davinci_emac_of_get_pdata(struct platfor
        const struct of_device_id *match;
        const struct emac_platform_data *auxdata;
        struct emac_platform_data *pdata = NULL;
@@ -1393,7 +1393,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
        if (!IS_ENABLED(CONFIG_OF) || !pdev->dev.of_node)
                return dev_get_platdata(&pdev->dev);
-@@ -1697,11 +1696,8 @@ davinci_emac_of_get_pdata(struct platfor
+@@ -1709,11 +1708,8 @@ davinci_emac_of_get_pdata(struct platfor
        np = pdev->dev.of_node;
        pdata->version = EMAC_VERSION_2;
  
index bbe43d24c240d93f9ae3ffe44a07f88f91c14efd..11f1a25bce775995e83901f644a5854722207a25 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/include/net/sch_generic.h
 +++ b/include/net/sch_generic.h
-@@ -615,12 +615,13 @@ extern struct Qdisc_ops noop_qdisc_ops;
+@@ -617,12 +617,13 @@ extern struct Qdisc_ops noop_qdisc_ops;
  extern struct Qdisc_ops pfifo_fast_ops;
  extern struct Qdisc_ops mq_qdisc_ops;
  extern struct Qdisc_ops noqueue_qdisc_ops;
index bc9b3a4783d264910541904238b20b3b40c12992..268e9df051df7bcb216b68274d3e3b8b9ab112d0 100644 (file)
@@ -101,7 +101,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        help
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
-@@ -3198,10 +3198,20 @@ static int xmit_one(struct sk_buff *skb,
+@@ -3200,10 +3200,20 @@ static int xmit_one(struct sk_buff *skb,
        if (dev_nit_active(dev))
                dev_queue_xmit_nit(skb, dev);
  
index ad8636b16d8e831f2309ab544eaa46e1ee3bb4bb..9ea1afd57ad45edb871b907c6e16601171b23ef3 100644 (file)
@@ -45,7 +45,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        selftest.o \
 --- a/drivers/dma-buf/dma-buf.c
 +++ b/drivers/dma-buf/dma-buf.c
-@@ -1313,4 +1313,5 @@ static void __exit dma_buf_deinit(void)
+@@ -1314,4 +1314,5 @@ static void __exit dma_buf_deinit(void)
        dma_buf_uninit_debugfs();
        kern_unmount(dma_buf_mnt);
  }
index b5ec03f2864a952961341788e3b27d694dba2f7e..4332b17ff9a8bfce0408c50c21bc314c723a5df1 100644 (file)
@@ -25,7 +25,7 @@ Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -2039,7 +2039,8 @@ config CPU_MIPS32
+@@ -2040,7 +2040,8 @@ config CPU_MIPS32
  
  config CPU_MIPS64
        bool
index c08d6a61f3091714d2073784a0a711c4ef942316..02a558f7feef3df5f80fe97963d41265150375af 100644 (file)
@@ -19,7 +19,7 @@ Acked-by: Rob Landley <rob@landley.net>
  config CEVT_BCM1480
        bool
  
-@@ -3046,6 +3043,18 @@ choice
+@@ -3047,6 +3044,18 @@ choice
                bool "Extend builtin kernel arguments with bootloader arguments"
  endchoice
  
index e0540866c6be8aa32dc39e98ade67a04bd755171..b1ac7ffca0d540c93f82c9bc333fff684e61a20b 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        __u16                   tc_index;       /* traffic control index */
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
-@@ -5495,6 +5495,9 @@ static enum gro_result dev_gro_receive(s
+@@ -5498,6 +5498,9 @@ static enum gro_result dev_gro_receive(s
        int same_flow;
        int grow;
  
@@ -42,7 +42,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (netif_elide_gro(skb->dev))
                goto normal;
  
-@@ -7297,6 +7300,48 @@ static void __netdev_adjacent_dev_unlink
+@@ -7300,6 +7303,48 @@ static void __netdev_adjacent_dev_unlink
                                           &upper_dev->adj_list.lower);
  }
  
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static int __netdev_upper_dev_link(struct net_device *dev,
                                   struct net_device *upper_dev, bool master,
                                   void *upper_priv, void *upper_info,
-@@ -7347,6 +7392,7 @@ static int __netdev_upper_dev_link(struc
+@@ -7350,6 +7395,7 @@ static int __netdev_upper_dev_link(struc
        if (ret)
                return ret;
  
@@ -99,7 +99,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        ret = call_netdevice_notifiers_info(NETDEV_CHANGEUPPER,
                                            &changeupper_info.info);
        ret = notifier_to_errno(ret);
-@@ -7440,6 +7486,7 @@ void netdev_upper_dev_unlink(struct net_
+@@ -7443,6 +7489,7 @@ void netdev_upper_dev_unlink(struct net_
  
        __netdev_adjacent_dev_unlink_neighbour(dev, upper_dev);
  
@@ -107,7 +107,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        call_netdevice_notifiers_info(NETDEV_CHANGEUPPER,
                                      &changeupper_info.info);
  
-@@ -8170,6 +8217,7 @@ int dev_set_mac_address(struct net_devic
+@@ -8173,6 +8220,7 @@ int dev_set_mac_address(struct net_devic
        if (err)
                return err;
        dev->addr_assign_type = NET_ADDR_SET;
index bdddd062eb117d02d3680d61e00850e4cbc0a14c..0e97f2140c3aea0b4790dbd1c86a7dfd0fbe2731 100644 (file)
@@ -95,7 +95,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
  static int netif_rx_internal(struct sk_buff *skb);
  static int call_netdevice_notifiers_info(unsigned long val,
-@@ -5937,6 +5938,11 @@ void __napi_schedule(struct napi_struct
+@@ -5940,6 +5941,11 @@ void __napi_schedule(struct napi_struct
  {
        unsigned long flags;
  
@@ -107,7 +107,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        local_irq_save(flags);
        ____napi_schedule(this_cpu_ptr(&softnet_data), n);
        local_irq_restore(flags);
-@@ -5988,6 +5994,10 @@ EXPORT_SYMBOL(napi_schedule_prep);
+@@ -5991,6 +5997,10 @@ EXPORT_SYMBOL(napi_schedule_prep);
   */
  void __napi_schedule_irqoff(struct napi_struct *n)
  {
@@ -118,7 +118,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!IS_ENABLED(CONFIG_PREEMPT_RT))
                ____napi_schedule(this_cpu_ptr(&softnet_data), n);
        else
-@@ -6252,9 +6262,89 @@ static void init_gro_hash(struct napi_st
+@@ -6255,9 +6265,89 @@ static void init_gro_hash(struct napi_st
        napi->gro_bitmask = 0;
  }
  
@@ -208,7 +208,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        INIT_LIST_HEAD(&napi->poll_list);
        hrtimer_init(&napi->timer, CLOCK_MONOTONIC, HRTIMER_MODE_REL_PINNED);
        napi->timer.function = napi_watchdog;
-@@ -6271,6 +6361,7 @@ void netif_napi_add(struct net_device *d
+@@ -6274,6 +6364,7 @@ void netif_napi_add(struct net_device *d
  #ifdef CONFIG_NETPOLL
        napi->poll_owner = -1;
  #endif
@@ -216,7 +216,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        set_bit(NAPI_STATE_SCHED, &napi->state);
        set_bit(NAPI_STATE_NPSVC, &napi->state);
        list_add_rcu(&napi->dev_list, &dev->napi_list);
-@@ -6311,6 +6402,7 @@ static void flush_gro_hash(struct napi_s
+@@ -6314,6 +6405,7 @@ static void flush_gro_hash(struct napi_s
  void netif_napi_del(struct napi_struct *napi)
  {
        might_sleep();
@@ -224,7 +224,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (napi_hash_del(napi))
                synchronize_net();
        list_del_init(&napi->dev_list);
-@@ -6323,50 +6415,18 @@ EXPORT_SYMBOL(netif_napi_del);
+@@ -6326,50 +6418,18 @@ EXPORT_SYMBOL(netif_napi_del);
  
  static int napi_poll(struct napi_struct *n, struct list_head *repoll)
  {
@@ -279,7 +279,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        /* Some drivers may have called napi_schedule
         * prior to exhausting their budget.
-@@ -10346,6 +10406,10 @@ static int __init net_dev_init(void)
+@@ -10349,6 +10409,10 @@ static int __init net_dev_init(void)
                sd->backlog.weight = weight_p;
        }
  
@@ -292,7 +292,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        /* The loopback device is special if any other network devices
 --- a/net/core/net-sysfs.c
 +++ b/net/core/net-sysfs.c
-@@ -442,6 +442,52 @@ static ssize_t proto_down_store(struct d
+@@ -470,6 +470,52 @@ static ssize_t proto_down_store(struct d
  }
  NETDEVICE_SHOW_RW(proto_down, fmt_dec);
  
@@ -345,7 +345,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static ssize_t phys_port_id_show(struct device *dev,
                                 struct device_attribute *attr, char *buf)
  {
-@@ -532,6 +578,7 @@ static struct attribute *net_class_attrs
+@@ -581,6 +627,7 @@ static struct attribute *net_class_attrs
        &dev_attr_flags.attr,
        &dev_attr_tx_queue_len.attr,
        &dev_attr_gro_flush_timeout.attr,
index 4c2c487ac09b54664c87daba25499346f7c728ce..e6c96a052a14aa193d274bf2c53a185d3848d5f5 100644 (file)
@@ -13,7 +13,7 @@ Reviewed-by: Stuart Yoder <stuart.yoder@freescale.com>
 
 --- a/arch/arm64/include/asm/pgtable.h
 +++ b/arch/arm64/include/asm/pgtable.h
-@@ -422,6 +422,9 @@ static inline pmd_t pmd_mkdevmap(pmd_t p
+@@ -428,6 +428,9 @@ static inline pmd_t pmd_mkdevmap(pmd_t p
        __pgprot_modify(prot, PTE_ATTRINDX_MASK, PTE_ATTRINDX(MT_DEVICE_nGnRnE) | PTE_PXN | PTE_UXN)
  #define pgprot_writecombine(prot) \
        __pgprot_modify(prot, PTE_ATTRINDX_MASK, PTE_ATTRINDX(MT_NORMAL_NC) | PTE_PXN | PTE_UXN)
index 63366ee221e3d5c26959bcd7624ba3274f005c67..bd39eb7e144ee300f7aa5e37c57d955e8b663d5e 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Haiying Wang <Haiying.wang@freescale.com>
 
 --- a/arch/arm64/include/asm/pgtable.h
 +++ b/arch/arm64/include/asm/pgtable.h
-@@ -425,6 +425,8 @@ static inline pmd_t pmd_mkdevmap(pmd_t p
+@@ -431,6 +431,8 @@ static inline pmd_t pmd_mkdevmap(pmd_t p
  #define pgprot_cached(prot) \
        __pgprot_modify(prot, PTE_ATTRINDX_MASK, PTE_ATTRINDX(MT_NORMAL) | \
                        PTE_PXN | PTE_UXN)
index 58a7be7f7d22e4ff118936c8454ecac4a75fce8b..f7edb7411d96cb6e2fa18e68485c2f5e3998b468 100644 (file)
@@ -87,7 +87,7 @@ Signed-off-by: Li Yang <leoyang.li@nxp.com>
  }
  
  /**
-@@ -3873,6 +3889,7 @@ static int cgroup_add_file(struct cgroup
+@@ -3896,6 +3912,7 @@ static int cgroup_add_file(struct cgroup
  {
        char name[CGROUP_FILE_NAME_MAX];
        struct kernfs_node *kn;
@@ -95,7 +95,7 @@ Signed-off-by: Li Yang <leoyang.li@nxp.com>
        struct lock_class_key *key = NULL;
        int ret;
  
-@@ -3903,6 +3920,14 @@ static int cgroup_add_file(struct cgroup
+@@ -3926,6 +3943,14 @@ static int cgroup_add_file(struct cgroup
                spin_unlock_irq(&cgroup_file_kn_lock);
        }
  
index 26d64e9b603f33c96b616f9d9b106c5a863f2a9f..469bbfdffaa3d782128edf42bc3f59409bbf89c4 100644 (file)
@@ -89,7 +89,7 @@ Signed-off-by: Li Yang <leoyang.li@nxp.com>
  }
  
  /**
-@@ -3889,7 +3873,6 @@ static int cgroup_add_file(struct cgroup
+@@ -3912,7 +3896,6 @@ static int cgroup_add_file(struct cgroup
  {
        char name[CGROUP_FILE_NAME_MAX];
        struct kernfs_node *kn;
@@ -97,7 +97,7 @@ Signed-off-by: Li Yang <leoyang.li@nxp.com>
        struct lock_class_key *key = NULL;
        int ret;
  
-@@ -3920,14 +3903,6 @@ static int cgroup_add_file(struct cgroup
+@@ -3943,14 +3926,6 @@ static int cgroup_add_file(struct cgroup
                spin_unlock_irq(&cgroup_file_kn_lock);
        }
  
index 52d15b71a6db58d15e9d90b7df9fb70eed1c21a9..761652ab71e4a863806a8994c9b4987cd3f02c1e 100644 (file)
@@ -51,7 +51,7 @@ Signed-off-by: Horia Geantă <horia.geanta@nxp.com>
  static int caam_get_era_from_hw(struct caam_ctrl __iomem *ctrl)
 --- a/drivers/crypto/caam/regs.h
 +++ b/drivers/crypto/caam/regs.h
-@@ -492,7 +492,8 @@ struct rngtst {
+@@ -495,7 +495,8 @@ struct rngtst {
  
  /* RNG4 TRNG test registers */
  struct rng4tst {
index f0622762547966f3d7d8004e883d0819208aa447..106255449c9f05ffcff557bf7316799649d53e64 100644 (file)
@@ -103,16 +103,16 @@ Signed-off-by: Horia Geantă <horia.geanta@nxp.com>
 @@ -1099,10 +1099,10 @@ int caam_pkc_init(struct device *ctrldev
  
        /* Determine public key hardware accelerator presence. */
-       if (priv->era < 10)
+       if (priv->era < 10) {
 -              pk_inst = (rd_reg32(&priv->ctrl->perfmon.cha_num_ls) &
 +              pk_inst = (rd_reg32(&priv->jr[0]->perfmon.cha_num_ls) &
                           CHA_ID_LS_PK_MASK) >> CHA_ID_LS_PK_SHIFT;
-       else
--              pk_inst = rd_reg32(&priv->ctrl->vreg.pkha) & CHA_VER_NUM_MASK;
-+              pk_inst = rd_reg32(&priv->jr[0]->vreg.pkha) & CHA_VER_NUM_MASK;
+       } else {
+-              pkha = rd_reg32(&priv->ctrl->vreg.pkha);
++              pkha = rd_reg32(&priv->jr[0]->vreg.pkha);
+               pk_inst = pkha & CHA_VER_NUM_MASK;
  
-       /* Do not register algorithms if PKHA is not present. */
-       if (!pk_inst)
+               /*
 --- a/drivers/crypto/caam/caamrng.c
 +++ b/drivers/crypto/caam/caamrng.c
 @@ -363,10 +363,10 @@ int caam_rng_init(struct device *ctrldev
index 91f1cebd55efbcca4e976a37ab0722a316d0f36e..db0e256dededf53a54e77a3f120488f56e3b0f02 100644 (file)
@@ -261,7 +261,7 @@ Signed-off-by: Horia Geantă <horia.geanta@nxp.com>
  
 --- a/drivers/crypto/caam/regs.h
 +++ b/drivers/crypto/caam/regs.h
-@@ -382,6 +382,12 @@ struct version_regs {
+@@ -385,6 +385,12 @@ struct version_regs {
  #define CHA_VER_VID_MD_LP512  0x1ull
  #define CHA_VER_VID_MD_HP     0x2ull
  
@@ -274,7 +274,7 @@ Signed-off-by: Horia Geantă <horia.geanta@nxp.com>
  struct sec_vid {
        u16 ip_id;
        u8 maj_rev;
-@@ -412,17 +418,22 @@ struct caam_perfmon {
+@@ -415,17 +421,22 @@ struct caam_perfmon {
  #define CTPR_MS_PG_SZ_SHIFT   4
        u32 comp_parms_ms;      /* CTPR - Compile Parameters Register   */
        u32 comp_parms_ls;      /* CTPR - Compile Parameters Register   */
@@ -300,7 +300,7 @@ Signed-off-by: Horia Geantă <horia.geanta@nxp.com>
  
        /* Component Instantiation Parameters                   fe0-fff */
        u32 rtic_id;            /* RVID - RTIC Version ID       */
-@@ -441,6 +452,62 @@ struct caam_perfmon {
+@@ -444,6 +455,62 @@ struct caam_perfmon {
        u32 caam_id_ls;         /* CAAMVID - CAAM Version ID LS */
  };
  
@@ -363,7 +363,7 @@ Signed-off-by: Horia Geantă <horia.geanta@nxp.com>
  /* LIODN programming for DMA configuration */
  #define MSTRID_LOCK_LIODN     0x80000000
  #define MSTRID_LOCK_MAKETRUSTED       0x00010000      /* only for JR masterid */
-@@ -645,6 +712,35 @@ struct caam_ctrl {
+@@ -648,6 +715,35 @@ struct caam_ctrl {
  #define JRSTART_JR2_START       0x00000004 /* Start Job ring 2 */
  #define JRSTART_JR3_START       0x00000008 /* Start Job ring 3 */
  
@@ -399,7 +399,7 @@ Signed-off-by: Horia Geantă <horia.geanta@nxp.com>
  /*
   * caam_job_ring - direct job ring setup
   * 1-4 possible per instantiation, base + 1000/2000/3000/4000
-@@ -815,6 +911,62 @@ struct caam_job_ring {
+@@ -818,6 +914,62 @@ struct caam_job_ring {
  
  #define JRCR_RESET                  0x01
  
index 0fb3847fdac3548adc5b61fa19ca202431505565..2914f010a402a454853d77eb1f6c88a791cc4248 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Horia Geantă <horia.geanta@nxp.com>
 
 --- a/drivers/crypto/caam/regs.h
 +++ b/drivers/crypto/caam/regs.h
-@@ -518,12 +518,6 @@ struct masterid {
+@@ -521,12 +521,6 @@ struct masterid {
        u32 liodn_ls;   /* LIODN for non-sequence and seq access */
  };
  
@@ -34,7 +34,7 @@ Signed-off-by: Horia Geantă <horia.geanta@nxp.com>
  /* RNGB test mode (replicated twice in some configurations) */
  /* Padded out to 0x100 */
  struct rngtst {
-@@ -637,7 +631,7 @@ struct caam_ctrl {
+@@ -640,7 +634,7 @@ struct caam_ctrl {
        u32 deco_rsr;                   /* DECORSR - Deco Request Source */
        u32 rsvd11;
        u32 deco_rq;                    /* DECORR - DECO Request */
index f3ebbccd583871e687da5c5f88a84db48f14fe3d..2a518790ed1a338efdbd569d13f673c5ef69a155 100644 (file)
@@ -558,7 +558,7 @@ Signed-off-by: Dong Aisheng <aisheng.dong@nxp.com>
        },
 --- a/drivers/crypto/caam/regs.h
 +++ b/drivers/crypto/caam/regs.h
-@@ -631,8 +631,7 @@ struct caam_ctrl {
+@@ -634,8 +634,7 @@ struct caam_ctrl {
        u32 deco_rsr;                   /* DECORSR - Deco Request Source */
        u32 rsvd11;
        u32 deco_rq;                    /* DECORR - DECO Request */
index bb26cd34414329649ed094fa4d92d69ced2fc670..9c359d24b9b4fc11102d9bc4b385f0849b2b084f 100644 (file)
@@ -229,7 +229,7 @@ Signed-off-by: Hou Zhiqiang <Zhiqiang.Hou@nxp.com>
         * fall back to INTx or other interrupts, e.g., a system shared
 --- a/include/linux/pci.h
 +++ b/include/linux/pci.h
-@@ -2022,6 +2022,7 @@ static inline void pcibios_penalize_isa_
+@@ -2024,6 +2024,7 @@ static inline void pcibios_penalize_isa_
  int pcibios_alloc_irq(struct pci_dev *dev);
  void pcibios_free_irq(struct pci_dev *dev);
  resource_size_t pcibios_default_alignment(void);
index 361328cf059a86d1678ee9fd00420a4eacb780e7..9dd1cf5ff559edd0bc254538036c0527e14d681f 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
 
 --- a/drivers/usb/host/xhci-hub.c
 +++ b/drivers/usb/host/xhci-hub.c
-@@ -1420,6 +1420,15 @@ int xhci_hub_control(struct usb_hcd *hcd
+@@ -1421,6 +1421,15 @@ int xhci_hub_control(struct usb_hcd *hcd
                        /* 4.19.6 Port Test Modes (USB2 Test Mode) */
                        if (hcd->speed != HCD_USB2)
                                goto error;
index 00034e38f347151b17ac52845e2415fc533d3560..26c6c007fba3c32743d919b33ed9946fc9bca70f 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Li Jun <jun.li@nxp.com>
 
 --- a/drivers/usb/host/xhci-hub.c
 +++ b/drivers/usb/host/xhci-hub.c
-@@ -1738,7 +1738,8 @@ static bool xhci_port_missing_cas_quirk(
+@@ -1739,7 +1739,8 @@ static bool xhci_port_missing_cas_quirk(
                return false;
  
        if (((portsc & PORT_PLS_MASK) != XDEV_POLLING) &&
index 18b5f49073b869f7172bd6dff2cdd54e6a888ad5..1206561fdac22a5ae79ed92ce8743a8efae5c325 100644 (file)
@@ -22,10 +22,10 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
  #include <linux/platform_data/x86/apple.h>
  #include <linux/pm_runtime.h>
  #include <linux/suspend.h>
-@@ -5783,3 +5784,34 @@ static void apex_pci_fixup_class(struct
+@@ -5790,3 +5791,34 @@ static void nvidia_ion_ahci_fixup(struct
+       pdev->dev_flags |= PCI_DEV_FLAGS_HAS_MSI_MASKING;
  }
- DECLARE_PCI_FIXUP_CLASS_HEADER(0x1ac1, 0x089a,
-                              PCI_CLASS_NOT_DEFINED, 8, apex_pci_fixup_class);
+ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_NVIDIA, 0x0ab8, nvidia_ion_ahci_fixup);
 +
 +#ifdef CONFIG_PCI_HOST_THUNDER_PEM
 +/*
index 306ae6cfdacb6461e0c039a81208f6ca62b8ba79..f088babc4ec799e1e9114a459ba68bee63245ef8 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/media/usb/uvc/uvc_driver.c
 +++ b/drivers/media/usb/uvc/uvc_driver.c
-@@ -2911,6 +2911,18 @@ static const struct usb_device_id uvc_id
+@@ -2916,6 +2916,18 @@ static const struct usb_device_id uvc_id
          .bInterfaceSubClass   = 1,
          .bInterfaceProtocol   = 0,
          .driver_info          = UVC_INFO_META(V4L2_META_FMT_D4XX) },
@@ -64,7 +64,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  
  #include <media/v4l2-common.h>
  
-@@ -1183,9 +1188,149 @@ static void uvc_video_decode_data(struct
+@@ -1188,9 +1193,149 @@ static void uvc_video_decode_data(struct
        uvc_urb->async_operations++;
  }
  
@@ -214,7 +214,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
        /* Mark the buffer as done if the EOF marker is set. */
        if (data[1] & UVC_STREAM_EOF && buf->bytesused != 0) {
                uvc_trace(UVC_TRACE_FRAME, "Frame complete (EOF found).\n");
-@@ -1742,6 +1887,8 @@ static int uvc_init_video_isoc(struct uv
+@@ -1747,6 +1892,8 @@ static int uvc_init_video_isoc(struct uv
        if (npackets == 0)
                return -ENOMEM;
  
index 48222266108f227a1ad8593ea97a9ca876fdfe9b..7192d61323cba102357ce22e074edc29ce57b78c 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/tty/serial/serial_core.c
 +++ b/drivers/tty/serial/serial_core.c
-@@ -416,6 +416,9 @@ uart_get_baud_rate(struct uart_port *por
+@@ -423,6 +423,9 @@ uart_get_baud_rate(struct uart_port *por
                break;
        }
  
index 9b280aef99542b456f7a1c0c8e453272fa78fda5..1f3367568fe7107373d136154ca52375c5eda2f1 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/kernel/mips-cm.c
 +++ b/arch/mips/kernel/mips-cm.c
-@@ -233,6 +233,7 @@ int mips_cm_probe(void)
+@@ -232,6 +232,7 @@ int mips_cm_probe(void)
  
        /* disable CM regions */
        write_gcr_reg0_base(CM_GCR_REGn_BASE_BASEADDR);
@@ -8,7 +8,7 @@
        write_gcr_reg0_mask(CM_GCR_REGn_MASK_ADDRMASK);
        write_gcr_reg1_base(CM_GCR_REGn_BASE_BASEADDR);
        write_gcr_reg1_mask(CM_GCR_REGn_MASK_ADDRMASK);
-@@ -240,7 +241,7 @@ int mips_cm_probe(void)
+@@ -239,7 +240,7 @@ int mips_cm_probe(void)
        write_gcr_reg2_mask(CM_GCR_REGn_MASK_ADDRMASK);
        write_gcr_reg3_base(CM_GCR_REGn_BASE_BASEADDR);
        write_gcr_reg3_mask(CM_GCR_REGn_MASK_ADDRMASK);
index 1c41db75b270b0c765988dfd22130cb5f3add891..db8f22bf02335921921202438c66fa6315bb1494 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/clocksource/Kconfig
 +++ b/drivers/clocksource/Kconfig
-@@ -127,6 +127,15 @@ config RDA_TIMER
+@@ -128,6 +128,15 @@ config RDA_TIMER
        help
          Enables the support for the RDA Micro timer driver.
  
@@ -16,7 +16,7 @@
  config SUN4I_TIMER
        bool "Sun4i timer driver" if COMPILE_TEST
        depends on HAS_IOMEM
-@@ -696,5 +705,4 @@ config INGENIC_TIMER
+@@ -697,5 +706,4 @@ config INGENIC_TIMER
        select IRQ_DOMAIN
        help
          Support for the timer/counter unit of the Ingenic JZ SoCs.