iproute2: bump version from v3.18.0 to v3.19.0
authorSteven Barth <cyrus@openwrt.org>
Tue, 17 Feb 2015 14:14:39 +0000 (14:14 +0000)
committerSteven Barth <cyrus@openwrt.org>
Tue, 17 Feb 2015 14:14:39 +0000 (14:14 +0000)
with refreshed patches

Signed-off-by: Russell Senior <russell@personaltelco.net>
SVN-Revision: 44479

package/network/utils/iproute2/Makefile
package/network/utils/iproute2/patches/006-no_sctp.patch
package/network/utils/iproute2/patches/120-libnetlink-pic.patch
package/network/utils/iproute2/patches/200-add-tc_esfq.patch
package/network/utils/iproute2/patches/210-add-act_connmark.patch
package/network/utils/iproute2/patches/300-ip_tiny.patch

index ad14ac4484ba63a4506fec57ad8a5b467fb5e906..56d2897e2a6b92fa327632e0eaaf598434d88216 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
-PKG_VERSION:=3.18.0
+PKG_VERSION:=3.19.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://kernel.org/pub/linux/utils/net/iproute2/
-PKG_MD5SUM:=6f6ad51a00007880460e103367b16057
+PKG_MD5SUM:=237083a1e3c388cde7a115a5724dc72a
 PKG_BUILD_PARALLEL:=1
 PKG_LICENSE:=GPL-2.0
 
index d4a0de00a5f376e75d4ca79ee4312a3ba2ab95f7..a3b2880d5a303c9d7beb3bc2764903f7f4ce12b4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/ip/ipxfrm.c
 +++ b/ip/ipxfrm.c
-@@ -469,7 +469,6 @@ void xfrm_selector_print(struct xfrm_sel
+@@ -467,7 +467,6 @@ void xfrm_selector_print(struct xfrm_sel
        switch (sel->proto) {
        case IPPROTO_TCP:
        case IPPROTO_UDP:
@@ -8,7 +8,7 @@
        case IPPROTO_DCCP:
        default: /* XXX */
                if (sel->sport_mask)
-@@ -1282,7 +1281,6 @@ static int xfrm_selector_upspec_parse(st
+@@ -1336,7 +1335,6 @@ static int xfrm_selector_upspec_parse(st
                switch (sel->proto) {
                case IPPROTO_TCP:
                case IPPROTO_UDP:
index 3ea7d193b21b37ca1b4311e43801f8e2d20607b4..26cc569dbff7a933aa1420e02a13ce5fc27c9fd0 100644 (file)
@@ -1,10 +1,11 @@
 --- a/lib/Makefile
 +++ b/lib/Makefile
-@@ -1,6 +1,6 @@
- include ../Config
+@@ -4,7 +4,7 @@ ifeq ($(IP_CONFIG_SETNS),y)
+       CFLAGS += -DHAVE_SETNS
+ endif
  
 -CFLAGS += -fPIC
 +CFLAGS += $(FPIC)
  
- UTILOBJ=utils.o rt_names.o ll_types.o ll_proto.o ll_addr.o inet_proto.o
+ UTILOBJ=utils.o rt_names.o ll_types.o ll_proto.o ll_addr.o inet_proto.o namespace.o
  
index 19d819974bb27fe5f4b2ab4e7a3225a2df6c76be..6c148ea65128ac016627d472ae4b3d074fcb0e33 100644 (file)
@@ -1,6 +1,6 @@
 --- a/tc/Makefile
 +++ b/tc/Makefile
-@@ -8,6 +8,7 @@ SHARED_LIBS ?= y
+@@ -13,6 +13,7 @@ SHARED_LIBS ?= y
  TCMODULES :=
  TCMODULES += q_fifo.o
  TCMODULES += q_sfq.o
index c0bf07aaddc124202b1dc11ea1888aa1c9977576..10167ae50c9786299d889749a8b6a39c160046a5 100644 (file)
@@ -1,13 +1,13 @@
 --- a/tc/Makefile
 +++ b/tc/Makefile
-@@ -39,6 +39,7 @@ TCMODULES += m_mirred.o
+@@ -44,6 +44,7 @@ TCMODULES += m_mirred.o
  TCMODULES += m_nat.o
  TCMODULES += m_pedit.o
  TCMODULES += m_skbedit.o
 +TCMODULES += m_connmark.o
  TCMODULES += m_csum.o
  TCMODULES += m_simple.o
- TCMODULES += p_ip.o
+ TCMODULES += m_vlan.o
 --- /dev/null
 +++ b/tc/m_connmark.c
 @@ -0,0 +1,74 @@
index 36201205d9c31ba239a85deb27d4bee11f68c415..4295d0aae93272212ac5d165838cf66827349817 100644 (file)
@@ -25,7 +25,7 @@
                sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
 --- a/ip/ip.c
 +++ b/ip/ip.c
-@@ -69,30 +69,42 @@ static const struct cmd {
+@@ -71,30 +71,42 @@ static const struct cmd {
        int (*func)(int argc, char **argv);
  } cmds[] = {
        { "address",    do_ipaddr },
@@ -70,7 +70,7 @@
  };
 --- a/lib/utils.c
 +++ b/lib/utils.c
-@@ -629,6 +629,7 @@ const char *rt_addr_n2a(int af, const vo
+@@ -630,6 +630,7 @@ const char *rt_addr_n2a(int af, const vo
        case AF_INET:
        case AF_INET6:
                return inet_ntop(af, addr, buf, buflen);
@@ -78,7 +78,7 @@
        case AF_IPX:
                return ipx_ntop(af, addr, buf, buflen);
        case AF_DECnet:
-@@ -637,6 +638,7 @@ const char *rt_addr_n2a(int af, const vo
+@@ -638,6 +639,7 @@ const char *rt_addr_n2a(int af, const vo
                memcpy(dna.a_addr, addr, 2);
                return dnet_ntop(af, &dna, buf, buflen);
        }
@@ -86,7 +86,7 @@
        default:
                return "???";
        }
-@@ -712,6 +714,7 @@ const char *format_host(int af, int len,
+@@ -713,6 +715,7 @@ const char *format_host(int af, int len,
                        case AF_INET6:
                                len = 16;
                                break;
@@ -94,7 +94,7 @@
                        case AF_IPX:
                                len = 10;
                                break;
-@@ -722,6 +725,7 @@ const char *format_host(int af, int len,
+@@ -723,6 +726,7 @@ const char *format_host(int af, int len,
                                len = 2;
                                break;
  #endif
                }
 --- a/lib/Makefile
 +++ b/lib/Makefile
-@@ -1,5 +1,9 @@
- include ../Config
+@@ -4,6 +4,10 @@ ifeq ($(IP_CONFIG_SETNS),y)
+       CFLAGS += -DHAVE_SETNS
+ endif
  
 +ifeq ($(IP_CONFIG_TINY),y)
 +  CFLAGS += -DIPROUTE2_TINY
 +
  CFLAGS += $(FPIC)
  
- UTILOBJ=utils.o rt_names.o ll_types.o ll_proto.o ll_addr.o inet_proto.o
+ UTILOBJ=utils.o rt_names.o ll_types.o ll_proto.o ll_addr.o inet_proto.o namespace.o