kernel: bump 4.14 to 4.14.214
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 9 Jan 2021 20:44:53 +0000 (21:44 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 12 Jan 2021 22:55:26 +0000 (23:55 +0100)
Refreshed all patches.

Removed patches because included in upstream:
- 499-mtd-parser-cmdline-Fix-parsing-of-part-names-with-co.patch
- 0071-2-PCI-qcom-Fixed-IPQ806x-PCIE-reset-changes.patch

Compile-tested on: ipq40xx, lantiq/xrx200, x86/64, ipq806x
Runtime-tested on: ipq40xx, lantiq/xrx200, x86/64

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
17 files changed:
include/kernel-version.mk
target/linux/ar71xx/patches-4.14/821-serial-core-add-support-for-boot-console-with-arbitr.patch
target/linux/ath25/patches-4.14/130-watchdog.patch
target/linux/ath79/patches-4.14/921-serial-core-add-support-for-boot-console-with-arbitr.patch
target/linux/bcm53xx/patches-4.14/905-BCM53573-minor-hacks.patch
target/linux/brcm47xx/patches-4.14/831-old_gpio_wdt.patch
target/linux/generic/backport-4.14/025-tcp-allow-drivers-to-tweak-TSQ-logic.patch
target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
target/linux/generic/hack-4.14/204-module_strip.patch
target/linux/generic/pending-4.14/499-mtd-parser-cmdline-Fix-parsing-of-part-names-with-co.patch [deleted file]
target/linux/ipq806x/patches-4.14/0071-1-PCI-qcom-Fixed-IPQ806x-specific-clocks.patch
target/linux/ipq806x/patches-4.14/0071-2-PCI-qcom-Fixed-IPQ806x-PCIE-reset-changes.patch [deleted file]
target/linux/ipq806x/patches-4.14/0071-3-PCI-qcom-Fixed-IPQ806x-PCIE-init-changes.patch
target/linux/ipq806x/patches-4.14/0071-6-PCI-qcom-Force-GEN1-support.patch
target/linux/ipq806x/patches-4.14/0071-7-pcie-Set-PCIE-MRRS-and-MPS-to-256B.patch
target/linux/ipq806x/patches-4.14/0071-8-pcie-qcom-Fixed-pcie_phy_clk-branch-issue.patch
target/linux/layerscape/patches-4.14/701-dpaa2-dpio-support-layerscape.patch

index 45f405383327af22d51fefe6abaea23d8bd018f4..0d42e167c882c200f4fe84abb416444f1a79b359 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .212
+LINUX_VERSION-4.14 = .214
 
-LINUX_KERNEL_HASH-4.14.212 = 0e1bc32c4842c3bbee3a15454408f528acd4d3c5e83312b93008d5ee2e9a0c79
+LINUX_KERNEL_HASH-4.14.214 = f54296216ace09a1bf81efaa9dbbd4ebbe8631dbf22df9c6f286157db827391e
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 23b6d73959aca642a42e10fa01f924512a0ec1af..3c33cd19cc3d5935ae812349dbf24236ce980bab 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Sungbo Eo <mans0n@gorani.run>
                        uport->cons->cflag = 0;
                }
                /*
-@@ -2072,8 +2074,10 @@ uart_set_options(struct uart_port *port,
+@@ -2076,8 +2078,10 @@ uart_set_options(struct uart_port *port,
         * Allow the setting of the UART parameters with a NULL console
         * too:
         */
index 01904d69a54e77a2991c43148484ecdcc9184f35..ac55711670dbd4cbc605832f8ea1ebbe6a117821 100644 (file)
 +MODULE_ALIAS("platform:" DRIVER_NAME);
 --- a/drivers/watchdog/Kconfig
 +++ b/drivers/watchdog/Kconfig
-@@ -1647,6 +1647,13 @@ config PIC32_DMT
+@@ -1648,6 +1648,13 @@ config PIC32_DMT
          To compile this driver as a loadable module, choose M here.
          The module will be called pic32-dmt.
  
index 23b6d73959aca642a42e10fa01f924512a0ec1af..3c33cd19cc3d5935ae812349dbf24236ce980bab 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Sungbo Eo <mans0n@gorani.run>
                        uport->cons->cflag = 0;
                }
                /*
-@@ -2072,8 +2074,10 @@ uart_set_options(struct uart_port *port,
+@@ -2076,8 +2078,10 @@ uart_set_options(struct uart_port *port,
         * Allow the setting of the UART parameters with a NULL console
         * too:
         */
index 39f4cf7662ffaa9c22e7ee4f4a1d08e420448dbd..4762505708e6cbecd164f32965503064e2ee4c54 100644 (file)
@@ -61,7 +61,7 @@ Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
  #include <linux/clockchips.h>
  #include <linux/clocksource.h>
  #include <linux/interrupt.h>
-@@ -836,6 +837,16 @@ static void arch_timer_of_configure_rate
+@@ -845,6 +846,16 @@ static void arch_timer_of_configure_rate
        if (of_property_read_u32(np, "clock-frequency", &arch_timer_rate))
                arch_timer_rate = rate;
  
index 88f472e63c8f1845f414dcf0877ea1c17027a08e..8b4ce63c645bb09a32f2e21045a9f26c37b2c936 100644 (file)
@@ -4,7 +4,7 @@ Signed-off-by: Mathias Adam <m.adam--openwrt@adamis.de>
 
 --- a/drivers/watchdog/Kconfig
 +++ b/drivers/watchdog/Kconfig
-@@ -1473,6 +1473,15 @@ config WDT_MTX1
+@@ -1474,6 +1474,15 @@ config WDT_MTX1
          Hardware driver for the MTX-1 boards. This is a watchdog timer that
          will reboot the machine after a 100 seconds timer expired.
  
index 51ed9517aa5c4f0fa572c783455f242751af74ef..39a3964af73e85d8ffaa1c7206d2dfd25b6f19b8 100644 (file)
@@ -65,7 +65,7 @@ Cc: Kir Kolyshkin <kir@openvz.org>
         * Before updating sk_refcnt, we must commit prior changes to memory
 --- a/net/ipv4/tcp_output.c
 +++ b/net/ipv4/tcp_output.c
-@@ -1699,7 +1699,7 @@ u32 tcp_tso_autosize(const struct sock *
+@@ -1700,7 +1700,7 @@ u32 tcp_tso_autosize(const struct sock *
  {
        u32 bytes, segs;
  
@@ -74,7 +74,7 @@ Cc: Kir Kolyshkin <kir@openvz.org>
                    sk->sk_gso_max_size - 1 - MAX_TCP_HEADER);
  
        /* Goal is to send at least one packet per ms,
-@@ -2217,7 +2217,7 @@ static bool tcp_small_queue_check(struct
+@@ -2218,7 +2218,7 @@ static bool tcp_small_queue_check(struct
  {
        unsigned int limit;
  
index 4315b8d6bbd80c117b4074bbbdff193b674bbf84..ecef1a4b2b52f994dbc8d2c8b9f9a97de965ace7 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
 
 --- a/drivers/usb/serial/option.c
 +++ b/drivers/usb/serial/option.c
-@@ -2012,7 +2012,8 @@ static const struct usb_device_id option
+@@ -2015,7 +2015,8 @@ static const struct usb_device_id option
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },                   /* D-Link DWM-156 (variant) */
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },
index d93b545b7ceccde15d5f4c87f9ef69e0fbe74fe7..33b90a83fe89d0fcc2e9f85bdad59c89c09dd453 100644 (file)
@@ -114,7 +114,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  config MODULES_TREE_LOOKUP
 --- a/kernel/module.c
 +++ b/kernel/module.c
-@@ -3024,9 +3024,11 @@ static struct module *setup_load_info(st
+@@ -3022,9 +3022,11 @@ static struct module *setup_load_info(st
  
  static int check_modinfo(struct module *mod, struct load_info *info, int flags)
  {
@@ -127,7 +127,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (flags & MODULE_INIT_IGNORE_VERMAGIC)
                modmagic = NULL;
  
-@@ -3047,6 +3049,7 @@ static int check_modinfo(struct module *
+@@ -3045,6 +3047,7 @@ static int check_modinfo(struct module *
                                mod->name);
                add_taint_module(mod, TAINT_OOT_MODULE, LOCKDEP_STILL_OK);
        }
diff --git a/target/linux/generic/pending-4.14/499-mtd-parser-cmdline-Fix-parsing-of-part-names-with-co.patch b/target/linux/generic/pending-4.14/499-mtd-parser-cmdline-Fix-parsing-of-part-names-with-co.patch
deleted file mode 100644 (file)
index 9fad266..0000000
+++ /dev/null
@@ -1,61 +0,0 @@
-From: Sven Eckelmann <sven@narfation.org>
-Date: Sun, 22 Nov 2020 00:48:33 +0100
-Subject: [PATCH RFC] mtd: parser: cmdline: Fix parsing of part-names with colons
-
-Some devices (especially QCA ones) are already using hardcoded partition
-names with colons in it. The OpenMesh A62 for example provides following
-mtd relevant information via cmdline:
-
-  root=31:11 mtdparts=spi0.0:256k(0:SBL1),128k(0:MIBIB),384k(0:QSEE),64k(0:CDT),64k(0:DDRPARAMS),64k(0:APPSBLENV),512k(0:APPSBL),64k(0:ART),64k(custom),64k(0:KEYS),0x002b0000(kernel),0x00c80000(rootfs),15552k(inactive) rootfsname=rootfs rootwait
-
-The change to split only on the last colon between mtd-id and partitions
-will cause newpart to see following string for the first partition:
-
-  KEYS),0x002b0000(kernel),0x00c80000(rootfs),15552k(inactive)
-
-Such a partition list cannot be parsed and thus the device fails to boot.
-
-Avoid this behavior by making sure that the start of the first part-name
-("(") will also be the last byte the mtd-id split algorithm is using for
-its colon search.
-
-Forwarded: https://patchwork.ozlabs.org/project/linux-mtd/patch/20201122001533.985641-1-sven@narfation.org/
-Fixes: eb13fa022741 ("mtd: parser: cmdline: Support MTD names containing one or more colons")
-Signed-off-by: Sven Eckelmann <sven@narfation.org>
-
---- a/drivers/mtd/cmdlinepart.c
-+++ b/drivers/mtd/cmdlinepart.c
-@@ -228,7 +228,7 @@ static int mtdpart_setup_real(char *s)
-               struct cmdline_mtd_partition *this_mtd;
-               struct mtd_partition *parts;
-               int mtd_id_len, num_parts;
--              char *p, *mtd_id, *semicol;
-+              char *p, *mtd_id, *semicol, *open_parenth;
-               /*
-                * Replace the first ';' by a NULL char so strrchr can work
-@@ -238,6 +238,13 @@ static int mtdpart_setup_real(char *s)
-               if (semicol)
-                       *semicol = '\0';
-+              /* make sure that part-names with ":" will not be handled as
-+               * part of the mtd-id with an ":"
-+               */
-+              open_parenth = strchr(s, '(');
-+              if (open_parenth)
-+                      *open_parenth = '\0';
-+
-               mtd_id = s;
-               /*
-@@ -247,6 +254,10 @@ static int mtdpart_setup_real(char *s)
-                */
-               p = strrchr(s, ':');
-+              /* Restore the '(' now. */
-+              if (open_parenth)
-+                      *open_parenth = '(';
-+
-               /* Restore the ';' now. */
-               if (semicol)
-                       *semicol = ';';
index b9f6e33be636dcab728915e0d1a85c997f6ef349..fd766028d938ea12d3ae3d1fd4aacd936cf3d457 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Sham Muthayyan <smuthayy@codeaurora.org>
        struct reset_control *pci_reset;
        struct reset_control *axi_reset;
        struct reset_control *ahb_reset;
-@@ -249,6 +251,14 @@ static int qcom_pcie_get_resources_2_1_0
+@@ -250,6 +252,14 @@ static int qcom_pcie_get_resources_2_1_0
        if (IS_ERR(res->phy_clk))
                return PTR_ERR(res->phy_clk);
  
@@ -35,7 +35,7 @@ Signed-off-by: Sham Muthayyan <smuthayy@codeaurora.org>
        res->pci_reset = devm_reset_control_get_exclusive(dev, "pci");
        if (IS_ERR(res->pci_reset))
                return PTR_ERR(res->pci_reset);
-@@ -281,6 +291,8 @@ static void qcom_pcie_deinit_2_1_0(struc
+@@ -287,6 +297,8 @@ static void qcom_pcie_deinit_2_1_0(struc
        clk_disable_unprepare(res->iface_clk);
        clk_disable_unprepare(res->core_clk);
        clk_disable_unprepare(res->phy_clk);
@@ -44,7 +44,7 @@ Signed-off-by: Sham Muthayyan <smuthayy@codeaurora.org>
        regulator_disable(res->vdda);
        regulator_disable(res->vdda_phy);
        regulator_disable(res->vdda_refclk);
-@@ -324,16 +336,28 @@ static int qcom_pcie_init_2_1_0(struct q
+@@ -330,16 +342,28 @@ static int qcom_pcie_init_2_1_0(struct q
                goto err_assert_ahb;
        }
  
@@ -76,7 +76,7 @@ Signed-off-by: Sham Muthayyan <smuthayy@codeaurora.org>
        }
  
        ret = reset_control_deassert(res->ahb_reset);
-@@ -389,10 +413,14 @@ static int qcom_pcie_init_2_1_0(struct q
+@@ -401,10 +425,14 @@ static int qcom_pcie_init_2_1_0(struct q
        return 0;
  
  err_deassert_ahb:
diff --git a/target/linux/ipq806x/patches-4.14/0071-2-PCI-qcom-Fixed-IPQ806x-PCIE-reset-changes.patch b/target/linux/ipq806x/patches-4.14/0071-2-PCI-qcom-Fixed-IPQ806x-PCIE-reset-changes.patch
deleted file mode 100644 (file)
index 8b9e5ff..0000000
+++ /dev/null
@@ -1,85 +0,0 @@
-From 490d103232287eb51c92c49a4ef8865fd0a9d59e Mon Sep 17 00:00:00 2001
-From: Sham Muthayyan <smuthayy@codeaurora.org>
-Date: Tue, 19 Jul 2016 18:58:18 +0530
-Subject: PCI: qcom: Fixed IPQ806x PCIE reset changes
-
-Change-Id: Ia6590e960b9754b1e8b7a51f318788cd63e9e321
-Signed-off-by: Sham Muthayyan <smuthayy@codeaurora.org>
----
- drivers/pci/host/pcie-qcom.c | 24 +++++++++++++++++++-----
- 1 file changed, 19 insertions(+), 5 deletions(-)
-
---- a/drivers/pci/dwc/pcie-qcom.c
-+++ b/drivers/pci/dwc/pcie-qcom.c
-@@ -98,6 +98,7 @@ struct qcom_pcie_resources_2_1_0 {
-       struct reset_control *ahb_reset;
-       struct reset_control *por_reset;
-       struct reset_control *phy_reset;
-+      struct reset_control *ext_reset;
-       struct regulator *vdda;
-       struct regulator *vdda_phy;
-       struct regulator *vdda_refclk;
-@@ -275,6 +276,10 @@ static int qcom_pcie_get_resources_2_1_0
-       if (IS_ERR(res->por_reset))
-               return PTR_ERR(res->por_reset);
-+      res->ext_reset = devm_reset_control_get(dev, "ext");
-+      if (IS_ERR(res->ext_reset))
-+              return PTR_ERR(res->ext_reset);
-+
-       res->phy_reset = devm_reset_control_get_exclusive(dev, "phy");
-       return PTR_ERR_OR_ZERO(res->phy_reset);
- }
-@@ -288,6 +293,7 @@ static void qcom_pcie_deinit_2_1_0(struc
-       reset_control_assert(res->ahb_reset);
-       reset_control_assert(res->por_reset);
-       reset_control_assert(res->pci_reset);
-+      reset_control_assert(res->ext_reset);
-       clk_disable_unprepare(res->iface_clk);
-       clk_disable_unprepare(res->core_clk);
-       clk_disable_unprepare(res->phy_clk);
-@@ -306,6 +312,12 @@ static int qcom_pcie_init_2_1_0(struct q
-       u32 val;
-       int ret;
-+      ret = reset_control_assert(res->ahb_reset);
-+      if (ret) {
-+              dev_err(dev, "cannot assert ahb reset\n");
-+              return ret;
-+      }
-+
-       ret = regulator_enable(res->vdda);
-       if (ret) {
-               dev_err(dev, "cannot enable vdda regulator\n");
-@@ -324,16 +336,16 @@ static int qcom_pcie_init_2_1_0(struct q
-               goto err_vdda_phy;
-       }
--      ret = reset_control_assert(res->ahb_reset);
-+      ret = reset_control_deassert(res->ext_reset);
-       if (ret) {
--              dev_err(dev, "cannot assert ahb reset\n");
--              goto err_assert_ahb;
-+              dev_err(dev, "cannot assert ext reset\n");
-+              goto err_reset_ext;
-       }
-       ret = clk_prepare_enable(res->iface_clk);
-       if (ret) {
-               dev_err(dev, "cannot prepare/enable iface clock\n");
--              goto err_assert_ahb;
-+              goto err_iface;
-       }
-       ret = clk_prepare_enable(res->core_clk);
-@@ -422,7 +434,9 @@ err_clk_phy:
-       clk_disable_unprepare(res->core_clk);
- err_clk_core:
-       clk_disable_unprepare(res->iface_clk);
--err_assert_ahb:
-+err_iface:
-+      reset_control_assert(res->ext_reset);
-+err_reset_ext:
-       regulator_disable(res->vdda_phy);
- err_vdda_phy:
-       regulator_disable(res->vdda_refclk);
index 57ee082c83d1a08820c1f684b3ed0be423b7076c..f8e65020a7af1e80e908c82f354047d57f6c3cb2 100644 (file)
@@ -87,7 +87,7 @@ Signed-off-by: Sham Muthayyan <smuthayy@codeaurora.org>
 -      u32 val;
        int ret;
  
-       ret = reset_control_assert(res->ahb_reset);
+       ret = regulator_enable(res->vdda);
 @@ -378,15 +410,26 @@ static int qcom_pcie_init_2_1_0(struct q
                goto err_deassert_ahb;
        }
index 5dea084bfa8c6556941e9896f737382de966de08..b9c5010b7473edf0d4f280c4f4299e915ca88b08 100644 (file)
@@ -40,7 +40,7 @@ Signed-off-by: Sham Muthayyan <smuthayy@codeaurora.org>
  
  
        /* Set the Max TLP size to 2K, instead of using default of 4K */
-@@ -1382,6 +1390,8 @@ static int qcom_pcie_probe(struct platfo
+@@ -1380,6 +1388,8 @@ static int qcom_pcie_probe(struct platfo
        struct dw_pcie *pci;
        struct qcom_pcie *pcie;
        int ret;
@@ -49,7 +49,7 @@ Signed-off-by: Sham Muthayyan <smuthayy@codeaurora.org>
  
        pcie = devm_kzalloc(dev, sizeof(*pcie), GFP_KERNEL);
        if (!pcie)
-@@ -1403,6 +1413,9 @@ static int qcom_pcie_probe(struct platfo
+@@ -1401,6 +1411,9 @@ static int qcom_pcie_probe(struct platfo
        if (IS_ERR(pcie->reset))
                return PTR_ERR(pcie->reset);
  
index c7dfd53cb177337fae263d01895046bff10e5835..166d6ac1a9b73e3c526d1d0bff112e697fdd198e 100644 (file)
@@ -31,7 +31,7 @@ Signed-off-by: Gokul Sriram Palanisamy <gpalan@codeaurora.org>
  struct qcom_pcie_resources_2_1_0 {
        struct clk *iface_clk;
        struct clk *core_clk;
-@@ -1472,6 +1480,35 @@ static int qcom_pcie_probe(struct platfo
+@@ -1470,6 +1478,35 @@ static int qcom_pcie_probe(struct platfo
        return 0;
  }
  
index 88bd7730c1f402255c6cddf14675759b45a132de..c2e66655a8407b05c5c3026f2f279c989dadbc6e 100644 (file)
@@ -47,14 +47,14 @@ Signed-off-by: Abhishek Sahu <absahu@codeaurora.org>
        reset_control_assert(res->axi_reset);
        reset_control_assert(res->ahb_reset);
 @@ -415,7 +416,6 @@ static void qcom_pcie_deinit_2_1_0(struc
-       reset_control_assert(res->ext_reset);
+       reset_control_assert(res->pci_reset);
        clk_disable_unprepare(res->iface_clk);
        clk_disable_unprepare(res->core_clk);
 -      clk_disable_unprepare(res->phy_clk);
        clk_disable_unprepare(res->aux_clk);
        clk_disable_unprepare(res->ref_clk);
        regulator_disable(res->vdda);
-@@ -472,12 +472,6 @@ static int qcom_pcie_init_2_1_0(struct q
+@@ -466,12 +466,6 @@ static int qcom_pcie_init_2_1_0(struct q
                goto err_clk_core;
        }
  
index ce5dfdbe86a98205a3fbbdb763add472c8d05692..9f3b3ba79aeed1a6a3086a3997bb3ae62586fedb 100644 (file)
@@ -371,7 +371,7 @@ Signed-off-by: Youri Querry <youri.querry_1@nxp.com>
  static irqreturn_t dpio_irq_handler(int irq_num, void *arg)
  {
        struct device *dev = (struct device *)arg;
-@@ -113,7 +91,7 @@ static int dpaa2_dpio_probe(struct fsl_m
+@@ -110,7 +88,7 @@ static int dpaa2_dpio_probe(struct fsl_m
        struct dpio_priv *priv;
        int err = -ENOMEM;
        struct device *dev = &dpio_dev->dev;
@@ -380,7 +380,7 @@ Signed-off-by: Youri Querry <youri.querry_1@nxp.com>
  
        priv = devm_kzalloc(dev, sizeof(*priv), GFP_KERNEL);
        if (!priv)
-@@ -135,6 +113,12 @@ static int dpaa2_dpio_probe(struct fsl_m
+@@ -132,6 +110,12 @@ static int dpaa2_dpio_probe(struct fsl_m
                goto err_open;
        }
  
@@ -393,7 +393,7 @@ Signed-off-by: Youri Querry <youri.querry_1@nxp.com>
        err = dpio_get_attributes(dpio_dev->mc_io, 0, dpio_dev->mc_handle,
                                  &dpio_attrs);
        if (err) {
-@@ -155,26 +139,35 @@ static int dpaa2_dpio_probe(struct fsl_m
+@@ -152,26 +136,35 @@ static int dpaa2_dpio_probe(struct fsl_m
        desc.dpio_id = dpio_dev->obj_desc.id;
  
        /* get the cpu to use for the affinity hint */
@@ -444,7 +444,7 @@ Signed-off-by: Youri Querry <youri.querry_1@nxp.com>
  
        err = fsl_mc_allocate_irqs(dpio_dev);
        if (err) {
-@@ -186,7 +179,7 @@ static int dpaa2_dpio_probe(struct fsl_m
+@@ -183,7 +176,7 @@ static int dpaa2_dpio_probe(struct fsl_m
        if (err)
                goto err_register_dpio_irq;
  
@@ -453,7 +453,7 @@ Signed-off-by: Youri Querry <youri.querry_1@nxp.com>
        if (!priv->io) {
                dev_err(dev, "dpaa2_io_create failed\n");
                goto err_dpaa2_io_create;
-@@ -196,7 +189,6 @@ static int dpaa2_dpio_probe(struct fsl_m
+@@ -193,7 +186,6 @@ static int dpaa2_dpio_probe(struct fsl_m
        dev_dbg(dev, "   receives_notifications = %d\n",
                desc.receives_notifications);
        dpio_close(dpio_dev->mc_io, 0, dpio_dev->mc_handle);
@@ -461,7 +461,7 @@ Signed-off-by: Youri Querry <youri.querry_1@nxp.com>
  
        return 0;
  
-@@ -207,6 +199,7 @@ err_register_dpio_irq:
+@@ -204,6 +196,7 @@ err_register_dpio_irq:
  err_allocate_irqs:
        dpio_disable(dpio_dev->mc_io, 0, dpio_dev->mc_handle);
  err_get_attr:
@@ -469,7 +469,7 @@ Signed-off-by: Youri Querry <youri.querry_1@nxp.com>
        dpio_close(dpio_dev->mc_io, 0, dpio_dev->mc_handle);
  err_open:
        fsl_mc_portal_free(dpio_dev->mc_io);
-@@ -227,7 +220,7 @@ static int dpaa2_dpio_remove(struct fsl_
+@@ -224,7 +217,7 @@ static int dpaa2_dpio_remove(struct fsl_
  {
        struct device *dev;
        struct dpio_priv *priv;
@@ -478,7 +478,7 @@ Signed-off-by: Youri Querry <youri.querry_1@nxp.com>
  
        dev = &dpio_dev->dev;
        priv = dev_get_drvdata(dev);
-@@ -236,11 +229,8 @@ static int dpaa2_dpio_remove(struct fsl_
+@@ -233,11 +226,8 @@ static int dpaa2_dpio_remove(struct fsl_
  
        dpio_teardown_irqs(dpio_dev);
  
@@ -492,7 +492,7 @@ Signed-off-by: Youri Querry <youri.querry_1@nxp.com>
  
        err = dpio_open(dpio_dev->mc_io, 0, dpio_dev->obj_desc.id,
                        &dpio_dev->mc_handle);
-@@ -261,7 +251,7 @@ static int dpaa2_dpio_remove(struct fsl_
+@@ -258,7 +248,7 @@ static int dpaa2_dpio_remove(struct fsl_
  
  err_open:
        fsl_mc_portal_free(dpio_dev->mc_io);
@@ -501,7 +501,7 @@ Signed-off-by: Youri Querry <youri.querry_1@nxp.com>
        return err;
  }
  
-@@ -285,11 +275,16 @@ static struct fsl_mc_driver dpaa2_dpio_d
+@@ -282,11 +272,16 @@ static struct fsl_mc_driver dpaa2_dpio_d
  
  static int dpio_driver_init(void)
  {