ramips: fix device name of netis WF-2881 to WF2881
authorSungbo Eo <mans0n@gorani.run>
Tue, 8 Oct 2019 13:21:13 +0000 (22:21 +0900)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 7 Feb 2020 13:33:17 +0000 (14:33 +0100)
The correct model name of WF-2881 is WF2881 without hyphen. The former used
boardnames are not added to SUPPORTED_DEVICES, to make it explicit that the
sysupgrade-tar image, which is newly added in the previous commit, should
not be used to upgrade from older version.

Signed-off-by: Sungbo Eo <mans0n@gorani.run>
[adjust commit title]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ramips/dts/mt7621_netis_wf-2881.dts [deleted file]
target/linux/ramips/dts/mt7621_netis_wf2881.dts [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk
target/linux/ramips/mt7621/base-files/etc/board.d/02_network
target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh

diff --git a/target/linux/ramips/dts/mt7621_netis_wf-2881.dts b/target/linux/ramips/dts/mt7621_netis_wf-2881.dts
deleted file mode 100644 (file)
index 9d37583..0000000
+++ /dev/null
@@ -1,139 +0,0 @@
-/dts-v1/;
-
-#include "mt7621.dtsi"
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-/ {
-       compatible = "netis,wf-2881", "mediatek,mt7621-soc";
-       model = "NETIS WF-2881";
-
-       aliases {
-               led-boot = &led_wps;
-               led-failsafe = &led_wps;
-               led-running = &led_wps;
-               led-upgrade = &led_wps;
-               label-mac-device = &ethernet;
-       };
-
-       chosen {
-               bootargs = "console=ttyS0,57600";
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               usb {
-                       label = "wf-2881:green:usb";
-                       gpios = <&gpio0 6 GPIO_ACTIVE_LOW>;
-                       trigger-sources = <&xhci_ehci_port1>, <&ehci_port2>;
-                       linux,default-trigger = "usbport";
-               };
-
-               led_wps: wps {
-                       label = "wf-2881:green:wps";
-                       gpios = <&gpio0 0 GPIO_ACTIVE_LOW>;
-               };
-       };
-
-       keys {
-               compatible = "gpio-keys";
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio0 12 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RESTART>;
-               };
-       };
-};
-
-&nand {
-       status = "okay";
-
-       partitions {
-               compatible = "fixed-partitions";
-               #address-cells = <1>;
-               #size-cells = <1>;
-
-               partition@0 {
-                       label = "u-boot";
-                       reg = <0x0 0x80000>;
-                       read-only;
-               };
-
-               partition@80000 {
-                       label = "config";
-                       reg = <0x80000 0x80000>;
-                       read-only;
-               };
-
-               factory: partition@100000 {
-                       label = "factory";
-                       reg = <0x100000 0x40000>;
-                       read-only;
-               };
-
-               partition@140000 {
-                       label = "firmware";
-                       reg = <0x140000 0x7e40000>;
-
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "kernel";
-                               reg = <0x0 0x400000>;
-                       };
-
-                       partition@400000 {
-                               label = "ubi";
-                               reg = <0x400000 0x7a40000>;
-                       };
-               };
-       };
-};
-
-&pcie {
-       status = "okay";
-};
-
-&pcie0 {
-       wifi@0,0 {
-               compatible = "mediatek,mt76";
-               reg = <0x0000 0 0 0 0>;
-               mediatek,mtd-eeprom = <&factory 0x8000>;
-               ieee80211-freq-limit = <5000000 6000000>;
-
-               led {
-                       led-sources = <2>;
-                       led-active-low;
-               };
-       };
-};
-
-&pcie1 {
-       wifi@0,0 {
-               compatible = "mediatek,mt76";
-               reg = <0x0000 0 0 0 0>;
-               mediatek,mtd-eeprom = <&factory 0x0000>;
-               ieee80211-freq-limit = <2400000 2500000>;
-
-               led {
-                       led-sources = <2>;
-                       led-active-low;
-               };
-       };
-};
-
-&ethernet {
-       mtd-mac-address = <&factory 0xe000>;
-};
-
-&state_default {
-       gpio {
-               ralink,group = "uart3", "uart2";
-               ralink,function = "gpio";
-       };
-};
diff --git a/target/linux/ramips/dts/mt7621_netis_wf2881.dts b/target/linux/ramips/dts/mt7621_netis_wf2881.dts
new file mode 100644 (file)
index 0000000..63a4975
--- /dev/null
@@ -0,0 +1,139 @@
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "netis,wf2881", "mediatek,mt7621-soc";
+       model = "NETIS WF2881";
+
+       aliases {
+               led-boot = &led_wps;
+               led-failsafe = &led_wps;
+               led-running = &led_wps;
+               led-upgrade = &led_wps;
+               label-mac-device = &ethernet;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,57600";
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               usb {
+                       label = "wf2881:green:usb";
+                       gpios = <&gpio0 6 GPIO_ACTIVE_LOW>;
+                       trigger-sources = <&xhci_ehci_port1>, <&ehci_port2>;
+                       linux,default-trigger = "usbport";
+               };
+
+               led_wps: wps {
+                       label = "wf2881:green:wps";
+                       gpios = <&gpio0 0 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 12 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+};
+
+&nand {
+       status = "okay";
+
+       partitions {
+               compatible = "fixed-partitions";
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x80000>;
+                       read-only;
+               };
+
+               partition@80000 {
+                       label = "config";
+                       reg = <0x80000 0x80000>;
+                       read-only;
+               };
+
+               factory: partition@100000 {
+                       label = "factory";
+                       reg = <0x100000 0x40000>;
+                       read-only;
+               };
+
+               partition@140000 {
+                       label = "firmware";
+                       reg = <0x140000 0x7e40000>;
+
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "kernel";
+                               reg = <0x0 0x400000>;
+                       };
+
+                       partition@400000 {
+                               label = "ubi";
+                               reg = <0x400000 0x7a40000>;
+                       };
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie0 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x8000>;
+               ieee80211-freq-limit = <5000000 6000000>;
+
+               led {
+                       led-sources = <2>;
+                       led-active-low;
+               };
+       };
+};
+
+&pcie1 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x0000>;
+               ieee80211-freq-limit = <2400000 2500000>;
+
+               led {
+                       led-sources = <2>;
+                       led-active-low;
+               };
+       };
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0xe000>;
+};
+
+&state_default {
+       gpio {
+               ralink,group = "uart3", "uart2";
+               ralink,function = "gpio";
+       };
+};
index fdb71ac5f32b7ae71718a979c9dfb15b5459420b..878d70c98e93d6d3178ec37c849ea05b2a5e1ce4 100644 (file)
@@ -624,7 +624,7 @@ define Device/netgear_wndr3700-v5
 endef
 TARGET_DEVICES += netgear_wndr3700-v5
 
-define Device/netis_wf-2881
+define Device/netis_wf2881
   BLOCKSIZE := 128k
   PAGESIZE := 2048
   FILESYSTEMS := squashfs
@@ -636,11 +636,10 @@ define Device/netis_wf-2881
   IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | \
        check-size $$$$(IMAGE_SIZE)
   DEVICE_VENDOR := NETIS
-  DEVICE_MODEL := WF-2881
+  DEVICE_MODEL := WF2881
   DEVICE_PACKAGES := kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
-  SUPPORTED_DEVICES += wf-2881
 endef
-TARGET_DEVICES += netis_wf-2881
+TARGET_DEVICES += netis_wf2881
 
 define Device/phicomm_k2p
   IMAGE_SIZE := 15744k
index c0412626f2c78a728842ed59b4eb86ad625468d5..9b7b56f0ba88754eb91973c33b47621fd8e4bcb7 100755 (executable)
@@ -43,7 +43,7 @@ ramips_setup_interfaces()
        netgear,r6350|\
        netgear,r6850|\
        netgear,wndr3700-v5|\
-       netis,wf-2881|\
+       netis,wf2881|\
        wevo,11acnas|\
        wevo,w2914ns-v2|\
        zio,freezio)
@@ -181,7 +181,7 @@ ramips_setup_macs()
        elecom,wrc-1900gst|\
        elecom,wrc-2533gst|\
        lenovo,newifi-d1|\
-       netis,wf-2881|\
+       netis,wf2881|\
        phicomm,k2p|\
        planex,vr500|\
        samknows,whitebox-v8|\
index eaddca0a831144c16709ab795e088c29d6407b9c..465ea0a90910ac5702211c8e8d3348846e6a872d 100755 (executable)
@@ -49,7 +49,7 @@ platform_do_upgrade() {
        netgear,r6260|\
        netgear,r6350|\
        netgear,r6850|\
-       netis,wf-2881|\
+       netis,wf2881|\
        xiaomi,mir3g|\
        xiaomi,mir3p)
                nand_do_upgrade "$1"