hostapd: introduce a client_cert option which is passed on to wpa_supplicant (#8876)
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 24 Jan 2012 20:54:13 +0000 (20:54 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 24 Jan 2012 20:54:13 +0000 (20:54 +0000)
SVN-Revision: 29901

package/hostapd/Makefile
package/hostapd/files/wpa_supplicant.sh

index 3b6b6feb3eb92406fd245ab56eb7e864b09a8b05..c4e5d9f25a212f04e1cad4a69126a19d5f4bbb8c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
 PKG_VERSION:=20111103
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_REV:=6caaae1e48da247b21b54ea6001646597e35d9b1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 1ab6c663e573bda96e6138a96a1b341773eec70b..9446202be3385793ee36fbb06d41cd04a8d130e2 100644 (file)
@@ -87,9 +87,11 @@ wpa_supplicant_setup_vif() {
                                        pairwise='pairwise=CCMP'
                                        group='group=CCMP'
                                        config_get identity "$vif" identity
+                                       config_get client_cert "$vif" client_cert
                                        config_get priv_key "$vif" priv_key
                                        config_get priv_key_pwd "$vif" priv_key_pwd
                                        identity="identity=\"$identity\""
+                                       client_cert="client_cert=\"$client_cert\""
                                        priv_key="private_key=\"$priv_key\""
                                        priv_key_pwd="private_key_passwd=\"$priv_key_pwd\""
                                ;;
@@ -132,6 +134,7 @@ network={
        $group
        $eap_type
        $ca_cert
+       $client_cert
        $priv_key
        $priv_key_pwd
        $phase2