iproute2: tc: fix missing em_ipset module
authorTony Ambardar <itugrok@yahoo.com>
Tue, 30 Jun 2020 05:07:19 +0000 (22:07 -0700)
committerHans Dedecker <dedeckeh@gmail.com>
Tue, 14 Jul 2020 20:00:43 +0000 (22:00 +0200)
Feature detection doesn't recognize ipset v7 use on kernel v5.x systems
and thus disables the tc ematch function em_ipset.

- backport patch:
  * 002-configure-support-ipset-v7.patch:
    650591a7a70c configure: support ipset version 7 with kernel version 5

Fixes: 4e0c54bc5bc8 ("kernel: add support for kernel 5.4")
Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
package/network/utils/iproute2/Makefile
package/network/utils/iproute2/patches/002-configure-support-ipset-v7.patch [new file with mode: 0644]

index a29b26f8172b7042eee147c443f6ace44b95abc5..56294430be396ade0712b10944b0b1b3f4d73f94 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
 PKG_VERSION:=5.7.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
diff --git a/package/network/utils/iproute2/patches/002-configure-support-ipset-v7.patch b/package/network/utils/iproute2/patches/002-configure-support-ipset-v7.patch
new file mode 100644 (file)
index 0000000..cd0c529
--- /dev/null
@@ -0,0 +1,32 @@
+From 650591a7a70cd79d826fcdc579a20c168c987cf2 Mon Sep 17 00:00:00 2001
+From: Tony Ambardar <tony.ambardar@gmail.com>
+Date: Tue, 7 Jul 2020 00:58:33 -0700
+Subject: [PATCH] configure: support ipset version 7 with kernel version 5
+
+The configure script checks for ipset v6 availability but doesn't test
+for v7, which is backward compatible and used on kernel v5.x systems.
+Update the script to test for both ipset versions. Without this change,
+the tc ematch function em_ipset will be disabled.
+
+Signed-off-by: Tony Ambardar <Tony.Ambardar@gmail.com>
+Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
+---
+ configure | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure b/configure
+index f415bf49..307912aa 100755
+--- a/configure
++++ b/configure
+@@ -208,7 +208,7 @@ typedef unsigned short ip_set_id_t;
+ #include <linux/netfilter/xt_set.h>
+ struct xt_set_info info;
+-#if IPSET_PROTOCOL == 6
++#if IPSET_PROTOCOL == 6 || IPSET_PROTOCOL == 7
+ int main(void)
+ {
+       return IPSET_MAXNAMELEN;
+-- 
+2.17.1
+