tools/zstd: compile with cmake
authorRosen Penev <rosenp@gmail.com>
Thu, 21 Jan 2021 04:54:58 +0000 (20:54 -0800)
committerPaul Spooren <mail@aparcar.org>
Sun, 31 Jan 2021 04:14:50 +0000 (18:14 -1000)
It's faster and more reliable.

Removed ccache cmake build dependency as it's now implicit.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
tools/Makefile
tools/zstd/Makefile

index 09fe340e6c3c583d2b8fbe279c6987c1bf7d5ce6..a2665dbc9a7b62e059aa253f2cbb08308d695a66 100644 (file)
@@ -72,6 +72,7 @@ $(curdir)/sdcc/compile := $(curdir)/bison/compile
 $(curdir)/squashfs/compile := $(curdir)/lzma-old/compile
 $(curdir)/squashfskit4/compile := $(curdir)/xz/compile $(curdir)/zlib/compile
 $(curdir)/zlib/compile := $(curdir)/cmake/compile
+$(curdir)/zstd/compile := $(curdir)/cmake/compile
 
 ifneq ($(HOST_OS),Linux)
   $(curdir)/squashfskit4/compile += $(curdir)/coreutils/compile
@@ -81,7 +82,7 @@ endif
 ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
 $(foreach tool, $(filter-out xz zstd patch pkgconf libressl cmake,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/compile))
 tools-y += ccache
-$(curdir)/ccache/compile := $(curdir)/cmake/compile $(curdir)/zstd/compile
+$(curdir)/ccache/compile := $(curdir)/zstd/compile
 endif
 
 # in case there is no patch tool on the host we need to make patch tool a
index 1107c0d92c1818c4fe19cab21ed26885e5fa915d..a0106f15f2d34402a067b9904f389930d9ec5426 100644 (file)
@@ -11,11 +11,16 @@ PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE
 PKG_CPE_ID:=cpe:/a:facebook:zstandard
 
+CMAKE_SOURCE_SUBDIR:=build/cmake
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/cmake.mk
 
-HOSTCC := $(HOSTCC_NOCACHE)
-HOST_MAKE_FLAGS = PREFIX=$(HOST_BUILD_PREFIX) HAVE_ZLIB=0 HAVE_LZMA=0 HAVE_LZ4=0
+CMAKE_HOST_OPTIONS += \
+       -DBUILD_TESTING=OFF \
+       -DCMAKE_C_COMPILER_LAUNCHER="" \
+       -DCMAKE_C_COMPILER=$(HOSTCC_NOCACHE) \
+       -DZSTD_LEGACY_SUPPORT=OFF
 
 $(eval $(call HostBuild))