tools: keep stamp file in $(STAGING_DIR_HOST)
authorYousong Zhou <yszhou4tech@gmail.com>
Thu, 24 Oct 2019 11:31:50 +0000 (11:31 +0000)
committerYousong Zhou <yszhou4tech@gmail.com>
Thu, 24 Oct 2019 11:34:34 +0000 (11:34 +0000)
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
tools/Makefile

index a161154b806b10a20c9ac220e85595918c3a32f1..23671cba91828fb74ee8b3557204685978b685bc 100644 (file)
@@ -152,6 +152,6 @@ $(curdir)/ := .config prereq
 $(curdir)/install: $(curdir)/compile
 
 tools_enabled = $(foreach tool,$(sort $(tools-y) $(tools-)),$(if $(filter $(tool),$(tools-y)),y,n))
-$(eval $(call stampfile,$(curdir),tools,compile,,_$(subst $(space),,$(tools_enabled))))
-$(eval $(call stampfile,$(curdir),tools,check,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),tools,compile,,_$(subst $(space),,$(tools_enabled)),$(STAGING_DIR_HOST)))
+$(eval $(call stampfile,$(curdir),tools,check,$(TMP_DIR)/.build,,$(STAGING_DIR_HOST)))
 $(eval $(call subdir,$(curdir)))