netifd: pass on delegate flag from dhcp to 6rd
authorSteven Barth <cyrus@openwrt.org>
Thu, 13 Mar 2014 10:33:26 +0000 (10:33 +0000)
committerSteven Barth <cyrus@openwrt.org>
Thu, 13 Mar 2014 10:33:26 +0000 (10:33 +0000)
SVN-Revision: 39909

package/network/config/netifd/Makefile
package/network/config/netifd/files/lib/netifd/dhcp.script
package/network/config/netifd/files/lib/netifd/proto/dhcp.sh

index 29c0300c6510c5de92cc6ebd0c1fd30d25d02344..d8ee840eb668203b514193e4ecd641be1946d26a 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netifd
-PKG_VERSION:=2014-03-11
+PKG_VERSION:=2014-03-13
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
index 77b77f5fece959bafe221bfaedf2ac1defc08a71..c59784036264cc5efadfadd619234974c0d86217 100755 (executable)
@@ -53,6 +53,7 @@ setup_interface () {
                json_add_string ip6prefix "$ip6rdprefix"
                json_add_int ip6prefixlen "$ip6rdprefixlen"
                json_add_string tunlink "$INTERFACE"
+               [ -n "$IFACE6RD_DELEGATE" ] && json_add_boolean delegate "$IFACE6RD_DELEGATE"
                json_close_object
 
                ubus call network add_dynamic "$(json_dump)"
index 80668ee4fde7c0c0ade93f525d9d0d3f631c63ce..0481d05132133287928e3aeb8d6135c470782c46 100755 (executable)
@@ -14,14 +14,15 @@ proto_dhcp_init_config() {
        proto_config_add_string 'reqopts:list(string)'
        proto_config_add_string iface6rd
        proto_config_add_string sendopts
+       proto_config_add_boolean delegate
 }
 
 proto_dhcp_setup() {
        local config="$1"
        local iface="$2"
 
-       local ipaddr hostname clientid vendorid broadcast reqopts iface6rd sendopts
-       json_get_vars ipaddr hostname clientid vendorid broadcast reqopts iface6rd sendopts
+       local ipaddr hostname clientid vendorid broadcast reqopts iface6rd sendopts delegate
+       json_get_vars ipaddr hostname clientid vendorid broadcast reqopts iface6rd sendopts delegate
 
        local opt dhcpopts
        for opt in $reqopts; do
@@ -35,6 +36,7 @@ proto_dhcp_setup() {
        [ "$broadcast" = 1 ] && broadcast="-B" || broadcast=
        [ -n "$clientid" ] && clientid="-x 0x3d:${clientid//:/}" || clientid="-C"
        [ -n "$iface6rd" ] && proto_export "IFACE6RD=$iface6rd"
+       [ "$delegate" = "0" ] && proto_export "IFACE6RD_DELEGATE=0"
 
        proto_export "INTERFACE=$config"
        proto_run_command "$config" udhcpc \