ramips: mt7621: harmonize naming scheme for Mikrotik
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Tue, 7 Apr 2020 08:34:33 +0000 (10:34 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 8 Apr 2020 11:46:30 +0000 (13:46 +0200)
So far, image/device/board names for Mikrotik devices in mt7621 have
been used quite inconsistently.

This patch harmonizes the naming scheme by applying the same style
as used lately in ath79, i.e. using "RouterBOARD" as separate word
in the model name (instead of RB prefix for the number) and deriving
the board/device name from that (= make lower case and replace spaces
by hyphens).

This style has already been used for most the model/DEVICE_MODEL
variables in mt7621, so this is essentially just adjusting the remaining
variables to that.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
12 files changed:
target/linux/ramips/dts/mt7621_mikrotik_rb750gr3.dts [deleted file]
target/linux/ramips/dts/mt7621_mikrotik_rbm11g.dts [deleted file]
target/linux/ramips/dts/mt7621_mikrotik_rbm33g.dts [deleted file]
target/linux/ramips/dts/mt7621_mikrotik_routerboard-750gr3.dts [new file with mode: 0644]
target/linux/ramips/dts/mt7621_mikrotik_routerboard-m11g.dts [new file with mode: 0644]
target/linux/ramips/dts/mt7621_mikrotik_routerboard-m33g.dts [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk
target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
target/linux/ramips/mt7621/base-files/etc/board.d/02_network
target/linux/ramips/mt7621/base-files/etc/board.d/03_gpio_switches
target/linux/ramips/mt7621/base-files/etc/uci-defaults/04_led_migration
target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh

diff --git a/target/linux/ramips/dts/mt7621_mikrotik_rb750gr3.dts b/target/linux/ramips/dts/mt7621_mikrotik_rb750gr3.dts
deleted file mode 100644 (file)
index e268b23..0000000
+++ /dev/null
@@ -1,178 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-/dts-v1/;
-
-#include "mt7621.dtsi"
-
-#include <dt-bindings/input/input.h>
-#include <dt-bindings/gpio/gpio.h>
-
-/ {
-       compatible = "mikrotik,rb750gr3", "mediatek,mt7621-soc";
-       model = "MikroTik RouterBOARD 750Gr3";
-
-       aliases {
-               led-boot = &led_usr;
-               led-failsafe = &led_usr;
-               led-running = &led_usr;
-               led-upgrade = &led_usr;
-       };
-
-       chosen {
-               bootargs = "console=ttyS0,115200";
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               pwr {
-                       label = "rb750gr3:blue:pwr";
-                       gpios = <&gpio 16 GPIO_ACTIVE_HIGH>;
-                       default-state = "on";
-               };
-
-               led_usr: usr {
-                       label = "rb750gr3:green:usr";
-                       gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
-               };
-       };
-
-       keys {
-               compatible = "gpio-keys";
-
-               mode {
-                       label = "mode";
-                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
-                       linux,code = <BTN_0>;
-               };
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RESTART>;
-               };
-       };
-
-       beeper {
-               compatible = "gpio-beeper";
-               gpios = <&gpio 15 GPIO_ACTIVE_HIGH>;
-       };
-
-       gpio_export {
-               compatible = "gpio-export";
-               #size-cells = <0>;
-
-               usb_power {
-                       gpio-export,name = "usb_power";
-                       gpio-export,output = <1>;
-                       gpios = <&gpio 12 GPIO_ACTIVE_HIGH>;
-               };
-       };
-};
-
-&spi0 {
-       status = "okay";
-
-       flash@0 {
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <20000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "RouterBoot";
-                               reg = <0x0 0x40000>;
-                               read-only;
-                               compatible = "fixed-partitions";
-                               #address-cells = <1>;
-                               #size-cells = <1>;
-
-                               partition@0 {
-                                       label = "bootloader1";
-                                       reg = <0x0 0xf000>;
-                                       read-only;
-                               };
-
-                               hard_config: partition@f000 {
-                                       label = "hard_config";
-                                       reg = <0xf000 0x1000>;
-                                       read-only;
-                               };
-
-                               partition@10000 {
-                                       label = "bootloader2";
-                                       reg = <0x10000 0xf000>;
-                                       read-only;
-                               };
-
-                               partition@20000 {
-                                       label = "soft_config";
-                                       reg = <0x20000 0x1000>;
-                               };
-
-                               partition@30000 {
-                                       label = "bios";
-                                       reg = <0x30000 0x1000>;
-                                       read-only;
-                               };
-                       };
-
-                       partition@40000 {
-                               compatible = "mikrotik,minor";
-                               label = "firmware";
-                               reg = <0x040000 0xfc0000>;
-                       };
-               };
-       };
-};
-
-&gmac0 {
-       mtd-mac-address = <&hard_config 0x0010>;
-       mtd-mac-address-increment = <1>;
-};
-
-&switch0 {
-       ports {
-               port@0 {
-                       status = "okay";
-                       label = "wan";
-                       mtd-mac-address = <&hard_config 0x0010>;
-                       mtd-mac-address-increment = <2>;
-               };
-
-               port@1 {
-                       status = "okay";
-                       label = "lan2";
-               };
-
-               port@2 {
-                       status = "okay";
-                       label = "lan3";
-               };
-
-               port@3 {
-                       status = "okay";
-                       label = "lan4";
-               };
-
-               port@4 {
-                       status = "okay";
-                       label = "lan5";
-               };
-       };
-};
-
-&state_default {
-       gpio {
-               /* via gpio7 (uart3 group) the PoE status can be read */
-               groups = "uart2", "uart3", "jtag", "wdt";
-               function = "gpio";
-       };
-};
-
-&sdhci {
-       status = "okay";
-};
diff --git a/target/linux/ramips/dts/mt7621_mikrotik_rbm11g.dts b/target/linux/ramips/dts/mt7621_mikrotik_rbm11g.dts
deleted file mode 100644 (file)
index aae899c..0000000
+++ /dev/null
@@ -1,168 +0,0 @@
-/dts-v1/;
-
-#include "mt7621.dtsi"
-
-#include <dt-bindings/input/input.h>
-#include <dt-bindings/gpio/gpio.h>
-
-/ {
-       compatible = "mikrotik,rbm11g", "mediatek,mt7621-soc";
-       model = "MikroTik RouterBOARD M11G";
-
-       aliases {
-               led-boot = &led_usr;
-               led-failsafe = &led_usr;
-               led-running = &led_usr;
-               led-upgrade = &led_usr;
-       };
-
-       chosen {
-               bootargs = "console=ttyS0,115200";
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               led_usr: usr {
-                       label = "rbm11g:green:usr";
-                       gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
-               };
-
-               rssi0 {
-                       label = "rbm11g:green:rssi0";
-                       gpios = <&gpio 22 GPIO_ACTIVE_LOW>;
-               };
-
-               rssi1 {
-                       label = "rbm11g:green:rssi1";
-                       gpios = <&gpio 23 GPIO_ACTIVE_LOW>;
-               };
-
-               rssi2 {
-                       label = "rbm11g:green:rssi2";
-                       gpios = <&gpio 24 GPIO_ACTIVE_LOW>;
-               };
-
-               rssi3 {
-                       label = "rbm11g:green:rssi3";
-                       gpios = <&gpio 25 GPIO_ACTIVE_LOW>;
-               };
-
-               rssi4 {
-                       label = "rbm11g:green:rssi4";
-                       gpios = <&gpio 26 GPIO_ACTIVE_LOW>;
-               };
-       };
-
-       keys {
-               compatible = "gpio-keys";
-
-               res {
-                       label = "reset";
-                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RESTART>;
-               };
-       };
-
-       pcie0_vcc_reg {
-               compatible = "regulator-fixed";
-               regulator-name = "pcie0_vcc";
-
-               regulator-min-microvolt = <3300000>;
-               regulator-max-microvolt = <3300000>;
-               gpio = <&gpio 9 GPIO_ACTIVE_HIGH>;
-               enable-active-high;
-               regulator-boot-on;
-               regulator-always-on;
-       };
-};
-
-&spi0 {
-       status = "okay";
-
-       w25q128@0 {
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               // XXX empiric value to obtain actual 10MHz SCK at the chip
-               spi-max-frequency = <3125000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "RouterBoot";
-                               reg = <0x0 0x40000>;
-                               read-only;
-                               compatible = "fixed-partitions";
-                               #address-cells = <1>;
-                               #size-cells = <1>;
-
-                               partition@0 {
-                                       label = "bootloader1";
-                                       reg = <0x0 0xf000>;
-                                       read-only;
-                               };
-
-                               hard_config: partition@f000 {
-                                       label = "hard_config";
-                                       reg = <0xf000 0x1000>;
-                                       read-only;
-                               };
-
-                               partition@10000 {
-                                       label = "bootloader2";
-                                       reg = <0x10000 0xf000>;
-                                       read-only;
-                               };
-
-                               partition@20000 {
-                                       label = "soft_config";
-                                       reg = <0x20000 0x1000>;
-                               };
-
-                               partition@30000 {
-                                       label = "bios";
-                                       reg = <0x30000 0x1000>;
-                                       read-only;
-                               };
-                       };
-
-                       partition@40000 {
-                               compatible = "mikrotik,minor";
-                               label = "firmware";
-                               reg = <0x040000 0xFC0000>;
-                       };
-               };
-       };
-};
-
-&gmac0 {
-       mtd-mac-address = <&hard_config 0x0010>;
-       mtd-mac-address-increment = <1>;
-};
-
-&switch0 {
-       ports {
-               port@0 {
-                       status = "okay";
-                       label = "lan";
-               };
-       };
-};
-
-&state_default {
-       gpio {
-               groups = "uart2", "wdt", "rgmii2";
-               function = "gpio";
-       };
-};
-
-&i2c {
-       status = "okay";
-};
-
-&pcie {
-       status = "okay";
-};
diff --git a/target/linux/ramips/dts/mt7621_mikrotik_rbm33g.dts b/target/linux/ramips/dts/mt7621_mikrotik_rbm33g.dts
deleted file mode 100644 (file)
index f7889bd..0000000
+++ /dev/null
@@ -1,208 +0,0 @@
-/dts-v1/;
-
-#include "mt7621.dtsi"
-
-#include <dt-bindings/input/input.h>
-#include <dt-bindings/gpio/gpio.h>
-
-/ {
-       compatible = "mikrotik,rbm33g", "mediatek,mt7621-soc";
-       model = "MikroTik RouterBOARD M33G";
-
-       aliases {
-               led-boot = &led_usr;
-               led-failsafe = &led_usr;
-               led-running = &led_usr;
-               led-upgrade = &led_usr;
-       };
-
-       chosen {
-               bootargs = "console=ttyS0,115200";
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               led_usr: usr {
-                       label = "rbm33g:green:usr";
-                       gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
-               };
-       };
-
-       keys {
-               compatible = "gpio-keys";
-
-               res {
-                       label = "res";
-                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RESTART>;
-               };
-       };
-
-       pcie0_vcc_reg {
-               compatible = "regulator-fixed";
-               regulator-name = "pcie0_vcc";
-
-               regulator-min-microvolt = <3300000>;
-               regulator-max-microvolt = <3300000>;
-               gpio = <&gpio 9 GPIO_ACTIVE_HIGH>;
-               enable-active-high;
-               regulator-boot-on;
-               regulator-always-on;
-       };
-
-       pcie1_vcc_reg {
-               compatible = "regulator-fixed";
-               regulator-name = "pcie1_vcc";
-
-               regulator-min-microvolt = <3300000>;
-               regulator-max-microvolt = <3300000>;
-               gpio = <&gpio 10 GPIO_ACTIVE_HIGH>;
-               enable-active-high;
-               regulator-boot-on;
-               regulator-always-on;
-       };
-
-       pcie2_vcc_reg {
-               compatible = "regulator-fixed";
-               regulator-name = "pcie2_vcc";
-
-               regulator-min-microvolt = <3300000>;
-               regulator-max-microvolt = <3300000>;
-               gpio = <&gpio 11 GPIO_ACTIVE_HIGH>;
-               enable-active-high;
-               regulator-boot-on;
-               regulator-always-on;
-       };
-
-       usb_vcc_reg {
-               compatible = "regulator-fixed";
-               regulator-name = "usb_vcc";
-
-               regulator-min-microvolt = <5000000>;
-               regulator-max-microvolt = <5000000>;
-               gpio = <&gpio 12 GPIO_ACTIVE_HIGH>;
-               enable-active-high;
-               regulator-always-on;
-       };
-};
-
-&spi0 {
-       status = "okay";
-
-       w25q40@0 {
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <3125000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "RouterBoot";
-                               reg = <0x0 0x40000>;
-                               read-only;
-                               compatible = "fixed-partitions";
-                               #address-cells = <1>;
-                               #size-cells = <1>;
-
-                               partition@0 {
-                                       label = "bootloader1";
-                                       reg = <0x0 0xf000>;
-                                       read-only;
-                               };
-
-                               hard_config: partition@f000 {
-                                       label = "hard_config";
-                                       reg = <0xf000 0x1000>;
-                                       read-only;
-                               };
-
-                               partition@10000 {
-                                       label = "bootloader2";
-                                       reg = <0x10000 0xf000>;
-                                       read-only;
-                               };
-
-                               partition@20000 {
-                                       label = "soft_config";
-                                       reg = <0x20000 0x1000>;
-                               };
-
-                               partition@30000 {
-                                       label = "bios";
-                                       reg = <0x30000 0x1000>;
-                                       read-only;
-                               };
-                       };
-               };
-       };
-
-       w25q128@1 {
-               compatible = "jedec,spi-nor";
-               reg = <1>;
-               // XXX empiric value to obtain actual 10MHz SCK at the chip
-               spi-max-frequency = <3125000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       // Region <0x0 0x40000> seems reserved by OEM
-
-                       partition@40000 {
-                               compatible = "mikrotik,minor";
-                               label = "firmware";
-                               reg = <0x040000 0xFC0000>;
-                       };
-               };
-       };
-};
-
-&gmac0 {
-       mtd-mac-address = <&hard_config 0x0010>;
-       mtd-mac-address-increment = <1>;
-};
-
-&switch0 {
-       ports {
-               port@0 {
-                       status = "okay";
-                       label = "wan";
-                       mtd-mac-address = <&hard_config 0x0010>;
-                       mtd-mac-address-increment = <2>;
-               };
-
-               port@1 {
-                       status = "okay";
-                       label = "lan1";
-               };
-
-               port@2 {
-                       status = "okay";
-                       label = "lan2";
-               };
-       };
-};
-
-&state_default {
-       gpio {
-               groups = "uart2", "wdt";
-               function = "gpio";
-       };
-};
-
-&sdhci {
-       status = "okay";
-};
-
-&i2c {
-       status = "okay";
-};
-
-&pcie {
-       status = "okay";
-};
diff --git a/target/linux/ramips/dts/mt7621_mikrotik_routerboard-750gr3.dts b/target/linux/ramips/dts/mt7621_mikrotik_routerboard-750gr3.dts
new file mode 100644 (file)
index 0000000..3f37155
--- /dev/null
@@ -0,0 +1,178 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/gpio/gpio.h>
+
+/ {
+       compatible = "mikrotik,routerboard-750gr3", "mediatek,mt7621-soc";
+       model = "MikroTik RouterBOARD 750Gr3";
+
+       aliases {
+               led-boot = &led_usr;
+               led-failsafe = &led_usr;
+               led-running = &led_usr;
+               led-upgrade = &led_usr;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               pwr {
+                       label = "routerboard-750gr3:blue:pwr";
+                       gpios = <&gpio 16 GPIO_ACTIVE_HIGH>;
+                       default-state = "on";
+               };
+
+               led_usr: usr {
+                       label = "routerboard-750gr3:green:usr";
+                       gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               mode {
+                       label = "mode";
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+                       linux,code = <BTN_0>;
+               };
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       beeper {
+               compatible = "gpio-beeper";
+               gpios = <&gpio 15 GPIO_ACTIVE_HIGH>;
+       };
+
+       gpio_export {
+               compatible = "gpio-export";
+               #size-cells = <0>;
+
+               usb_power {
+                       gpio-export,name = "usb_power";
+                       gpio-export,output = <1>;
+                       gpios = <&gpio 12 GPIO_ACTIVE_HIGH>;
+               };
+       };
+};
+
+&spi0 {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <20000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "RouterBoot";
+                               reg = <0x0 0x40000>;
+                               read-only;
+                               compatible = "fixed-partitions";
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+
+                               partition@0 {
+                                       label = "bootloader1";
+                                       reg = <0x0 0xf000>;
+                                       read-only;
+                               };
+
+                               hard_config: partition@f000 {
+                                       label = "hard_config";
+                                       reg = <0xf000 0x1000>;
+                                       read-only;
+                               };
+
+                               partition@10000 {
+                                       label = "bootloader2";
+                                       reg = <0x10000 0xf000>;
+                                       read-only;
+                               };
+
+                               partition@20000 {
+                                       label = "soft_config";
+                                       reg = <0x20000 0x1000>;
+                               };
+
+                               partition@30000 {
+                                       label = "bios";
+                                       reg = <0x30000 0x1000>;
+                                       read-only;
+                               };
+                       };
+
+                       partition@40000 {
+                               compatible = "mikrotik,minor";
+                               label = "firmware";
+                               reg = <0x040000 0xfc0000>;
+                       };
+               };
+       };
+};
+
+&gmac0 {
+       mtd-mac-address = <&hard_config 0x0010>;
+       mtd-mac-address-increment = <1>;
+};
+
+&switch0 {
+       ports {
+               port@0 {
+                       status = "okay";
+                       label = "wan";
+                       mtd-mac-address = <&hard_config 0x0010>;
+                       mtd-mac-address-increment = <2>;
+               };
+
+               port@1 {
+                       status = "okay";
+                       label = "lan2";
+               };
+
+               port@2 {
+                       status = "okay";
+                       label = "lan3";
+               };
+
+               port@3 {
+                       status = "okay";
+                       label = "lan4";
+               };
+
+               port@4 {
+                       status = "okay";
+                       label = "lan5";
+               };
+       };
+};
+
+&state_default {
+       gpio {
+               /* via gpio7 (uart3 group) the PoE status can be read */
+               groups = "uart2", "uart3", "jtag", "wdt";
+               function = "gpio";
+       };
+};
+
+&sdhci {
+       status = "okay";
+};
diff --git a/target/linux/ramips/dts/mt7621_mikrotik_routerboard-m11g.dts b/target/linux/ramips/dts/mt7621_mikrotik_routerboard-m11g.dts
new file mode 100644 (file)
index 0000000..bd58aea
--- /dev/null
@@ -0,0 +1,168 @@
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/gpio/gpio.h>
+
+/ {
+       compatible = "mikrotik,routerboard-m11g", "mediatek,mt7621-soc";
+       model = "MikroTik RouterBOARD M11G";
+
+       aliases {
+               led-boot = &led_usr;
+               led-failsafe = &led_usr;
+               led-running = &led_usr;
+               led-upgrade = &led_usr;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_usr: usr {
+                       label = "routerboard-m11g:green:usr";
+                       gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
+               };
+
+               rssi0 {
+                       label = "routerboard-m11g:green:rssi0";
+                       gpios = <&gpio 22 GPIO_ACTIVE_LOW>;
+               };
+
+               rssi1 {
+                       label = "routerboard-m11g:green:rssi1";
+                       gpios = <&gpio 23 GPIO_ACTIVE_LOW>;
+               };
+
+               rssi2 {
+                       label = "routerboard-m11g:green:rssi2";
+                       gpios = <&gpio 24 GPIO_ACTIVE_LOW>;
+               };
+
+               rssi3 {
+                       label = "routerboard-m11g:green:rssi3";
+                       gpios = <&gpio 25 GPIO_ACTIVE_LOW>;
+               };
+
+               rssi4 {
+                       label = "routerboard-m11g:green:rssi4";
+                       gpios = <&gpio 26 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               res {
+                       label = "reset";
+                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       pcie0_vcc_reg {
+               compatible = "regulator-fixed";
+               regulator-name = "pcie0_vcc";
+
+               regulator-min-microvolt = <3300000>;
+               regulator-max-microvolt = <3300000>;
+               gpio = <&gpio 9 GPIO_ACTIVE_HIGH>;
+               enable-active-high;
+               regulator-boot-on;
+               regulator-always-on;
+       };
+};
+
+&spi0 {
+       status = "okay";
+
+       w25q128@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               // XXX empiric value to obtain actual 10MHz SCK at the chip
+               spi-max-frequency = <3125000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "RouterBoot";
+                               reg = <0x0 0x40000>;
+                               read-only;
+                               compatible = "fixed-partitions";
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+
+                               partition@0 {
+                                       label = "bootloader1";
+                                       reg = <0x0 0xf000>;
+                                       read-only;
+                               };
+
+                               hard_config: partition@f000 {
+                                       label = "hard_config";
+                                       reg = <0xf000 0x1000>;
+                                       read-only;
+                               };
+
+                               partition@10000 {
+                                       label = "bootloader2";
+                                       reg = <0x10000 0xf000>;
+                                       read-only;
+                               };
+
+                               partition@20000 {
+                                       label = "soft_config";
+                                       reg = <0x20000 0x1000>;
+                               };
+
+                               partition@30000 {
+                                       label = "bios";
+                                       reg = <0x30000 0x1000>;
+                                       read-only;
+                               };
+                       };
+
+                       partition@40000 {
+                               compatible = "mikrotik,minor";
+                               label = "firmware";
+                               reg = <0x040000 0xFC0000>;
+                       };
+               };
+       };
+};
+
+&gmac0 {
+       mtd-mac-address = <&hard_config 0x0010>;
+       mtd-mac-address-increment = <1>;
+};
+
+&switch0 {
+       ports {
+               port@0 {
+                       status = "okay";
+                       label = "lan";
+               };
+       };
+};
+
+&state_default {
+       gpio {
+               groups = "uart2", "wdt", "rgmii2";
+               function = "gpio";
+       };
+};
+
+&i2c {
+       status = "okay";
+};
+
+&pcie {
+       status = "okay";
+};
diff --git a/target/linux/ramips/dts/mt7621_mikrotik_routerboard-m33g.dts b/target/linux/ramips/dts/mt7621_mikrotik_routerboard-m33g.dts
new file mode 100644 (file)
index 0000000..19e1a71
--- /dev/null
@@ -0,0 +1,208 @@
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/gpio/gpio.h>
+
+/ {
+       compatible = "mikrotik,routerboard-m33g", "mediatek,mt7621-soc";
+       model = "MikroTik RouterBOARD M33G";
+
+       aliases {
+               led-boot = &led_usr;
+               led-failsafe = &led_usr;
+               led-running = &led_usr;
+               led-upgrade = &led_usr;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_usr: usr {
+                       label = "routerboard-m33g:green:usr";
+                       gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               res {
+                       label = "res";
+                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       pcie0_vcc_reg {
+               compatible = "regulator-fixed";
+               regulator-name = "pcie0_vcc";
+
+               regulator-min-microvolt = <3300000>;
+               regulator-max-microvolt = <3300000>;
+               gpio = <&gpio 9 GPIO_ACTIVE_HIGH>;
+               enable-active-high;
+               regulator-boot-on;
+               regulator-always-on;
+       };
+
+       pcie1_vcc_reg {
+               compatible = "regulator-fixed";
+               regulator-name = "pcie1_vcc";
+
+               regulator-min-microvolt = <3300000>;
+               regulator-max-microvolt = <3300000>;
+               gpio = <&gpio 10 GPIO_ACTIVE_HIGH>;
+               enable-active-high;
+               regulator-boot-on;
+               regulator-always-on;
+       };
+
+       pcie2_vcc_reg {
+               compatible = "regulator-fixed";
+               regulator-name = "pcie2_vcc";
+
+               regulator-min-microvolt = <3300000>;
+               regulator-max-microvolt = <3300000>;
+               gpio = <&gpio 11 GPIO_ACTIVE_HIGH>;
+               enable-active-high;
+               regulator-boot-on;
+               regulator-always-on;
+       };
+
+       usb_vcc_reg {
+               compatible = "regulator-fixed";
+               regulator-name = "usb_vcc";
+
+               regulator-min-microvolt = <5000000>;
+               regulator-max-microvolt = <5000000>;
+               gpio = <&gpio 12 GPIO_ACTIVE_HIGH>;
+               enable-active-high;
+               regulator-always-on;
+       };
+};
+
+&spi0 {
+       status = "okay";
+
+       w25q40@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <3125000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "RouterBoot";
+                               reg = <0x0 0x40000>;
+                               read-only;
+                               compatible = "fixed-partitions";
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+
+                               partition@0 {
+                                       label = "bootloader1";
+                                       reg = <0x0 0xf000>;
+                                       read-only;
+                               };
+
+                               hard_config: partition@f000 {
+                                       label = "hard_config";
+                                       reg = <0xf000 0x1000>;
+                                       read-only;
+                               };
+
+                               partition@10000 {
+                                       label = "bootloader2";
+                                       reg = <0x10000 0xf000>;
+                                       read-only;
+                               };
+
+                               partition@20000 {
+                                       label = "soft_config";
+                                       reg = <0x20000 0x1000>;
+                               };
+
+                               partition@30000 {
+                                       label = "bios";
+                                       reg = <0x30000 0x1000>;
+                                       read-only;
+                               };
+                       };
+               };
+       };
+
+       w25q128@1 {
+               compatible = "jedec,spi-nor";
+               reg = <1>;
+               // XXX empiric value to obtain actual 10MHz SCK at the chip
+               spi-max-frequency = <3125000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       // Region <0x0 0x40000> seems reserved by OEM
+
+                       partition@40000 {
+                               compatible = "mikrotik,minor";
+                               label = "firmware";
+                               reg = <0x040000 0xFC0000>;
+                       };
+               };
+       };
+};
+
+&gmac0 {
+       mtd-mac-address = <&hard_config 0x0010>;
+       mtd-mac-address-increment = <1>;
+};
+
+&switch0 {
+       ports {
+               port@0 {
+                       status = "okay";
+                       label = "wan";
+                       mtd-mac-address = <&hard_config 0x0010>;
+                       mtd-mac-address-increment = <2>;
+               };
+
+               port@1 {
+                       status = "okay";
+                       label = "lan1";
+               };
+
+               port@2 {
+                       status = "okay";
+                       label = "lan2";
+               };
+       };
+};
+
+&state_default {
+       gpio {
+               groups = "uart2", "wdt";
+               function = "gpio";
+       };
+};
+
+&sdhci {
+       status = "okay";
+};
+
+&i2c {
+       status = "okay";
+};
+
+&pcie {
+       status = "okay";
+};
index 0ecd70685bef4d7602153912aad6f725023a0cd6..ec9d8aacae8165b80705febc5a9ff1d903fd57c1 100644 (file)
@@ -495,25 +495,27 @@ define Device/MikroTik
        check-size
 endef
 
-define Device/mikrotik_rb750gr3
+define Device/mikrotik_routerboard-750gr3
   $(Device/MikroTik)
-  DEVICE_MODEL := RouterBOARD RB750G
-  DEVICE_VARIANT := r3
+  DEVICE_MODEL := RouterBOARD 750Gr3
   DEVICE_PACKAGES += kmod-gpio-beeper
+  SUPPORTED_DEVICES += mikrotik,rb750gr3
 endef
-TARGET_DEVICES += mikrotik_rb750gr3
+TARGET_DEVICES += mikrotik_routerboard-750gr3
 
-define Device/mikrotik_rbm11g
+define Device/mikrotik_routerboard-m11g
   $(Device/MikroTik)
   DEVICE_MODEL := RouterBOARD M11G
+  SUPPORTED_DEVICES += mikrotik,rbm11g
 endef
-TARGET_DEVICES += mikrotik_rbm11g
+TARGET_DEVICES += mikrotik_routerboard-m11g
 
-define Device/mikrotik_rbm33g
+define Device/mikrotik_routerboard-m33g
   $(Device/MikroTik)
   DEVICE_MODEL := RouterBOARD M33G
+  SUPPORTED_DEVICES += mikrotik,rbm33g
 endef
-TARGET_DEVICES += mikrotik_rbm33g
+TARGET_DEVICES += mikrotik_routerboard-m33g
 
 define Device/mqmaker_witi
   IMAGE_SIZE := 16064k
index 66739a75368e84b2326f405ec1f7a0eb3d15c231..cc114da4ee2f09d42e4f8e135491661f13ac7f0b 100755 (executable)
@@ -34,7 +34,7 @@ gnubee,gb-pc2)
        ucidef_set_led_netdev "lan1" "lan1" "$boardname:green:lan1" "lan1"
        ucidef_set_led_netdev "lan2" "lan2" "$boardname:green:lan2" "lan2"
        ;;
-mikrotik,rbm11g)
+mikrotik,routerboard-m11g)
        ucidef_set_rssimon "wlan0" "200000" "1"
        ucidef_set_led_rssi "rssilow" "RSSILOW" "$boardname:green:rssi0" "wlan0" "1" "100"
        ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "$boardname:green:rssi1" "wlan0" "20" "100"
index f654574e1400cc691dd993a39d0a3fb4fda98a01..f573a049ce7128d74366400800d7cf882f4375f8 100755 (executable)
@@ -14,7 +14,7 @@ ramips_setup_interfaces()
                ;;
        asiarf,ap7621-nv1|\
        lenovo,newifi-d1|\
-       mikrotik,rbm33g|\
+       mikrotik,routerboard-m33g|\
        xiaomi,mir3g|\
        xiaomi,mir3g-v2)
                ucidef_set_interfaces_lan_wan "lan1 lan2" "wan"
@@ -31,7 +31,7 @@ ramips_setup_interfaces()
        linksys,re6500)
                ucidef_set_interface_lan "lan1 lan2 lan3 lan4"
                ;;
-       mikrotik,rbm11g|\
+       mikrotik,routerboard-m11g|\
        netgear,ex6150|\
        thunder,timecloud|\
        tplink,re350-v1|\
@@ -39,7 +39,7 @@ ramips_setup_interfaces()
        ubnt,unifi-nanohd)
                ucidef_set_interface_lan "lan"
                ;;
-       mikrotik,rb750gr3)
+       mikrotik,routerboard-750gr3)
                ucidef_set_interfaces_lan_wan "lan2 lan3 lan4 lan5" "wan"
                ;;
        ubiquiti,edgerouterx|\
@@ -89,9 +89,9 @@ ramips_setup_macs()
                wan_mac=$(mtd_get_mac_ascii u-boot-env wanaddr)
                label_mac=$wan_mac
                ;;
-       mikrotik,rb750gr3|\
-       mikrotik,rbm11g|\
-       mikrotik,rbm33g)
+       mikrotik,routerboard-750gr3|\
+       mikrotik,routerboard-m11g|\
+       mikrotik,routerboard-m33g)
                label_mac=$(mtd_get_mac_binary hard_config 0x10)
                ;;
        zbtlink,zbt-we1326|\
index d3bc85f827ac3263badfed865492c1b0b89bb6d4..511d9deed8f195bda2bfe79eabe2e4f90c3c877a 100755 (executable)
@@ -7,7 +7,7 @@ board_config_update
 board=$(board_name)
 
 case "$board" in
-mikrotik,rb750gr3)
+mikrotik,routerboard-750gr3)
        ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "17"
        ;;
 telco-electronics,x1)
index e745c2c5d495e498faedc7a6a5d11f7864406f93..73140fd7d5498c0b0247864cebf1b061fc778193 100644 (file)
@@ -4,11 +4,19 @@
 . /lib/functions/migrations.sh
 
 board=$(board_name)
+boardonly="${board##*,}"
 
 case "$board" in
+mikrotik,routerboard-750gr3)
+       migrate_leds "^rb750gr3:=$boardonly:"
+mikrotik,routerboard-m11g)
+       migrate_leds "^rbm11g:=$boardonly:"
+mikrotik,routerboard-m33g)
+       migrate_leds "^rbm33g:=$boardonly:"
 netgear,wndr3700-v5)
-       migrate_leds "^wndr3700v5:=wndr3700-v5:"
+       migrate_leds "^wndr3700v5:=$boardonly:"
        ;;
+
 esac
 
 migrations_apply system
index ad10dcbdaa4cc83b892f22e0ce55579637bfa8f1..afb3a52a82e3abd31a1aa717af695b5940a57d15 100755 (executable)
@@ -27,9 +27,9 @@ platform_do_upgrade() {
                        fi
                }
                ;;
-       mikrotik,rb750gr3|\
-       mikrotik,rbm11g|\
-       mikrotik,rbm33g)
+       mikrotik,routerboard-750gr3|\
+       mikrotik,routerboard-m11g|\
+       mikrotik,routerboard-m33g)
                [ -z "$(rootfs_type)" ] && mtd erase firmware
                ;;
        asus,rt-ac65p|\