tools/llvm-bpf: add llvm+clang build suitable for compiling code to eBPF
authorFelix Fietkau <nbd@nbd.name>
Sun, 17 Oct 2021 15:50:53 +0000 (17:50 +0200)
committerFelix Fietkau <nbd@nbd.name>
Wed, 20 Oct 2021 09:35:34 +0000 (11:35 +0200)
Preparation for building packages that ship eBPF code

Signed-off-by: Felix Fietkau <nbd@nbd.name>
toolchain/Config.in
tools/Makefile
tools/llvm-bpf/Makefile [new file with mode: 0644]

index 8ff5438d7991c434005cdf57827f33174e8e2fae..1d230ca22f47c72b82c51c66a8dc9b61b4af5e6e 100644 (file)
@@ -37,6 +37,13 @@ menuconfig TARGET_OPTIONS
 
                  Most people will answer N.
 
+config BUILD_LLVM_BPF
+       bool "Build LLVM toolchain for eBPF" if DEVEL
+       help
+         If enabled, a LLVM toolchain for building eBPF binaries will be built.
+         If this is not enabled, eBPF packages can only be built if the host
+         has a suitable toolchain
+
 
 menuconfig EXTERNAL_TOOLCHAIN
        bool
index f794e57f2ed5eed5d3de4f25f2f454e89e5bcbb3..dc665f6b46c71f0bc2b8c3d1d2721ced11ac00b4 100644 (file)
@@ -35,6 +35,7 @@ tools-$(CONFIG_TARGET_mxs) += elftosb sdimage
 tools-$(CONFIG_TARGET_tegra) += cbootimage cbootimage-configs
 tools-$(CONFIG_USES_MINOR) += kernel2minor
 tools-$(CONFIG_USE_SPARSE) += sparse
+tools-$(CONFIG_BUILD_LLVM_BPF) += llvm-bpf
 
 # builddir dependencies
 $(curdir)/autoconf/compile := $(curdir)/m4/compile
@@ -56,6 +57,7 @@ $(curdir)/isl/compile := $(curdir)/gmp/compile
 $(curdir)/libressl/compile := $(curdir)/pkgconf/compile
 $(curdir)/libtool/compile := $(curdir)/m4/compile $(curdir)/autoconf/compile $(curdir)/automake/compile $(curdir)/missing-macros/compile
 $(curdir)/lzma-old/compile := $(curdir)/zlib/compile
+$(curdir)/llvm-bpf/compile := $(curdir)/cmake/compile
 $(curdir)/make-ext4fs/compile := $(curdir)/zlib/compile
 $(curdir)/meson/compile := $(curdir)/ninja/compile
 $(curdir)/missing-macros/compile := $(curdir)/autoconf/compile
diff --git a/tools/llvm-bpf/Makefile b/tools/llvm-bpf/Makefile
new file mode 100644 (file)
index 0000000..a5ba2a4
--- /dev/null
@@ -0,0 +1,36 @@
+#
+# Copyright (C) 2006-2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=llvm-project
+PKG_VERSION:=13.0.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).src.tar.xz
+PKG_SOURCE_URL:=https://github.com/llvm/llvm-project/releases/download/llvmorg-$(PKG_VERSION)
+PKG_HASH:=6075ad30f1ac0e15f07c1bf062c1e1268c241d674f11bd32cdf0e040c71f2bf3
+
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION).src
+
+HOST_BUILD_PARALLEL:=1
+
+CMAKE_BINARY_SUBDIR := build
+CMAKE_SOURCE_SUBDIR := llvm
+
+include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+CMAKE_HOST_OPTIONS += \
+       -DLLVM_ENABLE_BINDINGS=OFF \
+       -DLLVM_INCLUDE_DOCS=OFF \
+       -DLLVM_INCLUDE_EXAMPLES=OFF \
+       -DLLVM_INCLUDE_TESTS=OFF \
+       -DLLVM_ENABLE_PROJECTS="clang;lld" \
+       -DLLVM_TARGETS_TO_BUILD=BPF \
+       -DCLANG_BUILD_EXAMPLES=OFF
+
+$(eval $(call HostBuild))