add portsentry package
authorFelix Fietkau <nbd@openwrt.org>
Sat, 16 Jul 2005 19:17:17 +0000 (19:17 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 16 Jul 2005 19:17:17 +0000 (19:17 +0000)
SVN-Revision: 1469

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/portsentry/Config.in [new file with mode: 0644]
openwrt/package/portsentry/Makefile [new file with mode: 0644]
openwrt/package/portsentry/ipkg/portsentry.conffiles [new file with mode: 0644]
openwrt/package/portsentry/ipkg/portsentry.control [new file with mode: 0644]
openwrt/package/portsentry/patches/100-conf_location.patch [new file with mode: 0644]
openwrt/package/portsentry/patches/101-postsentry_c.patch [new file with mode: 0644]

index 4d31ead2e0d07f8b8356eaaf6eb30c272203b9cd..bd80720fd1aae2b200b7dd3c95689d031670aa6f 100644 (file)
@@ -70,6 +70,7 @@ source "package/openswan/Config.in"
 source "package/openvpn/Config.in"
 source "package/pmacct/Config.in"
 source "package/portmap/Config.in"
+source "package/portsentry/Config.in"
 source "package/ppp/Config.in"
 source "package/rp-pppoe/Config.in"
 source "package/pptp/Config.in"
index d5cb452a2fe0e6a1e8e3079bb8d36916519287a5..1128f9c8c14bf5a6b825eb7621f254c8a9fad2e1 100644 (file)
@@ -98,6 +98,7 @@ package-$(BR2_PACKAGE_PICOCOM) += picocom
 package-$(BR2_PACKAGE_PMACCT) += pmacct
 package-$(BR2_PACKAGE_POPT) += popt
 package-$(BR2_PACKAGE_PORTMAP) += portmap
+package-$(BR2_PACKAGE_PORTSENTRY) += portsentry
 package-$(BR2_PACKAGE_POSTGRESQL) += postgresql
 package-$(BR2_PACKAGE_PPP) += ppp
 package-$(BR2_PACKAGE_PPTP) += pptp
diff --git a/openwrt/package/portsentry/Config.in b/openwrt/package/portsentry/Config.in
new file mode 100644 (file)
index 0000000..aa85b87
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PORTSENTRY
+       tristate "portsentry"
+       default m if CONFIG_DEVEL
+       help
+         Software for protection against port scans
+         
+         http://sourceforge.net/projects/sentrytools
+         
diff --git a/openwrt/package/portsentry/Makefile b/openwrt/package/portsentry/Makefile
new file mode 100644 (file)
index 0000000..7c5dd3c
--- /dev/null
@@ -0,0 +1,34 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=portsentry
+PKG_VERSION:=1.2
+PKG_RELEASE:=1
+PKG_MD5SUM:=3ebd3618ba9abfea2525e236bd44cebd
+
+PKG_SOURCE_URL:=@SF/sentrytools
+PKG_SOURCE:=$(PKG_NAME)-1.2.tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_beta
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,PORTSENTRY,portsentry,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR) linux
+       touch $@
+
+$(IPKG_PORTSENTRY): 
+       mkdir -p $(IDIR_PORTSENTRY)/usr/bin
+       mkdir -p $(IDIR_PORTSENTRY)/etc
+       cp $(PKG_BUILD_DIR)/$(PKG_NAME).conf $(IDIR_PORTSENTRY)/etc/
+       cp $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_PORTSENTRY)/usr/bin/
+       $(STRIP) $(IDIR_PORTSENTRY)/usr/bin/*
+       $(IPKG_BUILD) $(IDIR_PORTSENTRY) $(PACKAGE_DIR)
+
+mostlyclean:
+       $(MAKE) -C $(PKG_BUILD_DIR) clean
+       rm -f $(PKG_BUILD_DIR)/.built
diff --git a/openwrt/package/portsentry/ipkg/portsentry.conffiles b/openwrt/package/portsentry/ipkg/portsentry.conffiles
new file mode 100644 (file)
index 0000000..9c0810c
--- /dev/null
@@ -0,0 +1 @@
+/etc/portsentry.conf
diff --git a/openwrt/package/portsentry/ipkg/portsentry.control b/openwrt/package/portsentry/ipkg/portsentry.control
new file mode 100644 (file)
index 0000000..bf8fe42
--- /dev/null
@@ -0,0 +1,6 @@
+Package: portsentry
+Priority: optional
+Section: net
+Maintainer: Felix Fietkau <openwrt@nbd.name>
+Source: buildroot internal
+Description: Software for protection against port scans
diff --git a/openwrt/package/portsentry/patches/100-conf_location.patch b/openwrt/package/portsentry/patches/100-conf_location.patch
new file mode 100644 (file)
index 0000000..457c9c8
--- /dev/null
@@ -0,0 +1,11 @@
+--- portsentry/portsentry_config.h     2003-05-23 20:10:13.000000000 +0200
++++ portsentry.old/portsentry_config.h 2005-07-09 21:21:15.000000000 +0200
+@@ -22,7 +22,7 @@
+ /* These are probably ok. Be sure you change the Makefile if you */
+ /* change the path */
+-#define CONFIG_FILE "/usr/local/psionic/portsentry/portsentry.conf"
++#define CONFIG_FILE "/etc/portsentry.conf"
+ /* The location of Wietse Venema's TCP Wrapper hosts.deny file */
+ #define WRAPPER_HOSTS_DENY "/etc/hosts.deny"
diff --git a/openwrt/package/portsentry/patches/101-postsentry_c.patch b/openwrt/package/portsentry/patches/101-postsentry_c.patch
new file mode 100644 (file)
index 0000000..e36bb2a
--- /dev/null
@@ -0,0 +1,12 @@
+--- portsentry/portsentry.c    2003-05-23 20:10:13.000000000 +0200
++++ portsentry.old/portsentry.c        2005-07-09 21:57:24.000000000 +0200
+@@ -1581,8 +1581,7 @@
+ Usage (void)
+ {
+   printf ("PortSentry - Port Scan Detector.\n");
+-  printf ("Copyright 1997-2003 Craig H. Rowland <craigrowland at users dot 
+-sourceforget dot net>\n");
++  printf ("Copyright 1997-2003 Craig H. Rowland <craigrowland at users dot sourceforget dot net>\n");
+   printf ("Licensing restrictions apply. Please see documentation\n");
+   printf ("Version: %s\n\n", VERSION);
+ #ifdef SUPPORT_STEALTH