build,ib: add STRIP_ABI option for manifest
authorPaul Spooren <mail@aparcar.org>
Tue, 16 Mar 2021 01:59:26 +0000 (15:59 -1000)
committerPaul Spooren <mail@aparcar.org>
Tue, 16 Mar 2021 21:00:08 +0000 (11:00 -1000)
The ImageBuilder `make manifest` prints all installed packages. This
function can be used to create a list of package and corresponding
package versions before attempting image creation.

When called with `--strip-abi` OPKG can automatically strip attached
ABIVersions from package names. Make this function accessible for the
ImageBuilder by adding a `STRIP_ABI` variable.

Signed-off-by: Paul Spooren <mail@aparcar.org>
target/imagebuilder/files/Makefile

index 2d1e040286ab0ec43be7798cb11db4af35dc7532..aeae98aacdb0094594b874f4e4c021cc09decf72 100644 (file)
@@ -54,6 +54,7 @@ Print manifest:
 
        make manifest PROFILE="<profilename>" # override the default target profile
        make manifest PACKAGES="<pkg1> [<pkg2> [<pkg3> ...]]" # include extra packages
+       make manifest STRIP_ABI=1 # remove ABI version from printed package names
 
 endef
 $(eval $(call shexport,Helptext))
@@ -129,7 +130,7 @@ _call_manifest: FORCE
        mkdir -p $(TARGET_DIR) $(BIN_DIR) $(TMP_DIR) $(DL_DIR)
        $(MAKE) package_reload >/dev/null
        $(MAKE) package_install >/dev/null
-       $(OPKG) list-installed
+       $(OPKG) list-installed $(if $(STRIP_ABI),--strip-abi)
 
 package_index: FORCE
        @echo >&2