Convert ipkg to new packaging style
authorNicolas Thill <nico@openwrt.org>
Wed, 18 May 2005 09:28:51 +0000 (09:28 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 18 May 2005 09:28:51 +0000 (09:28 +0000)
SVN-Revision: 921

openwrt/package/ipkg/Makefile
openwrt/package/ipkg/ipkg.control [deleted file]
openwrt/package/ipkg/ipkg/ipkg.control [new file with mode: 0644]

index 464670af16f548464587cf410d1dcb138eda41ab..a0ec84a069b435894bb8fa809736699797ac1520 100644 (file)
@@ -12,70 +12,54 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
-IPKG_IPKG:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-IDIR_IPKG:=$(PKG_BUILD_DIR)/idir/$(PKG_NAME)
-INFO_IPKG:=$(IPKG_STATE_DIR)/info/$(PKG_NAME).list
+include $(TOPDIR)/package/rules.mk
 
-$(DL_DIR)/$(PKG_SOURCE):
-       $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+$(eval $(call PKG_template,IPKG,ipkg,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(PKG_BUILD_DIR)/.prepared: $(DL_DIR)/$(PKG_SOURCE)
-       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       $(PATCH) $(PKG_BUILD_DIR) ./patches
-       touch $(PKG_BUILD_DIR)/.prepared
-
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
-       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
                ./configure \
-               --target=$(GNU_TARGET_NAME) \
-               --host=$(GNU_TARGET_NAME) \
-               --build=$(GNU_HOST_NAME) \
-               --program-prefix="" \
-               --program-suffix="" \
-               --prefix=/usr \
-               --exec-prefix=/usr \
-               --bindir=/usr/bin \
-               --datadir=/usr/share \
-               --includedir=/usr/include \
-               --infodir=/usr/share/info \
-               --libdir=/usr/lib \
-               --libexecdir=/usr/lib \
-               --localstatedir=/var \
-               --mandir=/usr/share/man \
-               --sbindir=/usr/sbin \
-               --sysconfdir=/etc \
-               $(DISABLE_NLS) \
-               $(DISABLE_LARGEFILE) \
-       );
+                 --target=$(GNU_TARGET_NAME) \
+                 --host=$(GNU_TARGET_NAME) \
+                 --build=$(GNU_HOST_NAME) \
+                 --program-prefix="" \
+                 --program-suffix="" \
+                 --prefix=/usr \
+                 --exec-prefix=/usr \
+                 --bindir=/bin \
+                 --datadir=/usr/share \
+                 --includedir=/usr/include \
+                 --infodir=/usr/share/info \
+                 --libdir=/lib \
+                 --libexecdir=/lib \
+                 --localstatedir=/var \
+                 --mandir=/usr/share/man \
+                 --sbindir=/usr/sbin \
+                 --sysconfdir=/etc \
+                 $(DISABLE_LARGEFILE) \
+                 $(DISABLE_NLS) \
+       )
        touch $(PKG_BUILD_DIR)/.configured
 
-$(PKG_BUILD_DIR)/$(PKG_NAME): $(PKG_BUILD_DIR)/.configured
+$(PKG_BUILD_DIR)/.built:
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC=$(TARGET_CC)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               install
+       touch $(PKG_BUILD_DIR)/.built
 
-$(IPKG_IPKG): $(PKG_BUILD_DIR)/$(PKG_NAME)
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_IPKG) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-       mkdir -p $(IDIR_IPKG)/bin
-       cp -a $(PKG_BUILD_DIR)/.libs/ipkg-cl $(IDIR_IPKG)/bin/ipkg
-       $(STRIP) $(IDIR_IPKG)/bin/*
-       mkdir -p $(IDIR_IPKG)/lib
-       cp -a $(PKG_BUILD_DIR)/.libs/libipkg.so* $(IDIR_IPKG)/lib/
-       $(STRIP) $(IDIR_IPKG)/lib/*
-       mkdir -p $(PACKAGE_DIR)
+$(IPKG_IPKG):
+       install -d -m0755 $(IDIR_IPKG)/bin
+       cp -fpR $(PKG_INSTALL_DIR)/bin/ipkg-cl $(IDIR_IPKG)/bin/ipkg
+       install -d -m0755 $(IDIR_IPKG)/lib
+       cp -fpR $(PKG_INSTALL_DIR)/lib/libipkg.so.* $(IDIR_IPKG)/lib/
+       $(RSTRIP) $(IDIR_IPKG)
        $(IPKG_BUILD) $(IDIR_IPKG) $(PACKAGE_DIR)
-
-$(INFO_IPKG): $(IPKG_IPKG)
-       $(IPKG) install $(IPKG_IPKG)
-
-source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.prepared
-compile: $(IPKG_IPKG)
-install: $(INFO_IPKG)
-
-clean:
-       rm -rf $(PKG_BUILD_DIR) $(IPKG_IPKG)
diff --git a/openwrt/package/ipkg/ipkg.control b/openwrt/package/ipkg/ipkg.control
deleted file mode 100644 (file)
index 1a1bf31..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-Package: ipkg
-Section: base
-Priority: required
-Essential: yes
-Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
-Source: buildroot internal
-Description: lightweight package management system
- ipkg is the Itsy Package Management System, for handling
- installation and removal of packages on a system. It can
- recursively follow dependencies and download all packages
- necessary to install a particular package.
- .
- ipkg knows how to install both .ipk and .deb packages.
- .
- ipkg is intended to serve the same functions (and more) for
- Familiar that dpkg and apt serve for Debian, (while taking
- up much less space).
-
diff --git a/openwrt/package/ipkg/ipkg/ipkg.control b/openwrt/package/ipkg/ipkg/ipkg.control
new file mode 100644 (file)
index 0000000..1a1bf31
--- /dev/null
@@ -0,0 +1,18 @@
+Package: ipkg
+Section: base
+Priority: required
+Essential: yes
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Description: lightweight package management system
+ ipkg is the Itsy Package Management System, for handling
+ installation and removal of packages on a system. It can
+ recursively follow dependencies and download all packages
+ necessary to install a particular package.
+ .
+ ipkg knows how to install both .ipk and .deb packages.
+ .
+ ipkg is intended to serve the same functions (and more) for
+ Familiar that dpkg and apt serve for Debian, (while taking
+ up much less space).
+