some bugfixes and additions for the default compile target
authorFelix Fietkau <nbd@openwrt.org>
Thu, 1 Jun 2006 01:06:23 +0000 (01:06 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 1 Jun 2006 01:06:23 +0000 (01:06 +0000)
SVN-Revision: 3886

openwrt/package/rules.mk

index 4a8d947161ccf5ac3db667f05849800857ff165b..fe16a18f987057981830c555d1d959f6df782a86 100644 (file)
@@ -235,10 +235,8 @@ define Build/Compile/Default
                $(TARGET_CONFIGURE_OPTS) \
                CC=$(TARGET_CC) \
                CROSS="$(TARGET_CROSS)" \
-               PREFIX="$$(IDIR_$(1))" \
-               EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+               EXTRA_CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include" \
                ARCH="$(ARCH)" \
-               DESTDIR="$$(IDIR_$(1))" \
                $(1);
 endef