add dependencies from the NEEDS variable to ipkg/control
authorNicolas Thill <nico@openwrt.org>
Sun, 28 May 2006 22:58:07 +0000 (22:58 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 28 May 2006 22:58:07 +0000 (22:58 +0000)
SVN-Revision: 3831

openwrt/package/rules.mk

index 4999974900f0894807d88f154279a34233df93e5..9b551728b3a97e7ad84d84763083a6b9a6daf0f7 100644 (file)
@@ -134,7 +134,8 @@ define BuildPackage
        mkdir -p $$(IDIR_$(1))/CONTROL
        echo "Package: $(1)" > $$(IDIR_$(1))/CONTROL/control
        echo "Version: $(VERSION)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Depends: $$(IDEPEND_$(1))" >> $$(IDIR_$(1))/CONTROL/control
+       #FIXME: there should be a better way to do it
+       D="$$(IDEPEND_$(1))"; D="$$$${D}$$$${D:+, }$$(INEED_$(1))"; echo "Depends: $$$${D}" >> $$(IDIR_$(1))/CONTROL/control
        echo "Source: $(SOURCE)" >> $$(IDIR_$(1))/CONTROL/control
        echo "Section: $(SECTION)" >> $$(IDIR_$(1))/CONTROL/control
        echo "Priority: $(PRIORITY)" >> $$(IDIR_$(1))/CONTROL/control